Eine frohe Adventszeit wünscht Apfeltalk!

ISTTEXT, ISTZAHL ... in Numbers

JoeCas

Erdapfel
Mitglied seit
24.07.19
Beiträge
1
Hallo alle zusammen,

da ich nun selbst am Excel-Import für ISTZAHL, ISTTEXT gescheitert bin und im I-Net keine Lösungen zu finden sind, habe ich selbst etwas herumgetüftelt und folgendes gefunden:

Ausgang:
Die Spalte A beinhaltet entweder Text oder eine Zahl und die Spalte B beinhaltet einen Multiplikator, der unabhängig von Spalte A festgelegt wird.
A1 = "Text"
B1 = 2
A2 = 100
B2 = 3​
Formel:
=WENN(ISTFEHLER(A1/1);A1;A1*B1)
Ergebnis: "Text"
=WENN(ISTFEHLER(A2/1);B1;A1*B1)
Ergebnis: "300"​

Somit lässt sich in eine beliebige Formel sehr einfach eine Abfrage nach dem Schema "ISTTEXT/ISTZAHL" einbauen.

Viel Spaß!