1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

"... ist ein Programm, das [...] geladen wurde" deaktivieren

Dieses Thema im Forum "macOS & OS X" wurde erstellt von leibnizkeks, 20.02.09.

  1. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Hi Leute,

    ich habe ein Problem, das mich immer und immer wieder nervt.

    Jedes mal wenn ich eine beliebige Datei aus dem Internet lade - zb per Safari, Firefox, Cyberduck etc - und diese öffnen möchte, fragt mich OSX jedes mal, ob ich die Datei wirklich öffnen möchte. Die genaue Meldung ist: "... ist ein Programm, das aus dem Internet geladen. Möchten sie es wirklich öffnen?".

    Prinzipiell ist das nicht schlimm, wenn ich 1 mal auf "Öffnen" klicken muss. Richtig mies ist es allerdings, dass diese Abfrage nur maximal alle 10 Sekunden kommt. Das heißt, dass ich zu erst 10 Sekunden warten muss, bevor ich die nächste Datei öffne. Noch schlimmer ist es, wenn ich 10 Dateien auf einmal öffnen möchte: die Meldung bezieht sich immer nur auf -eine- Datei und nicht auf alle. Es wird also nur eine Datei geöffnet, so dass ich wieder weitere 10 Sekunden waten muss, bevor ich die nächste öffnen kann...

    Hat jemand eine Idee, wie ich diese Meldung abschalten kann?!

    Gruß & Danke
     
  2. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Das geht nicht.

    Die Meldung kommt auch nur, wenn man ein Programm herunterlädt und nicht bei jeder Datei.

    Ich habe es gerade ausprobiert, ich muss nicht 10 Sekunden warten, bei mir erscheinen sofort alle Fenster.

    Du hast also ein anderes Problem.
     
  3. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    >> Die Meldung kommt auch nur, wenn man ein Programm
    >> herunterlädt und nicht bei jeder Datei.

    Das stimmt wohl - aber zumindest bei jeder .php oder .html Datei. Wenn ich also per cyberduck einen Ordner mit 20 Dateien runterlade und diese zusammen öffnen möchte, muss ich ewig lange warten, bevor alle geöffnet sind.

    >> ich muss nicht 10 Sekunden warten, bei mir erscheinen sofort alle Fenster.
    >> Du hast also ein anderes Problem.

    Das ist allerdings merkwürdig...

    Gruß
     
  4. maelcum

    maelcum Jonathan

    Dabei seit:
    03.10.08
    Beiträge:
    82
    Hi,

    die Meldung die Du beschreibst ist die Quarantäne des OS X. Jeder Datei die nicht von einer Netzwerkfreigabe heruntergeladen wird, wird eine Flag angehängt, damit der Mac Dich auf die potentielle Gefahr hinweist.

    Man kann dieses Flag im Terminal mit dem Befehl "xattr -d com.apple.quarantine <Pfad/Dateiname>" entfernen.

    Ein intelligenter Zeitgenosse hat ein kleines Applescript geschrieben, dass man als "Ordneraktion" an einen Ordner binden kann. In meinem Fall an den Downloads-Ordner. Was auch immer darin landet (und das sind halt per Default die Downloads aus "dem Internet") wird automatisch um das Flag bereinigt. Und damit kommt auch keine Meldung mehr.

    Das Script wäre hier zu finden: http://henrik.nyh.se/2007/10/lift-the-leopard-download-quarantine

    (Jetzt habe ich gerade die Seite nochmals aufgerufen um sicherzugehen, dass sie noch existiert, und siehe da: Dort steht alles viel besser beschrieben...)

    Ich hoffe es hilft.

    Die 10 Sekunden-Pause die Du beschreibst, habe ich noch nie erlebt...
     
    countrydarkness gefällt das.
  5. naich

    naich Pommerscher Krummstiel

    Dabei seit:
    22.11.08
    Beiträge:
    3.059
    Die Quarantaine ist aber auch zuetwas nutze. So wird zb angezeigt, dass eine (präparierte) Datei mit der Endung mp3 doch ein Programm ist.

    Also ich würde das Script nicht auf meinen ganzen Downlods-Ordner anwenden.

    Aber dass man auch html-Dateien mit diesem Schutz versieht, ist tatsächlich etwas übertrieben (vor allem wenn man diese dateien nur mit einem texteditor öffnen möchte...
     
  6. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Es lassen sich auch global spezifische Dateitypen von der Quarantäne ausnehmen. Wie das geht, steht z. B. hier (Links beachten).
     
  7. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    >> Man kann dieses Flag im Terminal mit dem Befehl
    >> "xattr -d com.apple.quarantine <Pfad/Dateiname>" entfernen.

    Da spuckt mir das Terminal eine Fehlermeldung aus: No such xattr: com.apple.quarantine

    >> Das Script wäre hier zu finden:
    >> http://henrik.nyh.se/2007/10/lift-th...oad-quarantine

    Sehr witzig eigentlich, aber 1. geht es nicht, wegen oben genanntem Fehler und 2. sind Unterordner nicht davon betroffen. Wenn ich also in Downloads einen Ordner mit 20 Dateien herunterlade, dann wird die Ordneraktion nicht auf diese Dateien ausgeführt.

    >> Wie das geht, steht z. B. hier (Links beachten).

    Das habe ich auch bereits probiert - aber ohne Erfolg. Ich habe den String "public.php-script" hinzugefügt und im entsprechenden Pfad (/Library/Preferences/com.apple.DownloadAssessment.plist) gespeichert...

    Merkwürdigerweise sind das alles - nur für mich!? - nicht funktionierende Lösungen.

    Gruß
     
  8. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Lt. Anleitung gehört die plist in deine Benutzer-Library (also ~/Library), nicht in die globale /Library. Außerdem ist danach ein Neu-Einloggen von Nöten. Bei mir klappt das jedenfalls vorzüglich.
     
  9. maelcum

    maelcum Jonathan

    Dabei seit:
    03.10.08
    Beiträge:
    82
    Dann ist keine Quarantäne-Info gesetzt.
    Das lässt sich mit "xattr -l <Pfad/Dateiname>" auch schnell mal überprüfen. Sollte die Datei per Safari heruntergeladen worden sein, steht dort beispielsweise:
    com.apple.quarantine: 0000;49a17be4;Safari;|com.apple.Safari

    In diesem Fall führt "xattr -d ..." auch nicht zur Fehlermeldung sondern entsorgt diese Info kommentarlos, was ein weiteres "xattr -l ..." auch zeigt.

    Sorry dass ich nicht helfen konnte.
     
  10. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    >> Lt. Anleitung gehört die plist in deine Benutzer-Library
    >> (also ~/Library), nicht in die globale /Library.

    Tatsache - das klappt wunderbar! Ich danke dir.

    Gruß & Danke allen
     
  11. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Noch einmal eine kurze Rückfrage bei der Gelegenheit - ich kenne mich mit den UNIX Dateisystem und den Abkürzungen nicht wirklich aus.
    Wie lauten denn die Angaben für das absolute/global root Verzeichniss und für das Benutzer Verzeichniss? Die Tilde ~ steht also anscheinend für das Benutzer Verzeichniss?

    Gruß & Danke
     
  12. bezierkurve

    bezierkurve Danziger Kant

    Dabei seit:
    12.06.05
    Beiträge:
    3.861
    Kurz gesagt:
    • Die Tilde bezeichnet deinen Home-Ordner, ~/Library ist somit deine benutzerspezifische Library.
    • / ist die Wurzel deines Startvolumens, /Library somit die globale, für alle Benutzer gültige Library.
    • /System gehört dem System, dort schreibt man als Anwender nichts rein.
     
  13. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Ich habe gerade Snow Leopard installiert und stehe nun wieder vor dem gleichen Problem...

    Ich bin wieder nach der Anleitung von http://mymacinations.com/2008/02/06/changing-the-systems-default-settings-for-html-files-safe/ vorgegangen und es scheint auch funktioniert zu haben. Nun wird zwar keine Meldung a la "... ist ein Programm, das [...] geladen wurde" angezeigt, aber ich kann heruntergeladene Dateien immer nur einzeln öffnen! Es ist also so, als ob die Meldung noch aktiv ist - sie wird nur nicht angezeigt. Wenn ich also 20 Dateien vie FTP herunterlade (zb .html oder .php) dann kann ich diese nicht zusammen öffnen, sondern -muss- jede einzelnen öffnen!

    Hat jemand unter Snow Leopard (10.6.1) das gleiche Problem? Kennt bereits jemand eine Lösung?!

    Gruß & Danke
     
  14. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Bitte, leibnizkeks (schmecken besonders gut), kannst du, wenn du zitierst, die dafür vorgesehen Tags verwenden - ganz einfach oben in das kleine Texticon (4. von rechts) klicken erscheint von selbst, oder du schreibst es händisch hin. Aber wie ich sehe bist du ja kein Neerd.
    So wie ich auch nicht. :)

    Danke dir
    die Salome
     
    leibnizkeks gefällt das.
  15. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Sorry, vergesse ich immer wieder :)

    Und hat schon Erfahrungen damit gesammelt?

    Gruß
     
  16. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Jetzt, 2 Wochen später, wollte ich doch noch einmal pushen.

    Hat jemand unter Snow Leopard (10.6.1) das gleiche Problem? Kennt bereits jemand eine Lösung?!

    Gruß & Danke
     
  17. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Und drei Monate später bin ich mal so dreist und pushe erneut:

    Gruß
     
  18. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Kann ich nicht feststellen. Ich öffne nie 20 Dateien auf einmal – ich würde sie ja gar nicht lesen können, der gesamte Schreibtisch wäre voller Dateien. ich öffne jede Datei einzeln und bearbeite sie. 20 Dateien kann ich ohnehin nicht gleichzeitig bearbeiten.
    Aber vielleicht habe ich dein Problem auch nicht richtig verstanden.
    Tut mir leid, dass mir nichts Hilfreiches einfällt. Wen die Tipps von bezierkurve und maelcum nicht geholfen haben …
    Vielleicht solltest du die Rechte zurücksetzen. von Der DVD starten und nach der Sprachauswahl unter Dienstprogramme/Kennwort zurücksetzen auswählen. Im selben Fenster gibt es auch die Möglichkeit "Zugriffsrechte zurücksetzen". Das Kennwort musst du nicht ändern.
    salome
     
  19. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Einfach das Skript der Ordneraktion ein bisserl modifiziert:
    Code:
    [SIZE="-2"]on adding folder items to thisFolder after receiving addedItems
        repeat with anItem in addedItems
            set anItem's contents to (quoted form of POSIX path of (anItem as alias))
        end repeat
        set AppleScript's text item delimiters to " "
        do shell script "/usr/bin/find -x " & (addedItems as text) & " \\
        -exec /usr/bin/xattr -d com.apple.quarantine {} + 2>/dev/null;"
    end adding folder items to
    [/SIZE]
    
    An den Downloadordner angepappt - Laube steht.
     
  20. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182

Diese Seite empfehlen