1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Irssi auf Remote Server im Screen und UTF-8

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von ChristianK, 27.03.07.

  1. ChristianK

    ChristianK Thurgauer Weinapfel

    Dabei seit:
    29.06.05
    Beiträge:
    996
    Hi,

    ich verzweifle derzeit an meinem Irssi ... der läuft auf einem Linux Server und ich connecte per Terminal und SSH. Der Irssi selber läuft im Screen.
    Nur irgendwie bekomme ich die Umlaute einfach nicht gebacken o_O

    - Terminal ist UTF-8 und kann Umlaute!
    - SSH kann Umlaute
    - screen läuft mit UTF8 Support
    - Irssi mag net ...

    Schon versucht:
    Code:
    /set term_charset UTF-8
    Code:
    /set term_charset UTF-8
    /set recode_autodetect_utf8 ON
    /set recode_fallback UTF-8
    /set recode ON
    /set recode_out_default_charset UTF-8
    /set recode_transliterate ON
    hat alles zu nichts geführt ... weiss jemand Rat?

    Danke!
     
  2. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Ich hab in der .bash_profile noch ein export LANG="de_DE.UTF-8" stehen
     
  3. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Hast Du es in irssi schon mit
    Code:
    /SET term_type utf-8
    versucht?

    Bzw. ergänze evt. in Deiner ~/.screenrc die Zeile
    Code:
    defutf8 on
    falls Du screen nicht immer mittels screen -U aufrufst.
    Gruß Pepi
     
    #3 pepi, 28.03.07
    Zuletzt bearbeitet: 28.03.07
  4. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Und ich sollte meine eigenen ~/.*rc files aufmerksamer lesen. Gut dokumentiert wären sie ja... und drum hab ich den Artikel bei Mac OS X Hints mit dem Titel A guide to help set up Terminal auch wieder gefunden. Da ist bestimmt was brauchbares drinnen.
    Gruß Pepi
     
  5. ChristianK

    ChristianK Thurgauer Weinapfel

    Dabei seit:
    29.06.05
    Beiträge:
    996
    also:

    /set term_type utf-8 geht nicht da meine version vom Irssi zu neu ist.

    Ich habe es bisher mit dem Putty unter Windows hinbekommen mit folgendem Befehl:

    /set term_charset UTF-8
    /set recode_out_default_charset iso-8859-1
    /set recode_transliterate ON

    Da scheinbar der Server auf iso-8859-1 läuft ... die selben Settings gehen aber im Terminal leider nicht mehr :(

    Edith: jetzt schon ... habe in den Fenstereinstellungen vom Terminal noch den Haken bei "Nicht-ASCII Zeichen in ESCAPE Sequenz umwandeln" entfernen müssen ... jetzt tippt er meine Umlaute schon mal richtig ... nur die Darstellung der Umlaute von anderen sind noch nicht korrekt
     
    #5 ChristianK, 28.03.07
    Zuletzt bearbeitet: 28.03.07

Diese Seite empfehlen