1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

[Inkscape] Lässt sich nicht mehr starten

Dieses Thema im Forum "Grafikbearbeitung & Layout" wurde erstellt von mpk, 11.01.08.

  1. mpk

    mpk Gast

    Hallo,

    der Titel verrät mein Problem schon. Inkscape startet nicht mehr! Ich klicke doppelt auf das Symbol. Inkscape-Icon erscheint im Dock und X11-Icon erscheint. Dann passiert nichts mehr. :(

    Kann mir jemand bitte helfen??? Inkscape benutze ich fast täglich!!!

    mpk
     
  2. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Hast du schon 0.45.1 heruntergeladen? Da sollte der Leopard-Bug repariert sein (falls das Problem mit Leopard zusammenhaengt und du nicht Tiger benutzt).

    http://inkscape.org/
     
  3. mpk

    mpk Gast

    Ja, in der Tat ich benutze Leopard!

    Also gibt es eine extra Version für Leopard, in dem Bugs behoben wurden? Auf dieser Seite (http://inkscape.org/download/?lang=de) steht aber:
    Jedoch gibt es nur eine "Mac OS X Tiger und Leopard — Universal.dmg"! Ich glaube, dass ich diese Version schon mal installiert habe.

    Inkscape startet einfach nicht bzw. es startet schon, doch nicht die Bearbeitungsfläche!

    Was mache ich denn nun? Ich benötige Inkscape fast jeden Tag! Nachdem ich mir einen neues MB gekauft habe, hab ich Inkscape installiert und schon einmal gestartet! Nun funktioniert es nicht mehr!

    Hilfe!!
    mpk
     
  4. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Ich musste, um Inkscape starten zu koennen, ein kleines Skript anpassen, moment, ich schau mal.
     
  5. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Aalso.

    Such Inkscape im Finder.

    Dann mach das Terminal auf, gib ein "cd " (Mit Leerzeichen hintendran), und zieh das Inkscape-Icon ins Terminalfenster. Drueck dann Enter.

    Dann kopierst du das folgende und gibst es ein.

    Code:
    cat >script <<THISISANEOF
    #!/bin/sh
    #
    # Author: Aaron Voisine <aaron@voisine.org>
    # Inkscape Modifications: Michael Wybrow <mjwybrow@users.sourceforge.net>
    
    CWD="`dirname \"$0\"`"
    
    
    ps -wx -ocommand | grep -e '[X]11' > /dev/null
    if [ "$?" != "0" -a ! -f ~/.xinitrc ]; then
        echo "rm -f ~/.xinitrc" > ~/.xinitrc
        sed 's/xterm/# xterm/' /usr/X11R6/lib/X11/xinit/xinitrc >> ~/.xinitrc
    fi
    
    cp -f "$CWD/bin/getdisplay.sh" /tmp/
    rm -f /tmp/display.$UID
    #open-x11 /tmp/getdisplay.sh || \
    #open -a XDarwin /tmp/getdisplay.sh || \
    echo ":0" > /tmp/display.$UID
    open /Applications/Utilities/X11.app
    
    while [ "$?" == "0" -a ! -f /tmp/display.$UID ]; do
        sleep 1
    done
    export DISPLAY="`cat /tmp/display.$UID`"
    
    ps -wx -ocommand | grep -e '[X]11' > /dev/null || exit 11
    
    # Old OS X version specific test:
    #
    #VERSION=`/usr/bin/sw_vers | grep ProductVersion | cut -f2 -d'.'`
    #if [ "$VERSION" -eq "4" ]; then
    
    # Warn the user about time-consuming generation of fontconfig caches.
    test -f ~/.inkscape/.fccache-new || exit 12
    
    
    BASE="`echo "$0" | sed -e 's/\/Contents\/Resources\/script/\//'`"
    cd "$BASE"
    exec "$CWD/bin/inkscape" "$@"
    THISISANEOF
    
    Danach versuchst du nochmal, Inkscape zu starten - achtung, kann sehr lange dauern.
     
    #5 Xjs, 12.01.08
    Zuletzt bearbeitet: 12.01.08
  6. mpk

    mpk Gast

    Vielen Dank für die Hilfe, Xjs!

    Jedoch funktioniert Inkscape immer noch nicht!
    Vielleicht liegt es an der vorletzten Terminalzeile:
    Bitte helft mir weiter!! Ich weiß auch nicht man was man noch ausprobieren könnte.

    Ich habe schon mal in der Zwischenzeit habe ich versucht mit Hilfe von Darwin Inkscape für Windows auf dem Mac laufen zu lassen, doch das war nicht akzeptabel! Dann habe ich Inkscape portable heruntergeladen: ist genau das Gleiche passiert wie mit der normalen Version.

    Was kann man da nur machen??
    mpk :-[:-[
     

    Anhänge:

  7. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Ah, ich weiss, woran es liegt... ich hab "EOF" verwendet, und EOF war in der Datei schon benutzt.

    Neuer Code (korrigiere es auch gleich oben):

    Code:
    cat >script <<THISISANEOF
    #!/bin/sh
    #
    # Author: Aaron Voisine <aaron@voisine.org>
    # Inkscape Modifications: Michael Wybrow <mjwybrow@users.sourceforge.net>
    
    CWD="`dirname \"$0\"`"
    
    
    ps -wx -ocommand | grep -e '[X]11' > /dev/null
    if [ "$?" != "0" -a ! -f ~/.xinitrc ]; then
        echo "rm -f ~/.xinitrc" > ~/.xinitrc
        sed 's/xterm/# xterm/' /usr/X11R6/lib/X11/xinit/xinitrc >> ~/.xinitrc
    fi
    
    cp -f "$CWD/bin/getdisplay.sh" /tmp/
    rm -f /tmp/display.$UID
    #open-x11 /tmp/getdisplay.sh || \
    #open -a XDarwin /tmp/getdisplay.sh || \
    echo ":0" > /tmp/display.$UID
    open /Applications/Utilities/X11.app
    
    while [ "$?" == "0" -a ! -f /tmp/display.$UID ]; do
        sleep 1
    done
    export DISPLAY="`cat /tmp/display.$UID`"
    
    ps -wx -ocommand | grep -e '[X]11' > /dev/null || exit 11
    
    # Old OS X version specific test:
    #
    #VERSION=`/usr/bin/sw_vers | grep ProductVersion | cut -f2 -d'.'`
    #if [ "$VERSION" -eq "4" ]; then
    
    # Warn the user about time-consuming generation of fontconfig caches.
    test -f ~/.inkscape/.fccache-new || exit 12
    
    
    BASE="`echo "$0" | sed -e 's/\/Contents\/Resources\/script/\//'`"
    cd "$BASE"
    exec "$CWD/bin/inkscape" "$@"
    THISISANEOF
    
    
     
  8. mpk

    mpk Gast

    Ich hab's versucht: bis auf eine Kleinigkeit war alles gleich und es hat nicht funktioniert. Nachdem ich den Text ins Terminal eingefügt hatte wurde er komplett aufgelistet und am Ende stand:
    Code:
    ...
    >THISISANEOF
    Wenn man dann enter gedrückt hat, kam der gleiche Fehler wie oben.#

    Bitte helft mir!!

    mpk
    P.S.: Danke für die Hilfe, Xjs!
     
  9. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Machen wir's anders. Kopier die angehaengte Datei auf deinen Desktop, mach das Terminal auf wie vorhin und gib folgendes ein:

    Code:
    cp ~/Desktop/bla.txt ./script
    Dann kannst du die Datei vom Desktop loeschen.
     

    Anhänge:

    • bla.txt
      Dateigröße:
      1,1 KB
      Aufrufe:
      166
  10. mpk

    mpk Gast

    Okay, hab alles so ausgeführt, wie du es beschrieben hast - nichts hat sich geändert! Anbei noch ein Screenshot!

    Aber wie kann es denn sein, dass Inkscape kurz nach der Installation noch funktioniert hat? Stört vielleicht ein anderes Programm Inkscape??

    Ich hoffe - trotz aller Misserfolge -, dass ich(/wir) Inkscape ans Laufen bekommen!

    mpk

    P.S.: Ich würde mich ja mal beim Inkscape-Forum anmelden, doch das kann ich nicht, weil beim Registrieren immer der Fehler auftritt, dass meine E-Mail-Adresse falsch ist!
     

    Anhänge:

  11. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Ok, jetzt kam ja keine Fehlermeldung. Kannst du Inkscape jetzt immer noch nicht starten?
     
  12. mpk

    mpk Gast

    Ich kann Inkscape immer noch nicht starten! Seit meinem letzten Beitrag habe ich den Mac unverändert gelassen! Keine Reaktion: X11 und Inkscape gestartet und im Dock!

    mpk

    P.S.: Ich muss jetzt leider weg, doch morgen früh schaue ich wieder hier im Forum vorbei! :( Falls du bahnbrechende Erkenntnisse gewinnst kannst du mir auch eine E-Mail schreiben an: ms_av@web.de.
     
  13. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Hmm... Beim ersten Start braucht es sehr lang, ich glaube, etwa fuenf Minuten...
     
  14. mpk

    mpk Gast

    Ja, dass hattest du ja gesagt, aber ich habe mindestens fünf Minuten gewartet.

    Immer das Gleiche: Inkscape startet, danach startet dann X11. Das X11 - bash (??) Fenster öffnet sich und mehr passiert nicht!
     
  15. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Dass erst Inkscape startet, dann X11, dann das xterm-Fenster, ist okay.

    Starte Inkscape mal und lass es ueber Nacht oder so stehen.
     
  16. mpk

    mpk Gast

    Aber was soll das den bringen??

    Ich denke, dass X11 völlig in Ordnung ist. Der Fehler liegt bei Inkscape, da Gimp bei mir (wenn auch etwas langsam) funktioniert, und für Gimp wird ja auch X11 benötigt.

    Ich habe heute morgen noch einmal die Prozedur ausgeführt, die du mir gestern vorgeschlagen hast. Erst habe ich mit Hilfe eines Programms Inkscape komplett deinstalliert und dann noch mal neu draufgezogen und dann deine Scripts ausgeführt - mit Neustarts: keine Veränderung!

    mpk
     
  17. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    hmmmm. Dann weiss ich ehrlich gesagt auch nicht mehr weiter.

    Vielleicht fragst du mal im Inkscape-Forum nach, oder jemand anders weiss Abhilfe. Wie gesagt: bei mir funktioniert Inkscape nach Ausfuehren des dritten Skriptes (natuerlich nur, wenn man vorm Ausfuehren des Skripts die dritte Datei herunterlaedt).
     
  18. mpk

    mpk Gast

    Welches dritte Skript? Könntest du mich vielleicht nochmals aufklären? Oder meinest du die Datei "bla.txt"?

    @inkscape - Forum
    Okay, ich melde mich mal im Inkscape Forum an.

    Trotzdem, vielen Dank, Xjs
    mpk ;)
     
  19. Xjs

    Xjs Prinzenapfel

    Dabei seit:
    04.10.07
    Beiträge:
    547
    Das dritte Skript ist einfach "cp ~/Desktop/bla.txt ./script"; wobei, wandel das mal ab in
    Code:
    rm ./script; cp ~/Desktop/bla.txt ./script
    - natuerlich nachdem du im Terminal "cd " eingegeben hast und das Inkscape-Verzeichnis reingezogen.

    Die dritte Datei ist bla.txt.
     
  20. mpk

    mpk Gast

    So, ich habe mich mal im Inkscape Forum angemeldet und meinen Beitrag hinterlassen. Einer meinte, dass ich mal einen Bug melden sollte!

    Dann habe ich erst einmal nach ähnlichen Bugs gesucht und bin auf diesen hier gestoßen: https://bugs.launchpad.net/inkscape/+bug/176058

    Meinst du der hat was mit meinem Problem zu tun?
    mpk
     

Diese Seite empfehlen