1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

@INC in Perl auf 10.4.11 editieren

Dieses Thema im Forum "OS X-Developer" wurde erstellt von macgroupie, 16.03.09.

  1. macgroupie

    macgroupie Rheinischer Krummstiel

    Dabei seit:
    11.02.07
    Beiträge:
    385
    Hallo

    Ich möchte ein Perl-Script nutzen, welches LWP::UserAgent.pm verwendet. Das scheint nicht von Haus aus in 10.4.11 dabei zu sein, weswegen ich mir nach einigem Googeln das Modul besorgt habe. Es liegt jetzt in einem Pfad unterhalb von /opt.

    Nun ist mein Problem, dass mein Script sich immer darüber beschwert, dass das Modul innerhalb von @INC nicht zu finden sei. Wie füge ich den Pfad denn hinzu? Wie das geht, konnte ich mir leider weder mit Google noch mit der SuFu hier selbst beantworten. Weiss es jemand? Das use lib-Statement mit dem entsprechenden Pfad einfach dem Script hinzuzufügen, funktioniert leider nicht. Syntaktisch scheint alles richtig, denn es gibt dazu keine Fehlermeldung. Die bezüglich @INC aber schon noch. :(

    Danke für alle Tipps!
     
  2. Cyrics

    Cyrics Neuer Berner Rosenapfel

    Dabei seit:
    01.04.05
    Beiträge:
    1.975
    wie hast du denn das Perl-Modul installiert?!
    Bei richtiger Installation sollte es einfach direkt funktionieren.

    Soll heissen: perl Makefile.PL
    make
    sudo make install

    oder dergleichen. Dazu sollte man die mitgelieferten REAMEs lesen.

    Weitere Möglichkeit ist die Platzierung der Moduldatei in das lokale Verzeichnis deines Perl-Skripts.

    Viel Spaß mit Perl. Ist eine interessante Sprache, die fast alles kann, auch vom eigenen Programmierer missverstanden werden ;)
     

Diese Seite empfehlen