1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

import im phpmyadmin

Dieses Thema im Forum "PHP & Co." wurde erstellt von dewey, 14.09.08.

  1. dewey

    dewey Gewürzluiken

    Dabei seit:
    01.05.06
    Beiträge:
    5.732
    hallo,

    ich habe xampp und dort kann ich zwar im localhost/phpmyadmin datenbanken als .sql exportieren allerdings schlägt mir auch nach wiederholter neu installation von xampp der import der gleichen .sql die ich zuerst erfolgreich exportiert habe fehl.

    könnt ihr euch vorstellen an was es liegt?

    fehlermeldung bekomme ich diese:

    [​IMG]

    bzw. wenn ich über sql/dateiimport gehe folgende:

    Code:
    import.php: Missing parameter: import_type [URL="http://localhost/phpmyadmin/Documentation.html#faqmissingparameters"] (FAQ 2.8)[/URL]
    import.php: Missing parameter: format [URL="http://localhost/phpmyadmin/Documentation.html#faqmissingparameters"] (FAQ 2.8)[/URL]
    
    lg, dewey
     
  2. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Wie groß ist die SQL Datei?
     
  3. dewey

    dewey Gewürzluiken

    Dabei seit:
    01.05.06
    Beiträge:
    5.732
  4. Samsas Traum

    Samsas Traum Pommerscher Krummstiel

    Dabei seit:
    24.04.08
    Beiträge:
    3.030
    Häufigste Lösung ist wenn die FAQ Lösungen nichts bringen, dass du phpmyadmin mit http aufgerufen hast und nicht https. Das passiert mir zB fast immer ;)
     
  5. dewey

    dewey Gewürzluiken

    Dabei seit:
    01.05.06
    Beiträge:
    5.732
    ich ruf mit http auf, weil https nicht geht. ausserdem komm ich ja in den phpmyadmin aber eben das importieren geht nicht.
     
  6. Samsas Traum

    Samsas Traum Pommerscher Krummstiel

    Dabei seit:
    24.04.08
    Beiträge:
    3.030
    Hm, ich glaub phpmyadmin akzeptiert dein Cookie aber nicht wenn du nicht per https drin bist !?
    (schon ewig her das ich mich damit auseinandergesetzt habe)

    EDITH: aber die FAQ tipps haste schon probiert oder ?
    2.8 I get "Missing parameters" errors, what can I do?

    Here are a few points to check:

    * In config.inc.php, try to leave the $cfg['PmaAbsoluteUri'] directive empty. See also FAQ 4.7.
    * Maybe you have a broken PHP installation or you need to upgrade your Zend Optimizer. See PHP Bugs: #31134: foreach() semantics broken between 4.3.9 and 4.3.10.
    * If you are using Hardened PHP with the ini directive varfilter.max_request_variables set to the default (200) or another low value, you could get this error if your table has a high number of columns. Adjust this setting accordingly. (Thanks to Klaus Dorninger for the hint).
    * In the php.ini directive arg_separator.input, a value of ";" will cause this error. Replace it with "&;".
    * If you are using Hardened-PHP, you might want to increase request limits.
    * The directory specified in the php.ini directive session.save_path does not exist or is read-only.
     
  7. dewey

    dewey Gewürzluiken

    Dabei seit:
    01.05.06
    Beiträge:
    5.732
    bin bis jetzt immer ohne https reingegangen und hat immer funktioniert ;) hab gar nicht gewusst das man das machen könnte mit ssl :D
     
  8. dewey

    dewey Gewürzluiken

    Dabei seit:
    01.05.06
    Beiträge:
    5.732
    ok mit safari kann ich die seite mit https aufrufen. aber trozdem importiere ich und bekomm dann nicht mal ne fehlermeldung sondern bin dann einfach wieder am homescreen von localhost/phpmyadmin....ohne das was importiert wurde...
     
  9. dewey

    dewey Gewürzluiken

    Dabei seit:
    01.05.06
    Beiträge:
    5.732
    habs jetzt in windows getestet, dort funktioniert es :( wieso unter os x nicht?
     
  10. Irgendein Held

    Irgendein Held Oberösterreichischer Brünerling

    Dabei seit:
    17.06.07
    Beiträge:
    714
    Es hängt definitiv nicht mit SSL zusammen.
     
  11. Katzenfutter

    Katzenfutter Kaiser Wilhelm

    Dabei seit:
    16.12.06
    Beiträge:
    174
    @ Dewey

    Nutze vielleicht das "Terminal-Programm" von MySQL:
    im Terminal folgendes eingeben (die Worte in eckigen Klammern durch Deine Daten ersetzen):
    mysql -u[user] -p[passwort] [datenbank] < [xyz].sql
    Der Befehl bedingt allerdings, dass Du vorher [datenbank] angelegt hast.
    Kannst Du auch direkt per folgendem Befehl im Terminal erledigen:
    mysql -u[user] -p[passwort] -> ENTER
    dann
    create database [database]

    (Bei XAMPP musst Du evtl. das Tool "mysql" im Ordner "[XAMPP-Verz.]/bin/mysql" aufrufen...)

    Edith:
    Das Obige bedingt auch, dass Du Zugriff via Terminal oder SSH/SFTP hast...
     
    dewey gefällt das.
  12. dewey

    dewey Gewürzluiken

    Dabei seit:
    01.05.06
    Beiträge:
    5.732
    danke, werd ich dann mal ausprobieren :)

    edit: du hast jetzt 2 bobbel mehr :p
     
  13. Maluku

    Maluku Finkenwerder Herbstprinz

    Dabei seit:
    10.05.08
    Beiträge:
    464
    Gross und Kleinschreibung mal überprüft?

    Kommt mir immer in den Sinn, wenn jemand sagt: geht unter Windows aber unter Mac OS X/Unix/Linux nicht.
     

Diese Seite empfehlen