1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ich raffs nidd ... *seltsames Problem*

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von Tengu, 31.03.07.

  1. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    Hi Leute!

    Also ich raffs nidd... Das Terminal unter MacOS ärgert mich.

    - Da wären seltsame Dinge. Ich stelle es auf UTF 8 und trotzdem gibt es keine Umlaute. Es stelle es auf ISO Latin 1.... auch nichts. Mhh... ich weiß zwar, dass man keine Umlaute verwenden soll, aber eintippen sollte man die doch können. Oder zumindest wenn man auf die externe Festplatte eines anderen zugreift... Kann doch nidd sein... ist die Option tot oder wat?

    - die "Rechtsentfernen" Taste hab ich eingestellt. Dumm ist nur... das Terminal will die nicht.

    - Leerzeichen... werden auch nicht korrekt dargestellt.

    - Dann versuche ich irgendwie den Befehl zum Ausdrucken einer Datei zu finden... nix. Die Linux Befehle gehen nidd.

    - Dann dachte ich... he auf die guten alten Zeiten. Lädste mal irssi, gibts auch für Mac: irssi kommt mit Proxy Support. MacIrssi nicht. Auch mal wieder seltsam.


    Gibt es eines der Probleme Abhilfe oder ist das normal? :eek:

    Gruß,
    Tengu
     
  2. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.398
    Null Ahnung, ob dir das was weiterhilft, aber nachdem dir niemand Qualifizierteres was sagt -
    Ich hatte das Problem, daß meine Änderung der Hintergrundfarbe (unwichtig, aber ich wollte es, um das Terminalfenster schneller hinter diversen anderen Fenstern erkennen zu können) nie dauerhaft war, bis ich merkte, daß man da unten auf "als Standard verwenden" anklicken muß, sonst bleibt es auf das aktuelle fenster beschränkt.
    Vielleicht ist es ja was Ähnliches?
    Mit Umlauten hatte ich übrigens, ohne daß ich je was verändert hätte, nie Probleme.
    Nebenbei: Die Cracks hier im Forum können dir eher helfen, wenn du mehr Angaben machst zu Hardware und Betriebssystemsversion.
     
  3. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Es wäre hilfreich wenn Du noch ein paar mehr Angaben machen könntest wann und wo genau welches "Problem" auftritt.

    Mit den Umlauten gibt es sicherlich kein prinzipielles Problem, das liegt wohl an einer Deiner Einstellungen. Nimm mal das Hakerl bei "Escape non-ASCII Characters" weg und schau was dann passiert. Bei Dateinamen mit "seltsamen" Zeichen hilft oft auch die Tab Vervollständigung von Dateinamen. Das kennst Du bestimmt auch von Linux.

    Was hast Du wo wie für Forward-Delete eingestellt? Wie verhält es sich und was hättest Du gerne das es tut?

    Leerzeichen? Ähm, hääää?

    Ich weis nicht womit Du unter Linux gedruckt hast, aber bei mir sind lp und lpr beide in /usr/bin vorhanden.

    Was spricht dagegen irssi selbst zu compilieren? Alternativ kann man irssi natürlich auch bequem per fink oder MacPorts installieren. (In beiden Package Managern ist Version 0.8.10a verfügbar.)
    Gruß Pepi
     
  4. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Probier mal folgendes in ~/.bash_profile

    # Show umlaut characters correctly and use color for file types.
    alias ls='ls -vwG'

    LC_ALL=en_US.UTF-8
    export LC_ALL

    LANG=en_US.UTF-8
    export LANG
     
  5. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    Hallo zum Abend ...

    Das sind für mich mal sogar globale Probleme. Alsp pepi... die treten nirgendwo nich auf.

    Also das Verzeichnis bei mir lokal "Java Workspace" habe ich probehalber erstellt. Laut Terminal existiert es nicht. Das "JavaWorkspace" ist ein anderes. Beide wären ja eigentlich für Eclipse oder so. Naja ... angesprochen werden per Terminal kann das Verzeichnis mit Leerzeichen nicht. Ich weiss nicht mal warum... es wird nur angezeigt. Ein Leerzeichen hat in meiner Vorstellung von ASCII eine feste repräsentierende Zahl...

    Das Terminal ist standartmäßig "immer" und überall auf Western ISO, hat also ü, ä, ö theoretisch im Zeichensatz geladen. Das wird anscheinenend nicht beherzigt.
    Eingaben wie öäü werden nicht genommen. Es passiert nix. Trotz eingeladenen Zeichensatzes.
    @MacMark: Das hab ich so schon umgestellt. :( Da ändert sich genau nix. Das kann nicht sein. Also es widerspricht der Konfig...

    Irssi per fink ist möglich. Kann ich glaube ich so nutzen. Wusste gar nicht, dass das da existiert ;).

    Ein problem gelöst, juhu^^.

    gn8
     
  6. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Es funktioniert bei allen OS X-Macs so, die ich bislang hatte. Ich gehe davon aus, daß bei Deiner Instanz etwas nicht normal ist.
     
  7. Skeeve

    Skeeve Pomme d'or

    Dabei seit:
    26.10.05
    Beiträge:
    3.121
    Viel Errfahrung mit UNIX und dem Terminal hast Du noch nicht, nehme ich an, oder?

    Wahrscheinlich hast Du sowas eingegeben wie
    Code:
    ls Java Workspace
    stimmt's?

    Versuch es doch mal so, wie Du es schon in Deinem Zitat oben gemacht hast:
    Code:
    ls "Java Workspace"
    es geht auch
    Code:
    ls 'Java Workspace'
    oder
    Code:
    ls Java\ Workspace
    Space ist halt ein Trenner. Der muß maskiert werden, wenn er irgendwo hinzugehört. ";" übrigens auch.
     
  8. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    April, April


    Nöhhh... doch nidd. *musste sein*


    Klare Kiste Skeeve... :) Aber nö... das isses nidd. So neu ist mir das nich... Das wär jetzt der Hammer gewesen :). Tengu nicht doof!

    Code:
    echo Zu Dienen und zu Beschuetzen.
    
    test -r /sw/bin/init.sh && . /sw/bin/init.sh
    
    CLASSPATH=.:/Library/Java/Extensions/Prog1Tools.zip:$CLASSPATH; 
    export CLASSPATH
    
    # Show German characters correctly and use color for file types.
    
    LC_ALL=en_US.UTF-8
    export LC_ALL
    
    LANG=en_US.UTF-8
    export LANG
    alias ls='ls -vwG'
    
    # Your previous .profile  (if any) is saved as .profile.dpsaved
    # Setting the path for DarwinPorts.
    
    export PATH=/opt/local/bin:/opt/local/sbin:$PATH
    
    Ich habe hier mal meine aktuelle .profile hingeschrieben... Könnte da ein Fehler sein? Also irgendwie kanns ja nur da sein, oder?

    Aber das mit den Farben ist schon mal hübsch... ^^. Eine andere Problemlösung hätt ich gedacht wär iTerm gewesen. Aber das hat das selbe Problem. Das muss also an der .profile liegen. Mein ich...
     
  9. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Hast Du Terminal.app neugestartet nach den neuen Eintragungen?
     
  10. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    Klar... aber den Alias musste ich ausklammern, weil der glaub ich syntaktisch falsch war.
    Code:
    -bash: ./sw/bin/init.sh: No such file or directory
    : command not found
    : command not found
    ': not a valid identifier
    : command not found
    
    hmmh... könnte auch daran liegen... grr. Seit Neustem meine Startmeldung beim Terminal laden...
     
  11. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Du solltest Dich mal mit absoluten und relativen Pfaden auseinandersetzen. (Ja, ich habe geschaut, in Deinem Zitat ist kein Space zwischen . und /sw/bin/init.sh!)
    Was hast Du mit dem Fink angestellt?
    Gruß Pepi
     
  12. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    omg fink... das ist doch das Teil, das mir irssi installiert hat? Was hab damit gemacht? Weiß nicht. Den Eintrag hat wohl der Finkcommander so gemacht. Der wird wissen, was er tut, oder?

    Absolute und relative Pfade... nie gehört. Gleich mal nachschlagen. Mal die blöde Frage... was soll ich ändern? *keine Ahnung mehr hab* :oops:
     
  13. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Ok, bevor hier noch was schlimmes mit Deinem System passiert eigne Dir zunächst mal Terminal Basics an! Die Forumssuche hilft bei der Linkfindung.

    Nur mit dem Finkcommander isses ja nicht getan, Du solltest Dich auch mit fink auseinandersetzen um zu wissen was er tut und wie das funktionioniert. Fink selsbt ist eh ein Ding welches rundherum nur sehr selten zu Problemen führt, im Gegensatz zu MacPorts. (Anderer Ansatz, andere Probleme.)

    Was für eine Standardshell verwendest Du und wo ist Deine fink Installation?
    Gruß Pepi
     
  14. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    Ich nutze eine BaSh, natürlich die unter Darwin. Ob man da das Terminal nutzt, oder iTerm ist egal - das ist das Gleiche.

    finkcommander ist doch nur das grafische Interface für fink. Da ich lange BSD genutzt habe, kenne ich darwinports mittlerweile gut genug. Also es ist unwahrscheinlich, dass es etwas Banales wie eine fehlende Pfadangabe ist.
    Ich gehöre auch nicht zu den Leuten, die für absolute und relative Pfadangaben irgendeinen Fachausdruck brauchen. ;)

    Code:
    echo Zu Dienen und zu Beschuetzen
    # ein kleiner Willkommenssatz
    
    test -r /sw/bin/init.sh && ./sw/bin/init.sh
    # Zugriffsrechte liegen bei "mir" und sind auf rw- für mich. 
    
    CLASSPATH=.:/Library/Java/Extensions/Prog1Tools.zip:$CLASSPATH; 
    export CLASSPATH
    # Java Klassen... f. d. Uni
    
    # Show German characters correctly and use color for file types.
    LC_ALL=en_US.UTF-8
    export LC_ALL
    
    LANG=en_US.UTF-8
    export LANG
    
    # Your previous .profile  (if any) is saved as .profile.dpsaved
    # Setting the path for DarwinPorts.
    # blabla
    
    export PATH=/opt/local/bin:/opt/local/sbin:$PATH
    
    Die Fink Installation ist bei /sw/bin. Also im bin liegen die Binaries. init.sh ist dort auch vorhanden. Wird trotzdem nicht geladen.
    Rechte sind i. O., d. h. sowohl repariert, als auch gesetzt.

    Also MacPorts funktioniert bei mir wenigstens und gescheite Parallelstrukturen. naja... fink wollte ich halt testen. Schadet ja keinem.

    Somit für mich vollkommen unerklärlich:
    Code:
    Zu Dienen und zu Beschuetzen
    -bash: ./sw/bin/init.sh: No such file or directory
    : command not found
    : command not found
    ': not a valid identifier
    : command not found
    
    So begrüßt mich das Terminal...init.sh ist da aber! was den rest betrifft... alles Qwatsch^^. Das ist so nicht!
     
  15. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Ich verstehe ja Spaß wenn man ihn mir erklärt...

    poste bitte mal:
    ls -la /sw/bin/init.sh
    cat ~/.profile
    cat ~/.bash_profile
    cat ~/.bashrc

    Offenbar derkragelt sich Deine Shell Initialisierung beim ausführen irgendeiner Datei. Und wie schon erwähnt, wenn man per . sourced, dann muß dazwischen ein Leerzeichen sein was in Deinem Zitat nicht ist, weshalb ich davon ausgehe, daß der Aufruf von ./sw/bin/init.sh als relativer Pfad interpretiert wird, was erklären würde warum es nicht gefunden wird.
    Das "': not a valid identifier" läßt auf ein Problem mit Quotes oder deren Schachtelung schließen.
    Gruß Pepi
     
  16. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    ls -la /sw/bin/init.sh
    -rwxrwxrwx 1 tengu admin 3796 Jun 9 2006 /sw/bin/init.sh
    An mangelnden Rechten sollte es nicht liegen :)
    Die Datei ist älter als das Gerät?!^

    cat ~/.profile

    also derzeit:
    Mal ne blöde Frage... darf da ein Semikolon stehen beim Classpath?


    Die letzten beiden Dateien habe ich gar nicht. Nur .bash_history gibts noch.

    Bin ich echt zu doof? :-c
     
  17. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Du hast sogar zuviele Rechte an der Datei, das kann durchaus ebenfalls zu Problemen führen, korrekt wäre:
    Code:
    $ ls -la /sw/bin/init.sh
    -rw-r--r--   1 root  admin  3796 Nov 18  2005 /sw/bin/init.sh
    
    Schau mal nach ob Deine init.sh Datei ident ist mit meiner.
    Code:
    $ md5 /sw/bin/init.sh 
    MD5 (/sw/bin/init.sh) = 941149739839700639227f0a1bb24ae0
    Der ; bei der CLASSPATH Variablenzuweisung beende so wie ich das sehe nur das Shell Statement, sollte also keine Probleme verursachen. Du kannst ihn ebenso entfernen, was auch kein Problem sein sollte.

    Zu Debugging Zwecken kannst Du auch mal schauen wo die Fehler auftreten. Ergänze dazu einfach mal am Anfang und am Ende der ~/.profile ein
    Code:
    echo ~/.profile BEGIN
    und ein
    Code:
    echo ~/.profile END
    Gruß Pepi
     
    Tengu gefällt das.
  18. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    In die von Fink erstellte Zeile
    Code:
    test -r /sw/bin/init.sh && [COLOR="Red"].[/COLOR][COLOR="SeaGreen"]/[/COLOR]sw/bin/init.sh
    
    der .profile, die Du in #14 und #16 gepostet hast, gehört aber eigentlich zwischen dem Punkt (rot) und dem Slash (grün) ein Leerzeichen. Hat pepi oben in #11 schon gepostet. Kannst Du das mal ändern?
     
    #18 quarx, 03.04.07
    Zuletzt bearbeitet: 03.04.07
  19. Tengu

    Tengu Apfel der Erkenntnis

    Dabei seit:
    05.02.07
    Beiträge:
    721
    Ja... *Kopf einzieh*
    nach stundenlanegm Rumprobieren fiel auf, dass das Semikolon weg muss... Es ist leider nicht verständlich, warum da drüber liegende Bereiche auch betroffen waren. The Ghost In The Maschine... Ich weiß es nicht.

    Danke aber auf jeden Fall...
     
  20. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.897
    Profies soll man nie zu viele Tips auf einmal geben, daher kriegst du nur einen:
    Code:
    export PATH=[COLOR="Blue"]"[/COLOR]/opt/local/bin:/opt/local/sbin:$PATH[COLOR="Blue"]"[/COLOR]
    Näheres zu den Mirakeln des Doppelpunkts unter "man bash"
     
    Tengu gefällt das.

Diese Seite empfehlen