1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

.htaccess wird ignoriert

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von .mitro, 17.09.05.

  1. .mitro

    .mitro Allington Pepping

    Dabei seit:
    14.09.04
    Beiträge:
    193
    Hi,

    nachdem ich die letzten Stunden tüftelnd, aber ohne Lösung verbracht habe und kurz vor dem Verzweifeln steh, wende ich mich vertrauensvoll an euch.

    In meiner Webdesign-Testumgebung werden seit Neuestem .htaccess-Files vollkommen ignoriert. Funktioniert hat das Ganze erst unlängst und ich kann mich nicht erinnern, irgendetwas absichtlich umkonfiguriert zu haben.

    Folgendes Szenario:
    - AllowOverride steht auf All (in der httpd.conf)
    - ein virtueller Server ist angelegt, mit AccessFileName .htaccess
    - Rechte der .htaccess-Datei habe ich überprüft

    Wenn ich das modRewrite-Modul einbinde, den Apache neu starte und in die .htaccess irgendeinen syntaktisch inkorrekten Schwachsinn reinschreibe, bekomme ich nicht den üblichen Internal Server Error, sondern einfach gar nichts. Ebenso wenig funktionieren logischerweise meine RewriteRules.

    Ich habe die Konfiguration auch mit meinem zweiten Rechner verglichen und konnte keine nennenswerten Unterschiede erkennen.

    Das ganze läuft auf einem OS X Standard Apache mit der Version 1.3.33.

    Hat irgendjemand einen Tip, in welche Richtung ich weiter recherchieren könnte?

    Vielen Dank und liebe Grüße

    .mitro
     
  2. iPoe

    iPoe Pomme Etrangle

    Dabei seit:
    07.03.05
    Beiträge:
    910
    hallo,

    du hast in der apache2.conf (apache2) oder in der httpd.conf (alter apache) einen eintrag wie diesen erstellt?

    die .htaccess datei mit htpasswd2 oder htpasswd erstellt?

    und in der .htaccess den richtigen pfad zur passwort datei eingestellt?

    dann sollte es klappen...

    lg
    iPoe
     
  3. NLS

    NLS Querina

    Dabei seit:
    11.02.07
    Beiträge:
    181
    Hallo

    Hab seit mehreren Tagen ein ähnliches Problem und kann es einfach nicht beheben. Ich bin langsam am Verzweifeln. :(

    Da ich php-Applikationen mit dem Zend Framework schreibe, benötigt man .htaccess-Dateien - doch diese werden bei mir vollkommen ignoriert. Das ganze hat seinerzeit mit Mac OS Tiger funktioniert - doch seit Leopard hab ich keine Chance mehr. Es geht einfach nicht mehr.

    Die vorhandene .htaccess-Datei hat folgenden Inhalt:
    Code:
    deny from all
    RewriteEngine on
    RewriteRule .* index.php
    Allein die erste Zeile dieser Datei sollte die gesamte Webseite sofort sperren, man dürfte also gar nichts sehen. Doch es funktioniert nicht.

    Dazugehörige httpd.conf (die relevanten Teile davon - und ja, ich bearbeite die richtige Datei, editiere ich andere Sachen, werden die Änderungen alle übernommen):
    Code:
    #
    ServerRoot "/usr"
    
    #
    # DocumentRoot: The directory out of which you will serve your
    # documents. By default, all requests are taken from this directory, but
    # symbolic links and aliases may be used to point to other locations.
    #
    DocumentRoot "/Users/name/Sites"
    #
    <Directory />
    #    Options FollowSymLinks
    #    AllowOverride None
        Options FollowSymLinks
        AllowOverride All
        Order deny,allow
        Deny from all
    </Directory>
    #
    # This should be changed to whatever you set DocumentRoot to.
    #
    #<Directory "/Library/WebServer/Documents">
    <Directory "/Users/name/Sites">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        Deny from all
    </Directory>
    
    #
    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    #
    <IfModule dir_module>
        DirectoryIndex index.html
    </IfModule>
    
    #
    # The following lines prevent .htaccess and .htpasswd files from being 
    # viewed by Web clients. 
    #
    <FilesMatch "^\.([Hh][Tt]|[Dd][Ss]_[Ss])">
        Order allow,deny
        Deny from all
        Satisfy All
    </FilesMatch>
    
    <Directory "/Library/WebServer/CGI-Executables">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
    </Directory>
    Ich hoffe dass mir jemand helfen kann. Suchfunktion, Google etc. konnten es alle nicht.
     

Diese Seite empfehlen