1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

.htaccess ignoriert

Dieses Thema im Forum "PHP & Co." wurde erstellt von creative7even, 03.09.05.

  1. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    hallo!

    ich habe das problem, das die .htaccess - dateien in meinem webverzeichnis (lokal) ignoriert werden.

    in der .htaccess (Rechtevergabe: 744, also der Webserver sollte sie lesen können) steht folgendes:

    Code:
    ErrorDocument 404 ./error404.html
    die fehlermeldung wenn ich ein nicht vorhandenes dokument aufrufen möchte ist die:

    Code:
    Not Found
    
    The requested URL /test.html was not found on this server.
    
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    
    Apache/1.3.33 Server at powerbook.local Port 80
    also definitiv nicht error404.html.

    httpd.conf sieht so aus:

    Code:
    ...
    
    AccessFileName .htaccess
    
    ...
    <Directory />
        Options FollowSymLinks
        AllowOverride All
    </Directory>
    
    <Files ~ "^\.([Hh][Tt]|[Dd][Ss]_[Ss])">
        Order allow,deny
        Deny from all
        Satisfy All
    </Files>
    wo liegt der hund begraben?!
     
    #1 creative7even, 03.09.05
    Zuletzt bearbeitet: 03.09.05
  2. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Versuch dat mal so:

    ErrorDocument 404 /error404.html

    Ohne Punkt

    Schöne Grüße

    Andre
     
  3. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Danke, aber das hab ich auch schon probiert.
    Mittlerweile hab ich (oder www) zugriff auf die htaccess datei (überprüft mit FancyIndexing).
    Ändern kann ich die errordocuments nur in der httpd.conf. Die
    htaccess-datei wird dabei weiterhin ignoriert (auch wenn ich die entsprechenden Zeilen in der httpd.conf auskommentiere).
    Zugriffsrechte habe ich überprüft, auch die zeichenkodierung (mit vi)

    lg.c7.
     
  4. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    ok, jetzt hab ichs!

    wozu error_logs doch gut sind :mad: :mad: :mad:

    neben httpd.conf gibt es noch andere konfigurationsfiles - die musste ich auch noch ändern. der verweis darauf findet sich in der httpd.conf (verweis auf user und group)

    c7.
     
  5. steffen12

    steffen12 Erdapfel

    Dabei seit:
    29.05.09
    Beiträge:
    1
    hallo zusammen

    ich habe genau das selbe problem. ich möchte das modul mod_rewrite benutzen, jedoch wird meine .htacces datei werden komplett ignoriert. auch normale anzeige von fehlerseiten laufen nicht, mit dem gleichen ergebnis wie bei meinem vorposter.

    ich habe in der httpd.conf folgenden eintrag:
    Code:
    <Directory />
        Options FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
    </Directory>
    
    ...
    
    <Directory "/Library/WebServer/Documents/meineSeite">
        Options All
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    
    welche weiteren conf dateien muss ich noch wie anpassen?

    bei mir steht in der httpd.conf
    Code:
    User www
    Group www

    besten dank für eure hilfe, ich verzweifle hier nun schon fast 2 tage :(
     
  6. _linx_

    _linx_ Kleiner Weinapfel

    Dabei seit:
    04.01.09
    Beiträge:
    1.125
    Mal ne kurze Frage, wieso interessiert ihr euch für die http.conf wenn ihr mod_rewrite benutzen wollt? Bzw. wieso ändert ihr da was? Es lässt mic darauf schliessen, dass ihr dedicated-Server nutzt, korrekt?

    Wenn ihr die http.conf im Ausgangszuständ belassen hättet, würde es gehen…
     
  7. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    hi!

    findest du in der httpd.conf einen Eintrag der etwa so aussieht?
    Code:
    Include /private/etc/apache2/other/*.conf
    
    - möglicherweise überschreibt ein anderes config-file »AllowOverride«...
    - Permissions prüfen - (hardcore temporär auf 0777 damit der HTTP Server auch zu 100% lesen kann)
    - und .htaccess hat zwei »ss«

    lg
     
  8. Johannes.mac

    Johannes.mac Horneburger Pfannkuchenapfel

    Dabei seit:
    12.04.09
    Beiträge:
    1.407
    Schwierigkeiten mit mod_rewrite

    Ich plage mich nun schon Stunden mit dem Versuch herum, Wordpress 2.9 mittels .htaccess und mod_rewrite zu sinnvolleren URLs zu verhelfen.

    Das ganze lauft lokal auf meinem Mac. Wordpress ist in der Lage, die .htaccess zu schreiben, aber die betreffenden Links zeigen ins leere.
    Ich habe bereits in der etc/apache2/httpd.conf den AllowOverride-Befehl auf All gesetzt und meine etc/apache2/users/<meinname>.config sieht so aus:
    Code:
    <Directory "/Users/johannes/Sites/">
        Options Indexes Multiviews FollowSymLinks
        AllowOverride AuthConfig All
        Order allow,deny
        Allow from all
    </Directory>
    
    Kann mir hier jemand helfen, wie ich das zum laufen bringe? Ich weiß, da sind ein paar richtig schlaue Köpfe im Forum :) … Danke!
     
  9. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Setze AllowOverride auf All:
    Code:
    AllowOverride All
    
    ein Mischen von Keywords ist laut Apache Doc's nur mit den Keywords Options FileInfo AuthConfig Limit möglich.
    Nicht vergessen den Apache auch neu zu starten (damit die Änderungen der httpd.conf geladen werden).
    Um zu Testen ob die .htaccess-Datei auch verarbeitet wird, kann man durch Einfügen einer beliebige Zeichenkette (bspw: "12345" -> diese Direktive exisitiert nicht) versuchen einen Error 500 zu erzwingen...
    Ggf noch die Dateirechte prüfen - bzw. Dateinamen .htaccess auf Typos.
     
  10. Johannes.mac

    Johannes.mac Horneburger Pfannkuchenapfel

    Dabei seit:
    12.04.09
    Beiträge:
    1.407
    Leider funktioniert es immer noch nicht, nachdem ich obiges auf All gesetzt habe. Allerdings scheint eine beliebige Zeichenkette in der .htaccess keine Auswirkungen zu haben — die angeforderte URL wird nicht auf dem Server gefunden.
    Die Dateirechte der gesamten Dateien von Wordpress sind für die Gruppe _www auf lesen/schreiben/ausführen gestellt, Wordpress ist auch in der Lage, die .htaccess selbsttätig zu ändern.
     
  11. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Verwendest Du den mitgelieferten Apache2 (httpd.conf befindet sich dann üblicherweise in /etc/apache2/httpd.conf)?
    Wenn ja: wie siehts mit weiteren config-Dateien aus? Eventuell könnten die Settings durch später geparste Dateien wieder umgeschrieben werden -> siehe dazu die Ordner /etc/apache2/other/* oder /etc/apache2/users/*.
     
    Johannes.mac gefällt das.
  12. Johannes.mac

    Johannes.mac Horneburger Pfannkuchenapfel

    Dabei seit:
    12.04.09
    Beiträge:
    1.407
    Problem gelöst

    Ich konnte das Problem nun lösen.
    Meine httpd-userdir.conf (in private/etc/apache2/extras/) wurde zwar korrekt ausgeführt, doch die Wildcard in
    Code:
    Include /private/etc/apache2/users/*.conf
    sorgte dafür, dass es einen Konflikt zwischen meiner user.conf und der Sicherungsdatei ~user.conf gab. :-[

    Darauf bin ich aber erst gekommen, nachdem ich in der httpd-userdir.conf meine user.conf nochmal separat eingebunden habe und mich danach (als es funktionierte) fragte, warum die Wildcard das nicht erledigt. Und dann habe ich halt doch noch mal in den users Ordner gesehen… :)

    Danke für die Hilfe, manchmal sieht man den Wald vor lauter Bäumen nicht.
     

Diese Seite empfehlen