1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Home-Netzwerk Mac/OSX -> PC/XP -> Kabelmodem

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Altan078, 28.07.08.

  1. Altan078

    Altan078 Fuji

    Dabei seit:
    26.01.08
    Beiträge:
    38
    Hallo,

    habe folgende Konfiguration:

    * Kabelmodem fürs Internet (ohne WLAN)
    * XP-PC mit zwei Netzwerkkarten
    * Macbook (Leopard)

    Verkabelung:
    Macbook - |Ethernet-Kabel| - XP-PC - |Ethernet-Kabel| - Kabelmodem

    Der PC hängt am Kabelmodem und kommt problemlos ins Internet. Jetzt wollte ich es so einrichten, dass ich mein Macbook einfach per LAN-Verbindung zum PC mittels "Internet Connection Sharing" ins Internet route. Eine Netwerkverbindung zwischen den beiden Rechnern incl. Ping und Datentransfer funktioniert tadellos. Nur das ICS will nicht gehen.

    Ich habe schon alles befolgt, was auf http://www.netzwelt.de/news/72939-der-rechner-als-router-so.html
    steht, sprich:
    * Die LAN-Verbindung zum Router unter den XP-"Netzwerkverbindungen" für die LAN-Verbindung zum Macbook freigegeben
    * IP XP-PC: 192.168.0.1, Subnet 255.255.255.0
    * IP Macbook: 192.168.0.2, Subnet 255.255.255.0
    * "Router" Macbook (Netzwerk-Systemeinstellungen): 192.168.0.1
    * DNS-Server Macbook: leer; (hatte dort testweise auch schon einmal Die DNS-Serveradressen des Kabelmodems, welche ich durch "ipconfig /all" beim XP-Rechner ermittelt hatte, eingetragen. Half nicht)

    Zur weiteren Info für eventuelle XP-Cracks in diesem Forum: Der RPC-Locator-Dienst beim XP-PC läuft. Außerdem habe ich alle Firewalls auf dem XP-Rechner (Zone-Alarm und XP-Firewall) und die Leopard-Firewall beim Macbook deaktiviert.

    Leider funktioniert es immer noch nicht. Kann mir jemand weiterhelfen? Ich bin mir nicht sicher, ob ich alle Einstellungen unter Leopard korrekt getroffen habe.

    Grüße
     
  2. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Du musst die Einstellung für die Freigabe bei der LAN Verbindung zum Mac freigeben. Das ist die interne Schnittstelle (also dein Netz). Dazu musst du auch die DNS Server eintragen (die sollten unter XP schon stehen, bei den Eigenschaften der Netzwerkkarte zum Kabelmodem) Was ist das denn für ein Kabelrouter? Oder ist das nur ein Kabelmodem? Hast du eine feste IP für deinen XP Rechner bekommen (dann wirst du auch die DNS Server bekommen haben)
     
  3. rst

    rst Gala

    Dabei seit:
    01.11.07
    Beiträge:
    50
    Hallo

    Versuch doch mal die Netzwerkeinstellungen so zu verändern:
    PC <-> Modem
    Per DHCP eine dynamische IP adresse vergeben.
    (192.168.1.1 - 192.168.1.254)
    Als Subnetzmaske jeweils 255.255.255.0

    Dann der Netzwerkkarte im PC ein IP Adresse vergeben ebenso beim Mac.
    (192.168.2.1 - 192.168.2.254)
    Als Subnetzmaske jeweils 255.255.255.0, weil ja nur die letzte Zahl deinen Adressbereich darstellt.

    Also hast du zwei Netzwerke (da du ja auch zwei Adapter hast)

    Modem <-> PC (Netzwerk 1 mit 192.168.1.x)
    PC <-> MAC (Netzwerk 2 mit 192.168.2.x)

    Jetzt in die Netzwerkumgebung beim XP Rechner gehen und die beiden Adapter durch Sharing verbinden.

    Gruß rst

    P.S.
    Die Einstellungen der Firewall solltest du aber wieder einschalten, man weiß nie, wer so gerade im Netz unterwegs ist. ;)
     
  4. Altan078

    Altan078 Fuji

    Dabei seit:
    26.01.08
    Beiträge:
    38
    Hallo,

    ja, genau, es ist ein Kabelmodem.
    Was meinst Du muss ich noch freigeben? Am Mac oder am PC? Am PC hab ich schon die LAN-Verbindung zum Kabelmoden für die LAN-Verbindung zum Mac freigegeben.

    Habe jetzt beim MAC die beiden DNS-Server eingetragen, die ich mit "ipconfig /all" sehe:

    Code:
    Verbindungsspezifisches DNS-Suffix:
    Beschreibung. . . . . . . . . . . : NVIDIA nForce MCP Networking Contr
    
    Physikalische Adresse . . . . . . : 00-12-1F-D4-5F-4C
    DHCP aktiviert. . . . . . . . . . : Ja
    Autokonfiguration aktiviert . . . : Ja
    IP-Adresse. . . . . . . . . . . . : 72.56.214.177
    Subnetzmaske. . . . . . . . . . . : 255.255.254.0
    IP-Adresse. . . . . . . . . . . . : fe80::211:2fff:fec8:7f3b%5
    Standardgateway . . . . . . . . . : 91.65.211.254
    DHCP-Server . . . . . . . . . . . : 97.156.195.132
    DNS-Server. . . . . . . . . . . . : 97.156.195.179
                                        97.156.195.225
                                        fec0:0:0:ffff::1%3
                                        fec0:0:0:ffff::2%3
                                        fec0:0:0:ffff::3%3
    Lease erhalten. . . . . . . . . . : Donnerstag, 31. Juli 2008 22:39:40
    Lease läuft ab. . . . . . . . . . : Freitag, 1. August 2008 00:09:40
    

    Der PC kommt übrigens eine dynamische IP-Adresse vom Kabelmodem (DHCP). Leider tut sich aber immer noch nichts.

    Mir kommt es so vor, als sei am Mac noch etwas gesperrt.

    Grüße
     
  5. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Du hast die LAN Verbindung zum Modem freigegeben? Das brauchst du nicht. Du musst bei der Netzwerkkarte zum Mac die Einstellung wie hier: http://www.netzwelt.de/picture/images/articles/drei_1131968294.jpg vornehmen. (Ich denke mal du hast 2 Netzwerkkarten drin)
    Dann ändert sich die IP dieser Karte auch direkt auf 192.168.0.1. Danach stellst du halt beim Mac als IP 192.168.0.2 und als Gateway 192.168.0.1 (sollte auch als DNS benutzt werden können). Die Option solltest du bei der Netzwerkkarte zum Modem hin wieder deaktivieren.
    Dnach testest du zuerst einmal ob du den PC anpingen kannst (ping 192.168.0.1 im Terminal) und auch vom PC aus den Mac anpingen. Wenn das geht, bis du schon einmal einen großen Schritt weiter.
    Einmal schauen ob http://91.90.156.83 vom Mac aus funktioniert (das ist die IP von apfeltalk). Wenn das geht, klappt die Verbindung und du musst einen anderen DNS Server eintragen.
     
  6. Dietmar

    Dietmar Ribston Pepping

    Dabei seit:
    01.09.06
    Beiträge:
    298
    (Das andere "vergessen" wir jetzt einmal und kontrollieren Deine Einstellungen ...)

    XP-PC

    Netzwerkumgebung > Breitband > Deine Internetverbindung > Eigenschaften
    Hier sollte nur das Internetprotokoll TCP/IP aktiviert sein

    Netzwerkumgebung > LAN oder Hochgeschwindigkeitsinternet > Netzwerkkarte 1 (für den PC) > Eigenschaften > Allgemein
    Hier sollten
    Client für Microsoft-Netzwerke
    Datei- und Druckerfreigabe
    Internetprotokoll TCP/IP

    aktiviert sein

    Netzwerkumgebung > LAN oder Hochgeschwindigkeitsinternet > Netzwerkkarte 2 (für das MacBook) > Eigenschaften > Allgemein
    Hier sollte nur das Internetprotokoll TCP/IP aktiviert sein

    Wenn Du die Einstellungen überprüft bzw. vorgenommen hast, gehen wir zum nächsten Schritt.

    Mit Gruß
    Dietmar
     
  7. Altan078

    Altan078 Fuji

    Dabei seit:
    26.01.08
    Beiträge:
    38
    Hallo,

    also danke für die bisherigen antworten:

    @drlecter: habe es genauso gemacht, wie in dem Link beschrieben. Pingen geht beiderseits, wie besagt. Nur ins Internet gehts vom Macbook aus nicht, weder über die URL noch über die IP

    @Dietmar: Mir ist nicht ganz klar, was Du genau mit welcher Netzwerkverbindung meinst. Ich habe keine Netzwerkverbindung "Breitband" am XP-PC, sondern folgendes:

    XP-PC: Lan Verbindung (Netzwerkkarte 1) -> freigegeben für "Lan Verbindung 3", automatische IP
    XP-PC: Lan Verbindung 3 (Netzwerkkarte 2) -> IP 192.168.0.1
    (daneben noch Firewire und eine Virtual Machine NW-Verbindung)

    Macbook: die eingebaute NW-Karte -> IP 192.168.0.2

    Leider tut sich immer noch nichts


    Grüße und noch schönes Wochenende
     
  8. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Hast du bei dem Mac als Gataway die 192.168.0.1 eingetragen? Und warum hast du die LAN Verbindung 1 freigegeben? Das ist doch die Verbindung zur Außenwelt. Du musst bei der LAN 3 die Einstellung wie oben bei dem Link mit dem Bild vornehmen.
     
  9. Dietmar

    Dietmar Ribston Pepping

    Dabei seit:
    01.09.06
    Beiträge:
    298
    Das sollte Dir nur die Orientierung erleichtern ...

    Wenn ich auf meinem PC (über Start > Systemsteuerung > Netzwerkverbindungen)
    die Netzwerkverbindungen aufrufe, dann hab' ich bei mir die "Überschriften"

    Assistent

    Breitband
    (1 Ordner-Symbol)

    LAN oder Hochgeschwindigkeitsinternet
    (2 Ordner-Symbole)

    -------------------------------------------------------------------------------------------------------------------

    Der nächste Schritt:

    Lösche bitte bei beiden Netzwerkkarten > Internetprotokoll TCP/IP alle Einstellungen, die Du "händisch", also selbst, vorgenommen hast und aktiviere "Automatisch".
     
  10. Altan078

    Altan078 Fuji

    Dabei seit:
    26.01.08
    Beiträge:
    38
    Oh, ja vielen Dank! Scheinbar hatterich das immer verwechselt.
    Nur leider immer noch nicht ...!

    Eegal ob Ohne DNS-Server, mit DNS-Server 192.168.0.1 oder mit den DNS-Servern vom "Ifconfig /all" vom XP-PC.

    Router war immer 192.168.0.1

    Weiß noch jemand weiter?
     
  11. Dominik77

    Dominik77 Jamba

    Dabei seit:
    31.07.08
    Beiträge:
    54
  12. Dietmar

    Dietmar Ribston Pepping

    Dabei seit:
    01.09.06
    Beiträge:
    298
    Dazu wäre es vielleicht ganz sinnvoll, wenn Du auch mal am Rechner bleiben würdest ...
     
  13. Altan078

    Altan078 Fuji

    Dabei seit:
    26.01.08
    Beiträge:
    38
    Hallo,
    falls Du noch einen Tipp weißt, ich bin gerade am Rechner.
    Grüße
     
  14. Dietmar

    Dietmar Ribston Pepping

    Dabei seit:
    01.09.06
    Beiträge:
    298
    Schön, dann probier' mal das hier, während ich meine "grauen Zellen" aktiviere ...

    Mit Gruß
    Dietmar

    ... und vergiß nicht, Bescheid zu geben.
     
  15. Altan078

    Altan078 Fuji

    Dabei seit:
    26.01.08
    Beiträge:
    38
    Ah, interessant,

    die Variante von dem Link hatte ich auch schon, nur ohne DHCP am OS-X Rechner. Die IP-Zuweisung hat dort geklappt, der OS-X-Rechner hat jetzt die IP 192.168.0.205. DNS-Server wurde automatisch auf die IP vom XP-Rechner eingestellt (192.168.0.1).

    Das Ping XP -> OS-X klappt, umgekehrt aber nicht. Auch das Internet geht leider nicht.

    Viele Grüße
     
  16. Altan078

    Altan078 Fuji

    Dabei seit:
    26.01.08
    Beiträge:
    38
    Sorry, mein Fehler, die Zone-Alarm Firewall hat das Ping geblockt. Jetzt gehts in beide Richtungen.

    Bis auf das Internet...
     
  17. Dietmar

    Dietmar Ribston Pepping

    Dabei seit:
    01.09.06
    Beiträge:
    298
    Die "Pingerei" kannst Du mal vergessen - hab' ich noch nie gebraucht.
    Starte doch mal beide Rechner neu ...
     
  18. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    So, was passiert nun wenn du folgendes am Mac versuchst:
    Terminal öffnen und das eingeben:
    nslookup www.heise.de

    Als Altwort solltest du sowas bekommen:
    Non-authoritative answer:
    Name: www.heise.de
    Address: 193.99.144.85

    Ach, wenn du die Firewall auf dem PC hast, kann die auch noch weiter stören.
     
  19. Altan078

    Altan078 Fuji

    Dabei seit:
    26.01.08
    Beiträge:
    38
    Hey, super, danke.

    Es lag wohl schließlich an der Firewall. Mit der richtigen Einstellung klappt es. Und das mit dem DCHP + automatische Adresse beim Mac war auch wichtig. Jetzt rennt's

    Viele Grüße
     

Diese Seite empfehlen