1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Hilfe! Terminal funktioniert nicht mehr!

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von snoopysalive, 08.03.08.

  1. snoopysalive

    snoopysalive Allington Pepping

    Dabei seit:
    19.08.05
    Beiträge:
    195
    Hallo!

    Hat jemand von euch eine Ahnung, an was es liegen könnte, dass mein Terminal nicht mehr funktioniert? Das Terminal-Fenster wird gestartet, aber die Kommandozeile startet nicht. Das Terminal-Fenster bleibt also weiß.

    Ehrlich gesagt, weiß ich nicht, woran das liegt: Ich habe heute mein neues MBP bekommen und mir per Darwinports eine aktuelle bash installiert. Alles kein Problem. Dann habe ich in den Terminal-Einstellungen angegeben, dass es die neue bash starten solle (/opt/local/bin/bash). Ab dann lief es nicht mehr. Ich stellte also wieder zurück auf /bin/bash, aber das brachte auch nichts. Nicht mal mehr die Standard-Ameldungs-Shell läuft mehr.

    Ich kapier das nicht. Ich habe jedenfall schon die com.apple.Terminal.plist unter Library/Preferences gelöscht, aber auch das brachte nichts.

    Hat jemand eine Idee? Oder gibt's eine Möglichkeit, das Terminal zu löschen und neu zu installieren? Oder muss ich den Rechner neu aufstezen?

    Gruß,
    Matthias
     
  2. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.395
    Die Einstellungen für die Shell werden auch nicht in den Preferences gespeichert, dort stehen nur die Dinge, die für das Terminalfenster im Finder interessant sind.
    Schau dir mal mit einem Texteditor /etc/profile an und ~/.bash_profile.
     
  3. delycs

    delycs Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    13.09.06
    Beiträge:
    245
    Probier mal als erstes die .bashrc und .profile in deinem ordner zu löschen (Backup machen)
    In /etc gibts da auch noch 2 für die systemweiten Einstellungen die solltest du aber in Ruhe lassen.
    Wenn das nicht hilft geh ich davon aus das eine Verfriemelung der Einstellungen mit einfachen Mitteln nicht zu beheben ist, also muß der Fehler gefunden werden.

    Dazu kannst du erstmal testen ob die Anmeldung überhaupt geht. Versuch dich mal von nem anderen Rechner per ssh einzuloggen. Dann kann man erstmal ausschliesen das das Login vielleicht nicht ging und du deshalb nur ein weißes Fenster sahst.
    Wenn nicht geht kanns immer noch am login liegen oder an einer Falsch konfigurierten Befehlszeile für den Aufruf der Shell.

    Da muss ich aber erstmal nachschauen wie man das einstellen kann ohne shell :)
    Vielleicht hilft da ja auch iTerm. Ich weiß leider nicht ob es nicht die selben einstellungen für die Shell aus dem System liest. Kannst dann ja mal dort eine TCSH nehmen anstatt bash.
     
  4. snoopysalive

    snoopysalive Allington Pepping

    Dabei seit:
    19.08.05
    Beiträge:
    195
    Vielen Dank für eure Antworten, aber das Problem hat sich dann ganz von selbst erledigt. Als ich gestern den Rechner runterfahren wollte und erst noch alle offenen Programme schloss, tauchte plötzlich wieder die Befehlszeile auf. Das Terminal hat mich einfach nur verar***t. Jetzt geht's also wieder und auch mit der aktuellen über Darwinports erhältlichen Bash 3.2.33.
     

Diese Seite empfehlen