1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Hilfe für Latex Literaturverzeichnis und Zitierweise

Dieses Thema im Forum "LaTeX" wurde erstellt von SRV, 07.09.09.

  1. SRV

    SRV Jamba

    Dabei seit:
    20.06.09
    Beiträge:
    56
    Hallo,
    ich habe seit einiger Zeit ein MacBook und möchte nun meine erste Arbeit mit Tex schreiben. Auf meiner alten Windowsmaschine habe ich zuvor bereits einige geschrieben, diese können aber aufgrund der Kodierung noch nicht fehlerfrei bei Mac gesetzt werden, aber egal. Ich habe mir auf jedenfall das Miktex Kompletpaket installiert und habe nun extreme Probleme ein einfaches Zitat hinzubekommen. Ich kapier einfach nicht wie das gehen soll und finde das ganze Prozedere ziemlich kompliziert. Bin schon wieder am Zweifeln warum ich mich mal wieder aufs neue mit diesem Mist rumärgere und nicht einfach ein böses Office Paket meiner Wahl vorziehe... naja.
    Ich benutze jedenfalls nicht BibDesk, dass ich überhaupt nicht zum laufen gebracht habe, sodern JabRef. Aber ich bekomme es einfach nicht eingebunden. Ich erstelle also eine Lit.bib mit Jabref, und wähle eine Minimalumgebung, verweise mit \bibliography{lit} auf die datei und will einfach nur zitieren, aber es funktioniert nicht?!

    Ein weiteres Problem, liegt darin, dass ich noch nie den bei mir geforderten Zitierstil bei Latex bekommen hab. Aussehen solls so: im Text (Nachname 2009: 99) und im Literaturverzeichnis soll es so erscheinen: Nachname, Vorname (2009): Titel. Untertitel, Ort.
    Ich hab schon ein Harvard paket ausprobiert (was aber natürlich auf dem mac wieder nicht geht), bekomme aber nicht das gewünschte Ergebnis.

    Ich wäre wirklich dankbar für ein paar Tipps, ich bin so langsam wirklich kurz vorm ausrasten und frage mich ob dieser ganze Latexquatsch überhaupt noch sein muss... Argumente wie Unvergänglichkeit und Unproblematisch sind nach dem Systemwechsel und den damit verbundenen Kodierungsproblemen und Paketproblemen für mich jedenfalls erstmal aufgehoben.
     
  2. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    MikTeX? Ist dass nicht vorrangig eine Win-Distribution, dessen Portierung für GNU/Linux noch in der Beta-Phase steckt? Ich rate eigentlich immer zu MacTeX, dann sollte auch alles out-of-the-box funktionieren.

    Um dir weiterhelfen zu können, musst du uns a) ein Minimalbeispiel zeigen, d.h. ein aufs Wesentliche beschränktes Beispiel, das deiner Meinung nach funktionieren sollte und ausserdem benötigen wir die Fehlermeldung.

    Ein Beispiel für ein Minimalbeispiel:

    Code:
    \documentclass[]{article}
    
    \begin{document}
     Das ist ein Test \cite{test}
     \bibliographystyle{plain}
     \bibliography{MeineLiteraturdatenbank}
    \end{document}
    
    Wobei das BibTeX-File im selben Verzeichnis wie das LaTeX Dokument liegt.
     
    Der_Apfel gefällt das.
  3. unoseraphim

    unoseraphim Golden Delicious

    Dabei seit:
    13.03.09
    Beiträge:
    9
    Ähnliches Problem mit dem Einbinden des bib-Files ins LaTeX-Dokument

    Hallo, dieser Thread ist zwar schon ein Jahr alt, aber da mein Problem ziemlich genau dem oben beschriebenen (OK, ich hab sicher nicht MikTeX installiert ;) ) Problem entspricht, post ich's hier dazu:

    Ich hab auf meinem MBP MacTeX 2010 installiert (alles up to date) und schaffe es scheinbar nicht das BIB-File in das LaTeX-Dokument einzubinden. Ich arbeite mit TextMate und setzte die LaTeX-Datei mit pdflatex über die "Typeset"-Funktion des LaTeX-Bundles von TextMate.

    Nachdem ich bei einigen größeren LaTeX-Dokumenten (die eigentlich funktionieren hätten müssen) bemerkt habe, dass es Probleme mit dem Literaturverzeichnis gibt, habe ich mit folgender Minimalversion getestet:

    test.tex
    Code:
    \documentclass{article}
    \begin{document}
    Hallo Welt
    \cite{buch}
    \bibliographystyle{plain}
    \bibliography{literatur}
    \end{document}
    
    literatur.bib
    Code:
    @BOOK{buch,
    author = {Hans Wurst},
    title = {Wurstverarbeitung},
    publisher = {Wurstbetrieb},
    year = {1234},
    }
    
    Alle Dateien liegen im selben Verzeichnis. Nach dem (mehrmaligen) Ausführen von pdfTeX bekomme ich ein PDF mit dem Text "Hallo Welt [?]" und folgende test.log
    Code:
    This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010) (format=pdflatex 2010.9.15)  15 SEP 2010 15:36
    entering extended mode
     restricted \write18 enabled.
     file:line:error style messages enabled.
     %&-line parsing enabled.
    **test.tex
    (./test.tex
    LaTeX2e <2009/09/24>
    Babel <v3.8l> and hyphenation patterns for english, dumylang, nohyphenation, ge
    rman-x-2009-06-19, ngerman-x-2009-06-19, ancientgreek, ibycus, arabic, armenian
    , basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danish, dutch, u
    kenglish, usenglishmax, esperanto, estonian, farsi, finnish, french, galician, 
    german, ngerman, swissgerman, monogreek, greek, hungarian, icelandic, assamese,
     bengali, gujarati, hindi, kannada, malayalam, marathi, oriya, panjabi, tamil, 
    telugu, indonesian, interlingua, irish, italian, kurmanji, lao, latin, latvian,
     lithuanian, mongolian, mongolianlmc, bokmal, nynorsk, polish, portuguese, roma
    nian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, turkish,
     turkmen, ukrainian, uppersorbian, welsh, loaded.
    (/usr/local/texlive/2010/texmf-dist/tex/latex/base/article.cls
    Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
    (/usr/local/texlive/2010/texmf-dist/tex/latex/base/size10.clo
    File: size10.clo 2007/10/19 v1.4h Standard LaTeX file (size option)
    )
    \c@part=\count79
    \c@section=\count80
    \c@subsection=\count81
    \c@subsubsection=\count82
    \c@paragraph=\count83
    \c@subparagraph=\count84
    \c@figure=\count85
    \c@table=\count86
    \abovecaptionskip=\skip41
    \belowcaptionskip=\skip42
    \bibindent=\dimen102
    )
    No file test.aux.
    \openout1 = `test.aux'.
    
    LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 2.
    LaTeX Font Info:    ... okay on input line 2.
    LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 2.
    LaTeX Font Info:    ... okay on input line 2.
    LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 2.
    LaTeX Font Info:    ... okay on input line 2.
    LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 2.
    LaTeX Font Info:    ... okay on input line 2.
    LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 2.
    LaTeX Font Info:    ... okay on input line 2.
    LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 2.
    LaTeX Font Info:    ... okay on input line 2.
    
    LaTeX Warning: Citation `buch' on page 1 undefined on input line 4.
    
    No file test.bbl.
    [1
    
    {/usr/local/texlive/2010/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
    (./test.aux)
    
    LaTeX Warning: There were undefined references.
    
     ) 
    Here is how much of TeX's memory you used:
     203 strings out of 493747
     2153 string characters out of 3143546
     49070 words of memory out of 3000000
     3581 multiletter control sequences out of 15000+200000
     3948 words of font info for 15 fonts, out of 3000000 for 9000
     714 hyphenation exceptions out of 8191
     23i,4n,21p,151b,107s stack positions out of 5000i,500n,10000p,200000b,50000s
    </usr/local/texlive/2010/texmf-dist/fonts/type1/public/amsfonts/cm/cmbx10.pfb
    ></usr/local/texlive/2010/texmf-dist/fonts/type1/public/amsfonts/cm/cmr10.pfb>
    Output written on test.pdf (1 page, 20207 bytes).
    PDF statistics:
     16 PDF objects out of 1000 (max. 8388607)
     10 compressed objects within 1 object stream
     0 named destinations out of 1000 (max. 500000)
     1 words of extra memory for PDF output out of 10000 (max. 10000000)
    
    In der test.aux steht folgendes:
    Code:
    \relax 
    \citation{buch}
    \bibstyle{plain}
    \bibdata{literatur}
    
    Ich muss zugeben, ich bin mit meiner Weisheit am Ende und überlege momentan zwischen MacTeX neu zu installieren und meine Masterarbeit mit Mellel oder dergleichen zu schreiben. Bin für alle Tipps dankbar.
     
  4. floorjiann

    floorjiann Strauwalds neue Goldparmäne

    Dabei seit:
    18.01.07
    Beiträge:
    639
    Sieht danach aus, dass du die .bib Datei nicht komiliert hast. Drück mal auf Run BibTeX und dann 2 mal auf Re-Run pdflatex.
     
  5. unoseraphim

    unoseraphim Golden Delicious

    Dabei seit:
    13.03.09
    Beiträge:
    9
    Hab jetzt noch einen expliziten Run von BibTeX zu starten. Bekomme allerdings folgende Fehlermeldung:

    Running BibTeX on test.tex
    Processing: test.aux
    Program bibtex exited with error code 1

    Folgender Inhalt steht in der test.aux

    Code:
    \relax 
    \citation{buch}
    \bibstyle{plain}
    \bibdata{literatur}
     
  6. unoseraphim

    unoseraphim Golden Delicious

    Dabei seit:
    13.03.09
    Beiträge:
    9
    Problem ist irgendwo beim Starten von BibTeX

    Ich melde mich gleich noch einmal. Hab jetzt etwas herum probiert und sämtliche Befehle vom Terminal aus gestartet und siehe da: nach dem normalen Prozedere (pdflatex, bibtex, 2xpdflatex) erhalte ich ein korrektes PDF.

    Scheinbar startet TextMate BibTeX nicht richtig. Jetzt habe ich das Setzen mit TeXShop probiert und dort ähnliche Probleme gehabt: zuerst konnte es nicht richtig setzen und unter Menü:Setzen:BibTeX war ausgegraut. Nach einmaligen öffnen der Programmeinstellungen und wieder schließen, kann ich plötzlich in TeXShop bibtex ohne Probleme starten. Auch nach kompletten Beenden des Programms und neuen Start ist dies noch möglich. In TextMate funktioniert bibtex allerdings nach wie vor nicht.
     
  7. unoseraphim

    unoseraphim Golden Delicious

    Dabei seit:
    13.03.09
    Beiträge:
    9
    Bin weiter beim Fehler eingrenzen. Derzeitiger Stand:
    Button vom LaTeX-Bundle von TextMate "Run BibTeX" funktioniert nach wie vor nicht. Allerdings habe ich in den Preferences des Bundles die Typeset Action auf "Run Latexmk.pl script" umgestellt und erhalte jetzt zumindest beim "normalen" Typeset (, welches jetzt das besagte Script ausführt) ein korrektes PDF.

    Was ich allerdings nach wie vor nicht heraus gefunden habe ist, warum der Button "Run BibTeX" nicht funktioniert. Er endet mit folgender Meldung:
    Program bibtex exited with error code 1

    Weiß jemand, wo/wie ich heraus bekomme, was "error code 1" in diesem TextMate-Bundle bedeutet? Die Dokumentation und die Hilfe vom LaTeX-Bundle habe ich bereits durchsucht.
     
  8. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Dazu sollte sich vielleicht jemand äußern, der TextMate häufiger benutzt. Frag vielleicht mal Zettt.
     
  9. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Witzigerweise, bekomme ich seit heute denselben Fehler, wenn ich BibTeX laufen lasse. Wie hast du das Problem gelöst/Wie kann man das Problem lösen? Meine .aux ist ein wenig länger...daher wohl unpraktisch hier zu posten.
    http://pastie.org/1394821

    Vorher hatte ich noch einen Fehler erhalten, nur von BibTeX, dass ich doch bitte \input{} statt \include{} benutzen solle. BibTeX könne nicht in ein "anderes Verzeichnis" schreiben. Was auch immer das heissen mag, habe ich mein \include{thesis} auf \input{thesis} umgeschrieben.
    Danach meckert zwar BibTeX nicht mehr über den Speicherort *und* den Bla-Fehler 1 sondern nur noch über Bla-Fehler 1.
     
  10. unoseraphim

    unoseraphim Golden Delicious

    Dabei seit:
    13.03.09
    Beiträge:
    9
    Mein Problem habe ich damals "gelöst" indem ich TextMate auf die Typeset Action "Run Latexmk.pl script" umgestellt habe. Somit war kein expliziter Run von BibTeX mehr notwendig. Bei mir bestand das Problem nur beim Start von BibTeX über TextMate. Bei manueller Eingabe auf der Command Line gab es keine Probleme.

    Mittlerweile arbeite ich allerdings nicht mehr mit BibTeX sondern bin auf biber (http://sourceforge.net/projects/biblatex-biber) umgestiegen, da es eine bessere Unterstützung von UTF8 bietet. Bisher hatte ich mit biber keine Probleme.

    Ich hab jetzt mal probeweise ein altes Tex-File (mit Verwendung von BibTeX) in TextMate geöffnet und via der Funktionen von Tex-Bundle setzen lassen. Funktioniert jetzt wieder problemlos ohne irgend ein Zutun meinerseits.

    Der Unterschied zwischen \input{} und \include{} ist (soweit ich weiß), dass \input{} keinen Seitenwechsel einfügt und schachtelbar ist. Außerdem schreibt \include{} für jedes eingefügte Tex-File eine separate .aux-Datei. Von daher wär's möglich, dass die Schreibrecht-Probleme kommen, die du hattest. (Unterschied zwischen den beiden siehe: auf golatex.de )
     
  11. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Ja, ne, ich hab jetzt auch den Umweg über Latexmk gemacht. Ist halt nicht das was ich will, weil eigentlich will ich BibTeX nur einmal setzen lassen. Das ist schon ziemlich Pain in the Ass. Der TextMate Channel im IRC ist leider auch still.
     
  12. unoseraphim

    unoseraphim Golden Delicious

    Dabei seit:
    13.03.09
    Beiträge:
    9
    Wundert mich, dass sich im IRC-Channel nichts tut. Die User Mailing List (http://lists.macromates.com/listinfo/textmate) ist seit dem letzten Update von TextMate wieder recht aktiv geworden. Falls BibTeX bei dir im Terminal funktioniert (war bei mir zumindest damals so), kannst du ja mal in die texMate.py schauen, wie dort BibTeX angesprochen wird. Was ich so heraus gefunden hab', wird der run_bibtex-Befehl dort in den Zeilen 83 bis 104 definiert.
     
  13. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Ich meinte nicht, dass der IRC tot ist, nur, dass die Jungs dort ebenfalls nichts wissen. Schauen wir mal ob und wie ich das Problem jetzt löse. Vorerst mal nicht so wichtig. Schreiben ist wichtiger.
     

Diese Seite empfehlen