1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Grafikkarte unter Leopard deaktivieren

Dieses Thema im Forum "Desktop-Macs" wurde erstellt von zilVerGFX, 21.01.09.

  1. zilVerGFX

    zilVerGFX Macoun

    Dabei seit:
    26.12.08
    Beiträge:
    116
    Haloa,

    ich hab wieder mal ein Problem, und da mir die AT-Community bisher immer weitergeholfen hat, frag ich diesmal auch hier nach ;)


    Ich habe also folgendes Problem:

    Ich habe in meinem MacPro 2 Grafikkarten verbaut:

    • eine NVidea GeForce 8800 GT (Mac-Edition), welche ich unter Leopard nutze
    • eine NVidea GeForce 9800GTX+ (Hersteller: PNY) welche ich unter Windows benutze
    Soweit läuft alles super, nur eins stört mich: Die Windows-Grafikkarte ist im MacOS-Betrieb sehr laut, und wird zudem eh nicht erkannt (was mir bewusst ist, da ich die Grafikkarte auch nur unter Windows nutze). Meine Frage ist daher: ist es unter Leopard möglich, eine Grafikkarte während des MacOS-Betriebes zu deaktivieren?
    Unter MacOS X kommt sie eh nicht zum Einsatz, und der laute Lüfter ist ziemlich nervig =(


    Danke im Vorraus
    MfG. zilVer
     
  2. chris85

    chris85 Carola

    Dabei seit:
    16.09.08
    Beiträge:
    112
    Mal eine Gegenfrage: Funktionieren beide Grafikkarten ohne umstecken automatisch in den jeweiligen Betriebssystemen?

    Hier gab es soweit ich weiß mal einen Thread, in dem das Thema behandelt wurde und der letzte Stand war, dass man immer eine der Grafikkarten ausbauen müsste (da es sonst unter Windows bspw. zu Konflikten kommt).

    Vielleicht kannst du kurz erklären, wie du vorgegangen bist... würde mich interessieren. ;)

    Ansonsten kann ich dir leider nicht helfen...
     
  3. funrun

    funrun Klarapfel

    Dabei seit:
    09.06.08
    Beiträge:
    282
    Ich vermute, dass es daran lag, dass nicht beide GraKas den selben Treiber brauchten. Meines letzten Wissenstandes nach kann nämlich Vista nur einen GraKa-Treiber gleichzeitig aktiv halten, daher geht eine Ati/nVidia-Kombo nicht. Aber vielleicht hat Microsoft da auch schon mit SP1 nachgebessert...

    mfg
     
  4. zilVerGFX

    zilVerGFX Macoun

    Dabei seit:
    26.12.08
    Beiträge:
    116
    Windows deaktiviert bei mir automatisch die Grafikkarte auf dem sekundären PCIe-X16 Slot obwohl ich 2 Nvidea Grakas drinne hab.
    Jedenfalls war meine frage wie ich die Grafikkarte unter MacOS austellen kann, bzw. ob ich irgednwie die Stromzufur per Software aussstellen kann, damit der Lüfter nicht nervt.

    MfG.
     
  5. noname_MAC

    noname_MAC deaktivierter Benutzer

    Dabei seit:
    26.10.07
    Beiträge:
    86
    Leider kann ich dir auch nicht weiter helfen.

    Mich interessiert aber das Thema, da ich mir auch ein Mac Pro kaufen möchte und genau dies Vorhabe.

    Hast du schon mal versucht die 9800GTX+ mit einem osx86 Treiber einzubinden??
    Könnte klappen. Soll auch sehr Stabil laufen.

    2.Tipp
    Versuch es vielleicht mit einem Bios-Editor für die nvidia Karte.. dakannst du ja den "normal"Fan Speed auch einstellen.

    Gruß noname
     
  6. Cathul

    Cathul Tydemans Early Worcester

    Dabei seit:
    26.10.07
    Beiträge:
    397
    Es gibt keine expliziten osx86 Treiber für Mac OSX und NVidia-Karten. Den vorhandenen Treibern wird per EFI-Strings nur die Karte bekannt gemacht. Das die 9800GTX+ nicht nativ erkannt wird, liegt einzig daran, dass diese kein EFI-"Bios" hat und Mac OSX daher nativ nichts mit den Karten anfangen kann.

    Natit, Titan etc. sind daher auch keine Treiber, sondern nur EFI-Injektoren, die entsprechende EFI-Strings generieren und zur Laufzeit an MacOSX melden.
     
  7. noname_MAC

    noname_MAC deaktivierter Benutzer

    Dabei seit:
    26.10.07
    Beiträge:
    86
    Ah Ok Danke. Also sollte es ja kein Problem sein, diese Grafikkarte auch an zu steuern?? Oder Habe ich das nun nicht ganz verstanden?! Leopard starten -> EFI-String eintragen -> neustart und nun sollte doch Leopard mit den passenden Strings starten?
     
  8. Cathul

    Cathul Tydemans Early Worcester

    Dabei seit:
    26.10.07
    Beiträge:
    397
    Theoretisch nicht, allerdings habe ich im einschlägigen osx86 Forum noch keine Erfolgsmeldung gelesen.
     
  9. noname_MAC

    noname_MAC deaktivierter Benutzer

    Dabei seit:
    26.10.07
    Beiträge:
    86
    Aber unter einem osx86 - System läuft diese Karte (+) ja unter Leopard mit voller Unterstützung.
     
  10. Cathul

    Cathul Tydemans Early Worcester

    Dabei seit:
    26.10.07
    Beiträge:
    397
    Schon, aber dort hat das Mainboard-BIOS kein EFI ;)
    Du kannst ja mal den Hinweisen folgen und versuchen EFI-Strings für deine 9800GTX zu erhalten und diese entsprechend in die com.Apple.boot.plist einzubinden.
    Ich persönlich gehe aber nicht davon aus, dass das ganze funktioniert, da die Karte nach dem Systemstart nicht richtig initialisiert wird. U.a. wirst Du keine Ausgabe des Bootmenüs etc. haben, nicht von CD booten können, da auf diesen die EFI-Strings für nicht Apple-Karten nicht enthalten sind etc. Fraglich ist auch, ob der Rechner ohne eine EFI-fähige Karte überhaupt in OSX startet.

    Eben das meinte ich mit "hab noch keine Erfahrungsberichte gelesen". ;)
     
  11. noname_MAC

    noname_MAC deaktivierter Benutzer

    Dabei seit:
    26.10.07
    Beiträge:
    86
    Hoffentlich testet der Thread-Ersteller dies mal :) Interessiert mich mal brennend.
     

Diese Seite empfehlen