1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

GCC >= 4.1.x zum Compilieren von wxWidgets

Dieses Thema im Forum "OS X-Developer" wurde erstellt von Prophet, 28.01.07.

  1. Prophet

    Prophet Gast

    Moin,

    ich habe letztens versucht wxWidgets auf meine iBook G4 zu Compilieren. Allerdings hagelte es nur fehlermeldungen. Ich habe im wxWidgets Forum daraufhin nachgefragt, dort wurde mir nur dazu geraten mir eine aktueller GCC Version zu verwenden. Im moment habe ich die version 4.0.1 drauf. Nun wollte ich mir eine aktueller version drafuspielen fand aber nirgends einen Download mit Binary. Könnt ihr mir einen Link geben wo ich die aktuelle Version des GCC als Binary für mein iBook herbekomme?

    Wenn nicht muss ich ihn mir wohl Compilieren. Aber in diesem fall habe ich keine ahnung wo ich die Binary dann hinwerfen soll. Kann mir das einer sagen? Wo soll das aller hin was nach dem Kompilieren entsteht?

    Gruß, Prophet05

    Edit:
    > Mac OS X 10.4.8
    > iBook G4
    > GCC 4.0.1
     
    #1 Prophet, 28.01.07
    Zuletzt von einem Moderator bearbeitet: 29.01.07
  2. slayercon

    slayercon Meraner

    Dabei seit:
    17.01.05
    Beiträge:
    231
    Wenn du keinen Bock auf selber kompilieren hast dann benutze doch darwin port
    Darwin wxwidgets

    lg S.
     
  3. Prophet

    Prophet Gast

    Danke füür den Link! Das ist ein gute alternative zum selbst Kompilieren! Mal schauen ob ich das mache.

    Trotzdem nochmal die Frage wie ich an eine Neuere GCC version rannkomme ;)
     
  4. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Von http://gcc.gnu.org downloaden und dann compilieren. ;)
    Zumindest bis gcc <=4.1.1 sollte das funktionieren (siehe Buildstat).

    Dass wxwidgets nicht out-of-the-box compiliert, ist allerdings seltsam. Normalerweise vergrößern sich die Probleme doch, wenn man einen aktuelleren Compiler einsetzt (welcher z.B. strenger ist). Sollte es hier andersrum sein?
     
  5. Prophet

    Prophet Gast

    Mit 4.0.1 habe ich Probleme wie gesagt.
     

Diese Seite empfehlen