1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

gcc 4.0.0 und/oder gcc 4.0.1?

Dieses Thema im Forum "OS X-Developer" wurde erstellt von Wombat, 08.03.06.

  1. Wombat

    Wombat Gast

    Hallo an alle!

    Bei mir ist ein Problem aufgetreten, als ich versucht habe, das Paket svn-client-ssl in der Konsole mit Fink zu installieren. Ich bekomme erstmal eine Liste mit Abhängigkeiten, die ich neben dem eigentlichen Paket auch noch installieren muss. Der Vorgang der Installation bricht irgendwann ab und macht mich darauf aufmerksam, dass ich als Default Compiler gcc 4.0 einstellen müsste. Die Fehlermeldung sieht so aus:
    Code:
    ~ Administrator$ fink install svn-client-ssl
    Information about 1747 packages read in 4 seconds.
    The following package will be installed or updated:
     svn-client-ssl
    The following 8 additional packages will be installed:
     apr-ssl apr-ssl-common apr-ssl-shlibs neon24-ssl neon24-ssl-shlibs
     openldap-ssl-dev openldap-ssl-shlibs svn-ssl-shlibs
    Do you want to continue? [Y/n] y
    Failed: This package must be compiled with GCC 4.0.0, but you currently have
    GCC 4.0.1 selected.  To correct this problem, run the command:
    
        sudo gcc_select 4.0
    
    (You may need to install a more recent version of the Developer Tools to be
    able to do so.)
    ~ Administrator$ 
    
    Ich habe Xcode Version 2.2.1 installiert und gebe sudo gcc_select 4.0 in der Konsole ein. Daraufhin bekomme ich die Rückmeldung, dass ich bereits gcc 4.0 als Default Compiler eingestellt habe. Folgende Versionen sind bei mir installiert:
    Code:
    ~ Administrator$ sudo gcc_select -l
    Password:
    Available compiler versions:
    3.3             3.3-fast        4.0
    ~ Administrator$ 
    bzw.:
    Code:
    ~ Administrator$ gcc_select
    Current default compiler:
    gcc version 4.0.1 (Apple Computer, Inc. build 5250)
    Ich habe versucht gcc 4.0.0 mit Fink zu installieren, funktioniert aber nicht.

    Nun meine Frage an die Entwickler hier:

    Wie kann ich das Problem lösen? Kann ich neben dem bestehenden gcc 4.0.1 Compiler auch noch die Version gcc 4.0.0 installieren? Ist das überhaupt zu empfehlen? Wenn das geht, kann mir jemand sagen, wie genau man das anstellen muss? Ausser in der Auswahlliste bei Fink finde ich nirgends ein Paket gcc für Mac OS X.

    Kann mir da bitte jemand weiterhelfen?

    Vielen Dank,
    Wombat
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Die Fink Package descriptions upzudaten sollte helfen.
    fink selfupdate

    Alternativ kannst Du auch das Subversion Binary Package von Martin Ott installieren. Damit ersparst Du Dir Berge an Dependency Packages die Du eigentlich wahrscheinlich garnicht haben willst.
    Gruß Pepi
     
  3. Wombat

    Wombat Gast

    Vielen Dank für Deinen Rat, pepi.

    Werde mich heute nachmittag dran setzen.

    Vielen Dank für Deine Hilfe :) und viele Grüsse,

    Wombat
     

Diese Seite empfehlen