1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

GarageBand Midi Problem

Dieses Thema im Forum "Musikproduktion" wurde erstellt von iSight, 27.05.07.

  1. iSight

    iSight Gast

    Hallo zusammen,

    seit einiger Zeit habe ich ein Problem mit GarageBand 3. Ich hatte mal einen Treiber installiert, damit GB ein Keyboard erkennt. Dies hat auch eine ganze Weile prima funktioniert, bis ich nach einiger Zeit (nach mind. einem OS X update) ein GB Projekt geöffnet habe, um daran weiterzuarbeiten. Doch leider erschien dann diese Fehlermeldung (siehe Anhang).
    Durch einen Benutzerwechsel hatte ich schon gehofft, das Problem zu umgehen, was nicht funktionierte, so dass dieses Midi Problem wohl auf System Basis liegen muss. Mit dem Dienstprogramm "Audio-Midi-Konfiguration" erhoffte ich mir weitere Hinweise zur Lösung des Problems, allerdings kommt es hier auch zu einer Fehlermeldung in dem Midi Bereich.
    Dadurch kann ich meine Projekte in GB nun nicht mehr abspielen oder verändern. Der gesamte Ton funktioniert in GB nicht mehr. :-[

    Habt ihr eine Idee, wie man dieses Problem beheben könnte?

    Vielen Dank,

    Globox
     

    Anhänge:

  2. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Da stehts ja schon ;)

    Du hast ein Problem mit deinen MIDI-Treibern.
    Wieviele hast du denn installiert?

    /Library/Audio/MIDI Drivers/
     
  3. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Wahrscheinlich befindet sich der betreffende Midi Treiber in /Library/Audio/MIDI Drivers … löschen und Garageband neustarten.
    Da Du sagst, dass es nach einem Update nicht mehr ging, hilft in diesem Fall stattdessen eventuell auch schon Rechte reparieren.


    Gruss

    Upps: Edit: Siehe Zettt
     
  4. iSight

    iSight Gast

    In dem Verzeichnis /Library/Audio/MIDI Drivers/ befindet sich die Datei EmagicUSBMIDIDriver.plugin, die ich nun gelöscht habe. Danach habe ich das Startvolume, sowie die Zugriffsrechte repariert.
    Nun habe ich GarageBand neugestartet und es erscheint wieder die selbe Fehlermeldung.
     
  5. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Wird das jetzt hier zum Sport alles farblich zu markieren?
    Na gut dann mag ich mal mitmischen...

    ~/Library/Audio/MIDI Drivers/ ?

    Deinen Treiber hast du aber wieder installiert oder? Den brauchst du ja hast du ja selbst gesagt...
     
  6. m00gy

    m00gy Gast

    Könnte auch weiterhelfen, wenn wir wüssten, was für ein Keyboard Du mittels Treiber angesprochen hast.
     
  7. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Hmph … Ich bin mal davon ausgegangen, dass Du weisst, welche Miditreiber Du installiert hast … der Emagic ist ein "Werkstreiber"! Ist er noch im Papierkorb? Wenn nicht, so gibt es den hier noch mal…

    Bitte mal genauere Infos, welchen Treiber Du damals geladen hast

    Gruss
     
  8. iSight

    iSight Gast

  9. iSight

    iSight Gast

    Beim Starten des "Audio-Midi-Konfiguration" Dienstprogramms erhalte ich diese Fehlermeldung (Anhang).
    Midi scheint es übel erwischt zu haben. :-[
     

    Anhänge:

  10. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Mach doch mal nen Neustart.
     
  11. iSight

    iSight Gast

    Leider auch nach einem Neustart keine Änderung. :(
     
  12. m00gy

    m00gy Gast

    Braucht denn das GarageKey überhaupt einen Treiber? Theiming hat das auch und ich könnte schwören, er hat's einfach nur eingesteckt und sich gefreut, dass das GarageKey-Gerät class-compliant ist und damit keinen Treiber braucht... ?!
     
  13. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Hast du nach dem Neustart nochmal das DiskUtility drueber laufen lassen?
     
  14. iSight

    iSight Gast

    Auch nachdem ich nochmals Festplatten-Dienstprogramm drüber laufen gelassen habe, kommt immer noch die gleiche Fehlermeldung.
     
  15. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Sorry ratlos, weil leider weiss ich nicht wo der MIDI Server liegt.

    Ich wuerde mal nach der ENGLISCHEN Fehlermeldung googlen...
     
  16. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Hmm ... über dieses Keybord gibt es bei MacMice keine Angaben … wird wohl nicht mehr hergestellt. Was mich aber wundert ist, dass es überhaupt einen Midi Treiber benötigt. Ich habe schon was weiss ich wie viele Midi-USB-Keyboards an den Mac angeschlossen, und die wurden immer sofort erkannt … und dieses soll ja "speziell für GarageBand" sein.


    Also: Hast Du noch das Manual und die CD, mit der Du diesen Treiber geladen hast?

    Was passiert, wenn Du den erneut laden willst … oder gibt es einen Uninstaller … wie lautet der Pfad, wenn er nicht da liegt, wo er -eigentlich- hingehört. Und hast Du mal -wie von Zett empfohlen- in deinem User-Ordner geschaut, ob es da in der Library eventuell einen Audio/Midi Drivers Ordner gibt?
    Wenn Du weisst, wie der Treiber heisst, kannst Du ihn mit Spotlight suchen …

    Ansonsten bin ich sowieso überfragt, das merkt man ja auch schon an meinem ziellosen Rumgestochere …
    Doch kann es sein, dass Du eine Software geladen hattest (und nicht einen Treiber) ?

    Doch weiter im Text:
    Die Fehlermeldungen sind ja eindeutig … der Midi Server kann nicht gestartet werden. Er ist ja quasi der "Ansprechpartner" der Miditreiber auf dem Weg zum Programm (hier GarageBand)

    Also die systemeigenen Miditreiber liegen in
    /System/Library/Extensions

    bei mir gibt es dort

    /AppleMIDIFWDriver.plugin
    /AppleMIDIIACDriver.plugin
    /AppleMIDIRTPDriver.plugin
    /AppleMIDIUSBDriver.plugin

    und bei dir?

    Ach ja: Der Midi Server liegt hier:
    /System/Library/Frameworks/CoreMIDIServer.framework



    Gruss
     
  17. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Achja...waere es dann nicht eine Ueberlegung wert den MIDIServer neu zu installieren?
     
  18. iSight

    iSight Gast

    Nach dem ganzen Hin und Her habe ich nun mit Hilfe der Mac OS X Installations DVD den System- und Library Ordner neuinstalliert. Die Installation war nach 35 Minuten abgeschlossen und tatsächlich GarageBand und der Midi Server laufen wieder einwandfrei. - Welch ein Segen! - :)

    Vielen Dank nochmal für eure Hilfe! ;)

    Gruß,

    Globox
     

Diese Seite empfehlen