1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

FreeNas Schreibzugriff zu langsam

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Peitzi, 23.07.08.

  1. Peitzi

    Peitzi Blutapfel

    Dabei seit:
    07.08.07
    Beiträge:
    2.595
    Nabend zusammen,

    ich habe eben mal FreeNas als LiveCD auf meinem Server laufen lassen.
    An sich eine super Sache, jedoch ist die Schreibperformance wirklich mies. Er schafft nichtmal 1Mb/s.

    Lesend ists kein Problem, dort ist alles in bester Ordnung.

    Ist das etwa normal?

    Habs mit WLan und Fast Ethernet versucht. Liefern beide das schlechte Ergebnis.

    CPU Auslastung des Servers liegt bei rund 5%, Ram ist nur 10% benutzt, die Platten sind mit UFS formatiert und ich greife von Mac mit AFP zu.
     
  2. DukeNuke2

    DukeNuke2 Wagnerapfel

    Dabei seit:
    17.01.06
    Beiträge:
    1.559
    ist nicht wirklich normal... hast du mal versucht direkt zu verkabeln? also den switch weglassen und per crossover an den server gehen...
    ist einfach nur mal ein test um zu sehen ob der switch falsch tickt.
     
  3. Peitzi

    Peitzi Blutapfel

    Dabei seit:
    07.08.07
    Beiträge:
    2.595
    Ich hab grad leider kein Crossover da.
    Aber an der Verkabelung habe ich nichts verändert.

    Normalerweise läuft der Server unter WinServer2003.
    Ist die Platte dort NTFS formatiert und freigegeben, kann ich per SMB von Mac drauf zugreifen und erreiche ganz normale Schreibraten, sprich deutlich höhere als 1Mb/s wie es bei FreeNas ist.

    Am Switch kanns daher, meines Erachtens nach, nicht liegen, sondern muss was mit der NAS Software zu tun haben.
     
  4. DukeNuke2

    DukeNuke2 Wagnerapfel

    Dabei seit:
    17.01.06
    Beiträge:
    1.559
    freenas basiert auf BSD. und der netzwerkstack bei BSD ist.... naja, sagen wir mal verbesserungswürdig... daher kann es beim aushandeln der geschwindigkeiten im netz schnell mal zu problemen kommen. daher mal ein direkt-connect versuchen. das sollte auch mit einem normalen patch kabel funktionieren da die meisten netzwerkkarten einen auto-crossover haben. versuchen kannst du es ja mal.
    ich rate aber eher zu einem anderen os für die netzwerkfreigaben... opensolaris gibt es auch als live-cd. du kannst da ja mal damit versuchen. nur ist die administration da nicht ganz so einfach ;)
     
    Peitzi gefällt das.
  5. Peitzi

    Peitzi Blutapfel

    Dabei seit:
    07.08.07
    Beiträge:
    2.595
    Ah ok. Das BSD da so zickig ist, wusste ich nicht.

    Ich werd mich dann mal bei Solaris umschauen. Bis Dato bleibts dann erstmal bei Server2003.

    Besten Dank für deine Ausführungen!
     
  6. DukeNuke2

    DukeNuke2 Wagnerapfel

    Dabei seit:
    17.01.06
    Beiträge:
    1.559
    kein problem... viel spass beim weiter testen ;)
     

Diese Seite empfehlen