1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

FPS-Problem am externen Monitor

Dieses Thema im Forum "Mobil-Macs" wurde erstellt von BlackDodo, 06.10.09.

  1. BlackDodo

    BlackDodo Jamba

    Dabei seit:
    25.05.07
    Beiträge:
    59
    Huhu Apfeltalker! :)

    Neue Hardware, neue Probleme. ;)
    Den passenden Thread dazu fand ich leider nicht... daher mal ein Neuer:

    Das Setup (heute geliefert *g*):
    - das größte 15'' MacBook Pro (in Standard-Konfiguration = 2.8GHz, 512MB Geforce, 4GB RAM)
    - 24'' externer Monitor dazu, natürlich von Apple. ;)

    Was hatte ich damit vor:
    Irgendwie nervt mich die seltsame Mausbeschleunigung unter Mac OS beim Zocken, daher wieder, wie immer, Boot Camp genutzt:
    Windows XP SP3
    Wie immer, Treiber von CD für Windows installiert, Updates gemacht, etc.
    Alles tadellos erkannt, funzt perfekt, wie man das eben von MacBooks kennt. :)

    Allerdings:
    Starte ich nun WoW und lasse es auf dem MBP-Monitor laufen, geht zwar alles.
    Sobald ich das WoW-Fenster aber auf den externen Monitor verschiebe, bricht die FPS-Rate ein:
    100 FPS interner MPB-Monitor
    10 FPS am externen.

    Einziger Unterschied ist, wie gesagt:
    Ich verschiebe das Fenster vom einen auf den anderen Monitor. ;)
    Hab an den WoW-Grafik-Einstellungen geschraubt. Aber daran kann's eigentlich nicht liegen, am MBP-Moni sind es ja über 100 FPS.


    Falls das schon mal jemand gesehen hat, erzählt mir mehr davon. :)
    Falls nicht, hoffe ich, dass jemand eine Idee hat. ;)

    Gute Nacht! :)
    Dodo

    Edith hat gerade getestet:
    Die FPS-Rate skaliert mit der Fenstergröße.
    Mache ich das WoW-Fenster sehr klein, habe ich auch auf dem externen 24'' 80 FPS.
    Vollbild habe ich dann 5 FPS.... irgenwie seltsam. :-D
     
  2. VisioNOIR

    VisioNOIR Holländischer Prinz

    Dabei seit:
    23.08.09
    Beiträge:
    1.870
    Hallo!

    Das findest Du seltsam? Das ist IMHO das Normalste der Welt. Wenn mehr berechnet werden muss, dauert es nun mal etwas länger. ;)

    Versuch mal WoW nicht im Fenster-Modus (da gibt's eine Einstellung im WoW) laufen zu lassen. Mir ist auch schon diverse Male aufgefallen, dass "Fenster-OpenGL" mit der Dose anscheinend rechenintensiver ist, als wenn die Grafikkarte den ganzen Monitor ganz alleine für eine Applikation beanspruchen kann.
     
  3. BlackDodo

    BlackDodo Jamba

    Dabei seit:
    25.05.07
    Beiträge:
    59
    Ja, das war ja soweit auch ok. ;) Aber es skaliert halt extrem.
    Minimalfenster: 100+ FPS
    Maximiert: 5 FPS oder so. ;)

    Werde ich testen, mache mir aber nicht viel Hoffnungen. Wie gesagt, im maximierten Fenstermodus auf dem INTERNEN MBP-Monitor läuft es ja auch mit 100+ FPS.
    Schiebe ich das Fenster (ohne die Größe zu ändern!) auf den externen Monitor, habe ich nur noch ein Zehntel der FPS.

    Testen werde ich's morgen. Derzeit läuft der Migrationsassistent. ;)
    Der braucht die halbe Nacht, weil es im schlecht sortiertesten Elektroladen der Welt (a.k.a. MediaMarkt) natürlich keine FireWire800-Kabel gab (O-Ton: "Sowas gibt's?" *omfg*) und ich per Crossover 50GB Daten migrieren muss ... aber das ist nicht das Problem dieses Threads. ;)

    Test folgt morgen, wie gesagt.
    Für weitere Ideen bin ich dankbar, da ich mir von der Nicht-Fenstermodus-Variante nicht viel erhoffe. :D
     
  4. VisioNOIR

    VisioNOIR Holländischer Prinz

    Dabei seit:
    23.08.09
    Beiträge:
    1.870
    Meine Beobachtungen skalierten auch eher überproportional; zugegebener Maßen aber nicht so extrem wie bei Dir. Wie geschrieben, Vollbild verhält sich in der Dose anders als "Vollfenster".

    Ansonsten könnte es noch am Treiber liegen. Versuch es mal mit den aktuellsten Treibern von der nVIDIA-Homepage.
     

Diese Seite empfehlen