1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Folder in der Seitenleiste verschwindet

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Daisy, 08.02.06.

  1. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366
    Hilfe!

    seit 10.4.4 will mein Mac nicht mehr, dass ich arbeite ;). Der Folder '>>>> work', den ich mir praktischerweise in die Seitenleiste gezogen habe, bleibt da nicht mehr - er verschwindet nach jedem Neustart (das Original liegt auf einer externen HD, die nicht immer dranhängt - der Fehler tritt aber auch auf, wenn sie angeschlossen ist).

    Weiss jemand wie ich das abstelle oder warum das so ist?


    Grüße,

    Daisy
     
    Dante101 gefällt das.
  2. Dante101

    Dante101 Ralls Genet

    Dabei seit:
    11.10.05
    Beiträge:
    5.052
    Mag er vielleicht die Sonderzeichen nicht? (>>>> work)
     
  3. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366
    Vielen Dank für den Tipp, Dante,

    ich werd's mal mit was 'normalerem' probieren - aber eigentlich ist '>' ist ja kein Sonderzeichen (kommt im ASCII-Sortiment vor und ist keines der 'Tabu'-Zeichen in Dateinamen) und ausserdem ging es bei den früheren OS X-Versionen einwandfrei - hmm - ich werde Bericht erstatten was es ergeben hat (jetzt kann ich grad kein Reboot brauchen ;))

    Grüße,

    Daisy
     
  4. Anindo

    Anindo Wagnerapfel

    Dabei seit:
    19.09.05
    Beiträge:
    1.583
    Nee, dieses Feature hat Apple ausgebaut und ich kann dir auch sagen warum. Wenn man unter X.3.x Ordner aus dem Netzwerk in die Leiste geschoben hat, klappte das ein paar Wochen, bis auf einmal nach dem Start nur noch ein Fenster mit Server-Passwortabfrage kommt, man aber nichts mehr eingeben oder irgendwas anderes machen kann. Das System schießt sich quasi selber ab und man kriegt den Benutzer nur an´s laufen, wenn man die sidebar.plist mit Root-Account oder sonstwie aus den Preferences löscht. Wahrscheinlich hat Apple den Fehler nicht gefunden und löscht deshalb alle Verzeichnisse aus externen Volumes nach dem Neustart. :-[
     
  5. Dante101

    Dante101 Ralls Genet

    Dabei seit:
    11.10.05
    Beiträge:
    5.052
    Komisch. Bei uns funktioniert das schon über ein Jahr. Ohne Probleme.
     
  6. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366

    ... ist bei mir ja auch kein Netzwerkvolume, sondern nur eine externe (FireWire) Festplatte. Die Problematik mit Hängern bei nichtvorhandenen Netzwerk-Volumes die automatisch angemeldet werden sollen kenn' ich nur aus OS8/9-Zeiten.
     
  7. Dante101

    Dante101 Ralls Genet

    Dabei seit:
    11.10.05
    Beiträge:
    5.052
    Was die Hänger bei nicht gefundenen Server-Platten betrifft, muss ich anindo schon recht geben. Das dauert ewig, wenn man zu einer Platte verbinden will und der Rechner sie nicht findet. Aber wenn sie wieder angeschlossen wird funktioniert es trotzdem wieder jedes Mal.
     
  8. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366
    Vielen Dank nochmal,

    die Ursache habe ich nicht herausgefunden. An den 'Sonderzeichen' scheint's aber nicht zu liegen. Da ich keine Zeit habe, um weiterzuforschen, habe ich's einfach durch ein Skript ersetzt, das mir den Ordner öffnet ;)

    Grüße,

    Daisy
     
  9. Dante101

    Dante101 Ralls Genet

    Dabei seit:
    11.10.05
    Beiträge:
    5.052
    Ja, auch nicht blöd. Jetzt noch das Icon des Originals auf das Script kopiert und keiner merkt den Unterschied.

    Aber da kommt mir die Idee:
    Man könnte doch ein Script schreiben, besser ein Droplet, das, wenn man einen Ordner auf dieses zieht, es ein Script für eben diesen Ordner in die Seitenleiste legt (wie von Dir manuell gemacht). Das wär doch mal der Wahnsinn. Und zugleich kopiert eben dieses Droplet das Aussehen des Originals und fügt es in die Info des erstellten scripts (wie oben beschrieben)

    Geht das?

    (euphorischen) Gruß
    Daniel
     
  10. DBertelsbeck

    DBertelsbeck Tiefenblüte

    Dabei seit:
    20.04.04
    Beiträge:
    6.425
    Und hier die Lösung:
    Seit Tiger werden externe Platten nicht mehr beim Systemstart, sondern erst bei der Benutzeranmeldung gemountet. Da pssiert es eben, dass Dinge, die auf der ext. Platte liegen, nicht gestartet werden, z.B. Bilder aus iPhoto als Schreibtischhintergrund, Programme in den User-Startobjekten und eben auch Folder in der Seitenleiste.

    Die Lösung findet sich hier: AutoDiskmount
     
  11. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366
    Hallo und vielen Dank für die Lösung.

    Bin nur noch nicht ganz sicher, ob's auch die Lösung ist. Das was dort beschrieben ist, klingt einleuchtend: Tiger findet das Volume nicht, da es später mountet - ok - und dann? Dann nimmt er alles aus der Seitenleiste raus, was er nicht findet?

    Wenn das auch ein neues 'Feature' von Tiger ist, dass er Aliase von nichtgefundenen Originalen aus der Leiste entfernt, dann hilft mir der Tipp leider nix, denn meine externe Platte ist nicht immer angeschlossen. Dann kann ich mir die beschriebene Prozedur sparen und würde eher zu einem Ausbau der Skriptlösung tendieren - danke für die Anregung, Daniel :)
    Weisst Du wie sich das verhält, DBertelsbeck?

    Grüße,

    Daisy
     
  12. Anindo

    Anindo Wagnerapfel

    Dabei seit:
    19.09.05
    Beiträge:
    1.583
    Nein, ich habe von einem Bug geredet, der auftaucht, wenn man Ordner vom Server (in diesem Fall Windows Server über AFP) in die Seitenleiste zieht. Bei uns wurden zwei Macs deshalb vorübergehend unbenutzbar, obwohl der Server zu der Zeit normal erreichbar war. Da das Problem erst Wochen später auftauchte, war es schwierig einen Zusammenhang herzustellen. Unser Admin stand ziemlich ahnungslos da und ich weiß nicht, ob er ohne mich drauf gekommen wäre, das mit der sidebar.plist wenigstens mal auszuprobieren. Aliase im Dock oder auf dem Desktop sind nicht betroffen, genauso wie externe Festplatten.
     
  13. Dante101

    Dante101 Ralls Genet

    Dabei seit:
    11.10.05
    Beiträge:
    5.052
    In meinem Fall waren es Serverplatten eines Sun-Servers.
     
  14. DBertelsbeck

    DBertelsbeck Tiefenblüte

    Dabei seit:
    20.04.04
    Beiträge:
    6.425
    Oder setzt, wie auch unter dem angegebenen Link beschrieben, Standardicons ein.
    Was nützt es Dir, wenn ein Alias angezeigt wird, aber das Original nicht zur Verfügung steht, da die Platte nicht dran ist ?
     
  15. Daisy

    Daisy Uelzener Rambour

    Dabei seit:
    14.01.06
    Beiträge:
    366
    Das Problem ist, dass das Alias auch dann nicht mehr da ist, wenn ich die Platte wieder dran habe :(
     
  16. DBertelsbeck

    DBertelsbeck Tiefenblüte

    Dabei seit:
    20.04.04
    Beiträge:
    6.425
    Nun, wenn Du die Platte nachher anstöpselst, einfach den Finder neu starten, Kannst Du, glaube ich, einfach machen, in dem Du auf das Docksymbol mit der rechten Maustaste klickst und neu starten auswählst, oder im Apfelmenu - Beenden. In dem Fenster Finder beenden = Finder Neustart.
    (Sorry, sitze im Büro am PC)
     
  17. RaRe

    RaRe Auralia

    Dabei seit:
    07.11.04
    Beiträge:
    199
    Seitenleiste Festplatten

    Hallo,
    ich habe ein ähnliches Problem. Bei mir verschwindet keine ext. Platte, sondern das Startvolume.

    Ich habe in den Finder-Einstellungen für die Seitenleiste die Festplatte aktiviert, aber sie ist nicht sichtbar - genauso wenig wie auf dem Desktop.

    Ziehe ich die HD manuell in den oberen Teil der Seitenleiste (in den unteren geht es nicht, da gehört sie ja auch nicht hin), dann ist sie etwa 1 sek dort und verschwindet wieder.

    Ich habe eben auf Tiger geupdatet. Keine Probleme. Ich habe das Comboupdate auf 10.4.5 nun auch schon drei mal installiert (in der Hoffnung, es täte sich da was). Rechte sind auch immer schön repariert.

    Kennt jemand das Problem? In der Suche konnte ich leider nichts finden..

    Gruß
    Raphael
     
  18. Dante101

    Dante101 Ralls Genet

    Dabei seit:
    11.10.05
    Beiträge:
    5.052
    Die anderen Platten sind sichtbar? Oder auch nicht? Wenn nicht, könnte es einfach eine Darstellungsoption sein. Den Finder aktivieren und Command-J drücken. (Darstellungsoptionen) Dort kann man auswählen ob Volumes angezeigt werden sollen, oder nicht.

    Gruß
    D.
     
  19. RaRe

    RaRe Auralia

    Dabei seit:
    07.11.04
    Beiträge:
    199
    Danke! Nein, das hilft leider nicht. Im Finder ist alles soweit richtig eingestellt. Unter allen Einträgen mit Apfel+Komma geht nur die Festplatte nicht. CDs, Images, Netzwerk und Computer sind in der Seitenleiste sichtbar. Genauso wie auch auf dem Desktop.
     

Diese Seite empfehlen