1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Firewall eingeschaltet - wo sind die Netzwerkfreigaben?

Dieses Thema im Forum "macOS & OS X" wurde erstellt von daniellll, 09.10.08.

  1. daniellll

    daniellll Carola

    Dabei seit:
    16.08.05
    Beiträge:
    110
    hallo,

    ich habe u. a. eine dreambox und meinen qnap-server im netz. diese werden gefunden, wenn die os x firewall deaktiviert ist, bzw. alle verbindungen zulässt. wie kann ich die firewall dennoch aktivieren und meine freigaben bzw. geräte im netz finden?

    daniel
     
  2. Samsas Traum

    Samsas Traum Pommerscher Krummstiel

    Dabei seit:
    24.04.08
    Beiträge:
    3.030
    Systemeinstellungen -> Sicherheit -> Firewall
     
  3. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Die Application-Firewall macht keine Einschränkungen bezüglich ausgehender Verbindungen. Wo also ist Dein Problem?
     
  4. daniellll

    daniellll Carola

    Dabei seit:
    16.08.05
    Beiträge:
    110
    danke euch vorerst für die antworten.

    anbei zwei bilder zur verdeutlichung:

    [​IMG]

    [​IMG]
     
  5. Samsas Traum

    Samsas Traum Pommerscher Krummstiel

    Dabei seit:
    24.04.08
    Beiträge:
    3.030
    Ist jawohl logisch, die Firewall begrenzt die eingehenden Verbindungen, ScreenSharing ist jawohl ne ausgehende Verbindung. Hast wohl auf dem anderen ScreenSharing Teilnehmer nicht freigegeben!
     
  6. daniellll

    daniellll Carola

    Dabei seit:
    16.08.05
    Beiträge:
    110
    ignoriere bitte die screensharing freigabe, diese war automatisch eingestellt, weil ich screensharing verwende. aber wie komme ich an die freigaben ran, wenn die firewall aktiviert ist?

    daniel
     
  7. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Die Erreichbarkeit der "Freigaben" auf Rechner B haben nichts mit der Firewall auf Rechner A zu tun. Du kannst die Firewall auf A ein- oder ausschalten; das ist egal.

    Warum braucht eine PeeCee-Freigabe eine eingehende Verbindung zum Mac?
     
  8. daniellll

    daniellll Carola

    Dabei seit:
    16.08.05
    Beiträge:
    110
    ich habe nur 1 rechner!
     
  9. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Dann mußt Du halt den entsprechenden Windows-Dienst auf dem Host-Mac freigeben mit der dritten Firewall-Option.
     
  10. daniellll

    daniellll Carola

    Dabei seit:
    16.08.05
    Beiträge:
    110
    danke. nur wie mache ich das?
     
  11. Samsas Traum

    Samsas Traum Pommerscher Krummstiel

    Dabei seit:
    24.04.08
    Beiträge:
    3.030
    In der Liste, in der auch Screensharing drin ist, ist unten drunter doch ein "+" und ein "-". Da kannste rumpfuschen wie du lustig bist ;)
     
  12. daniellll

    daniellll Carola

    Dabei seit:
    16.08.05
    Beiträge:
    110
    danke. das ist mir auch schon aufgefallen. ;) aber ich wüsste nicht, was ich da auswählen soll. mhm.
     
  13. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Die beiden Programme bzw. den Emulator auswählen?
     
  14. daniellll

    daniellll Carola

    Dabei seit:
    16.08.05
    Beiträge:
    110
    welche beiden programme? es sind geräte im netzwerk.
     
  15. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Dann sollte die Firewall auf OS X darauf keinen Einfluß haben. Oder laufen da Clientprogramme/Treiber, die von den Geräten aus dem Netz angesprochen werden?
     
  16. Peter/Peet

    Peter/Peet Empire

    Dabei seit:
    29.06.07
    Beiträge:
    89
    Hallo.
    Ähnliche Schwierigkeiten mit Windowsfreigaben hatte ich auch. Ich habe dann in Das Praxisbuch MacOS X von Kai Surrendorf Seite 373 Hinweise gefunden.

    Da steht zusammengefasst, Zitat:
    "Hinweis - Die Anzeige der Rechnernamen mit Windows Vista funktionierte zur Drucklegung noch nicht immer einwandfrei. Es ist möglich, das ein Vista-Systeme sich in der Darstellung Netzwerk einfügt, aber dennoch nicht erreichbar ist."

    Da ich aber noch normal mit XP im Netzwerk arbeite war für mich interessanter: "... Rechner die Ihren Namen über Bonjour kommunizieren werden immer im Finder angezeigt... " Das war für mich die eifachste Lösung, ich habe auf dem Windows-System Bonjour installiert.

    Ansonsten steht hier: "... Der Gerätename, der unter Windows mit COMPUTER-Name bezeichnet wird, wird über das NetBIOS-Protokoll im Netzwerk über den Port 137 kommuniziert. Dies erfolgt als Broadcast im lokalen Netzwerk. Entgegennehmen muss diese Datenpakete der Dienst nmbd, der nur dann aktiv ist, wenn Sie in den Systemeinstellungen im Bereich Sharing auch Dateien über SMB bereitstellen."

    Probier vielleicht das mal aus. Bonjour kommuniziert soweit ich weiß auf Port 5353, also falls das nachinstalliert wird ggf. auch mal wegen der Ports schauen.

    Ein Wort noch zur Firewall... so wie Du es eingestellt hast kann es nicht gehen.
    Stellst Du die FW auf "alle eingehenden Verbindungen erlauben" ist sie logischerweise aus. Bei "nur notwendige Dienste erlauben" gibt es keine Ausnahmen. Es wird nur durchgelassen was wirklich absolut notwendig ist, das ist meines Wissens mDNSResponder, der für Bonjour benötigt wird, configd verwaltet die Netzwerkeinstellungen und racoon falls Du mit VPN rausgehen willst. Mehr nicht. Die EInstellung ist gedacht für unsichere Umgebungen, blockt halt alles. Dann gibt es noch "Zugriff auf bestimmte Dienste und Programme festlegen" hier ist das Verhalten wie eine Aplication FW. Wenn ein Programm eine Verbindungen von Außen haben möchte wirst Du gefragt, kannst aber auch selber manuell hinzufügen. Auf Deinen Screenshots sieht man, dass Du da die falsche Einstellung benutzt.

    LG, Peet.
     
    #16 Peter/Peet, 10.10.08
    Zuletzt bearbeitet: 10.10.08

Diese Seite empfehlen