1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

FFmpegX will x264 nicht muxen

Dieses Thema im Forum "Musikproduktion" wurde erstellt von fragreaver, 02.01.07.

  1. fragreaver

    fragreaver Gast

    Hi AT! :)

    Ich habe mir die Victoria's Secret Fashion Show aufgenommen. Allerdings ist der Film, dank 1080i, bei 40 Minuten Laufzeit knappe 5.7 Gigabyte groß. Da mein Monitor eh nicht mehr mitmacht, wollte ich den Film auf 720p bringen. Er encodiert auch wunderbar und die Qualität ist Spitze. Allerdings erstellt er eine Video- und Audio-Datei, sprich ich hab zwar Video, aber keinen Ton . Obwohl ich nix dergleichen eingestellt hab. Ich hab auch nirgendwo etwas gefunden, wie man H.264 muxen könnte. Ich poste einfach mal die Screenshots mit meinen Einstellungen:

    [​IMG] [​IMG][​IMG]
    [​IMG] [​IMG]

    Ich habe auch H.264(ffmpeg) probiert, aber dann wird der Film weitaus größer.
    Ich würde es ja mit Quicktime versuchen, allerdings hab ich kein Geld für das olle Plugin
    Vielleicht weiß ja jemand Rat :)

    mfg
     
  2. dusty1000

    dusty1000 Weißer Trierer Weinapfel

    Dabei seit:
    22.09.06
    Beiträge:
    1.508
    Hast du schon mal versucht, statt .AC3 im Audio Tab einfach mal "überspringen" einzustellen ?
    Dann sollte das Audiosignal ohne neuencodierung einfach durchgereicht werden.
     
  3. MasterDomino

    MasterDomino Roter Eiserapfel

    Dabei seit:
    28.04.05
    Beiträge:
    1.440
    Außerdem würde ich den Sound nicht 5.1 codieren, wenn das Ausgangssignal Stereo war. Vielleicht hilft das. Was ich außerdem nicht machen würde ist, "Two Pass Encoding" und "Constant Bitrate" beide zu wählen. Entweder willst du eine konstante Bitrate, dann muss er das Material aber nicht voranalysieren, oder du willst, dass er mit der Bitrate variiert und dann macht es Sinn, ihn das Material vorzuanalysieren, um zu wissen, wo er mit der Bitrate nach unten gehen kann.


    Gruß, MasterDomino
     
  4. fragreaver

    fragreaver Gast

    Passthrough bringt dasselbe Ergebnis. Ich probiers nochmal ohne 2nd Pass und auf Stereo.

    edit» ebenfalls keine veränderung :(
     
    #4 fragreaver, 03.01.07
    Zuletzt von einem Moderator bearbeitet: 03.01.07
  5. dusty1000

    dusty1000 Weißer Trierer Weinapfel

    Dabei seit:
    22.09.06
    Beiträge:
    1.508
    Womit spielst du den Film denn ab ?
     
  6. fragreaver

    fragreaver Gast

    Mit VLC. Ich habe die TS-Datei spaßeshalber auch mal in eine mpeg umgewandelt, da FFmpegX laut dem Entwickler
    Probleme mit TS hat. Allerdings hatte ich dasselbe Problem, nachdem ich es mit Mpeg Streamclip in MPEG umgewandelt habe.
    Jetzt versuche ich, Audio- und Videospur in eine mov zu exportieren. Ich hoffe, das klappt von der Qualität her, hab dieselben
    Einstellungen wie in der "originalen" x264-Datei verwendet und auch denselben Codec. Ma guckn! :)
     
  7. fragreaver

    fragreaver Gast

    Ich habs jetzt mit Quicktime gemacht, war ziemlich einfach :)

    1. Film-Datei öffnen
    2. Audio-Datei öffnen
    3. Audio-Fenster auswählen, ? + A, ? + C
    4. Video-Fenster auswählen, Bearbeiten -> Zum Film hinzufügen
    5. Datei -> Speichern

    Man bekommt eine MOV-Datei, mit Ton! :D

    Danke für eure Hilfe
     
  8. Dante101

    Dante101 Ralls Genet

    Dabei seit:
    11.10.05
    Beiträge:
    5.052
    Leider ist das ein workaround. Eine Lösung (obwohl ich das Problem zurzeit nicht habe) wäre für ffMpegX auch interessant.

    Vielleicht hat ja trotz Deiner Eigenhilfe jemand Lust, eine Lösung zu posten - für den Fall der Fälle.

    LG
    Daniel
     

Diese Seite empfehlen