1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

ffmpegX Auflösungs-Problem

Dieses Thema im Forum "Musikproduktion" wurde erstellt von Vorzeiger, 21.01.06.

  1. Vorzeiger

    Vorzeiger Granny Smith

    Dabei seit:
    15.02.05
    Beiträge:
    15
    Holla, ich möchte ein divx-Filmchen von einem aufgenommenen Eyetv-Programm durch ffmpegX erstellen. So ziehe ich das mpeg in das Quellfenster und lade das Divx-ffmpeg Preset. Ich benutze die Autocrop-Funktion um die schwarzen Balken zu entfernen. Wenn ich nun allerdings das Filmchen codieren lasse (die Auflösung ist entsprechend den schwarzen Stellen reduziert) erzeugt er mir ein avi im 4:3 Format!!! Ich habe die verschiedensten Möglichkeiten bei der Auflösung schon probiert... er erstellt mir immer ein 4:3 Video (sebst bei 1600x200). Versuche ich die ganze Schose mir dem "mencoder" kommt die richtige Auflösung raus allerdings alles ohne Ton!!!

    Kann mir einer bei dem Problem weiterhelfen?!? Die neusten Binaries habe ich installiert...
     
  2. LaForce

    LaForce Transparent von Croncels

    Dabei seit:
    18.01.06
    Beiträge:
    309
    hi vorzeiger,
    du kannst doch im Video-Tab von ffMpegX das Seitenverhältnis fest einstellen. Schon probiert?
     
  3. Vorzeiger

    Vorzeiger Granny Smith

    Dabei seit:
    15.02.05
    Beiträge:
    15
    Darum geht es ja gerade... egal was ich im Video-Tab einstelle... das Proggy macht mir mit dem ffmpeg-preset immer ein 4:3 Verhältnis. Ich nehm mal stark an das das "Auflösungs"-Wert maßgebend ist und nicht das "Verhältnis". Auf jeden Fall möchte ich die schwarzen Balken entfernen... mach also Autocrop und verringer die Auflösung dementprechend. Also Ergebnis kommt allerdings eine komplett andere Auflösung raus (4:3 eben)... Keine Ahnung ob ich mich verständlich ausdrücke...
    Eins steht fest... Definiere ich mit dem ffmpeg Preset eine Auflösung wird die "Höhe" einfach ignoriert!!!
     
  4. astraub

    astraub Champagner Reinette

    Dabei seit:
    17.06.04
    Beiträge:
    2.651
    Hallo,

    was hast Du denn im Video Tab bei "Verhältnis" angegeben? Unbestimmt? Zudem hängt es auch davon ab, was Dein Abspielgerät mit einem ungewöhnlichen Seitenverhältnis macht - hast Du dort schon einmal die Optionen überprüft (Stichwort 16:9 Modus).

    Gruss
    Andreas
     
  5. LaForce

    LaForce Transparent von Croncels

    Dabei seit:
    18.01.06
    Beiträge:
    309
    Jo... ich könnte mir vorstellen, daß dein Seitenverhältnis nicht zusammenpasst. DivX nimmt nicht alles was man einstellen kann. Im Zweifel kannst Du in der DivX-Software ausprobieren, ob sich dein Seitenverhältnis einstellen läßt. Falls nicht, geht's auch nicht und du mußt das nächstbeste nehmen
     
  6. Vorzeiger

    Vorzeiger Granny Smith

    Dabei seit:
    15.02.05
    Beiträge:
    15
    Wie gesagt, das Seitenverhältnis ignoriert er einfach. Egal was ich hier einstelle, die Breite im Auflösungsfenster verwendet er, die Höhe allerdings wird ignoriert und raus kommt ein 4:3 Bild. Aber wie ich schon geschrieben habe, das passiert nur mit der "ffmpeg" Codec-Einstellung. Bei "mencoder" funktioniert das Seitenverhältnis (mit den selben Einstellungen wie zuvor) allerdings hat der Film nachher keinen Ton!
    Sollte ich vielleicht irgendwo mal die Preferencen löschen oder was könnte das denn sein?
     

Diese Seite empfehlen