1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Festplattenproblem

Dieses Thema im Forum "macOS & OS X" wurde erstellt von abiogenesis, 01.07.09.

  1. abiogenesis

    abiogenesis Macoun

    Dabei seit:
    22.07.08
    Beiträge:
    122
    Hallo,

    als ich gestern bei meinem iMac einen Neustart machte, bootete OSX bis zum grauen Apfel und dem drehenden Kreis. Kurz darauf schaltete er sich komplett ab. Wieder eingeschaltet selbiger Ablauf. Nochmal eingeschaltet nur noch ein grauer Bildschirm nach Startton. Nach 10x Ein-Ausschalten und gedrückter D-Taste hat der Hardwaretest von der Tiger DVD funktioniert -> Ergebnis: keine Probleme.
    Als nächstes mit der Tiger DVD gebootet und das Festplattendienstprogramm gestartet. Volumen reparieren ausgewählt -> Ergebnis: Abbruch mit folgender Meldung (Anhang: FDPD.jpg) Na gut, muß halt ein schwereres Geschütz her.
    Mit Disk Warrior von einer bootbaren DVD gestartet und einen Directory Rebuild durchgeführt -> Ergebnis: Anhang DW Report.pdf
    Danach mit der LEO Upgrade DVD gestartet und nochmal das FPDP mit Volumen reparieren durchlaufen lassen -> Ergebnis: keine Probleme. Mac neu gestartet, OSX bootet normal durch. Folgendes Logfile hab ich in Library/Logs/DirectoryService gefunden, Anhang: DirectoryService.txt
    Als zusätzliche Information hier noch der Aufbau meiner Festplatte, ermittelt mit dem von Rastafari geposteten Befehl:

    Code:
    Disk: /dev/rdisk0	geometry: 38913/255/63 [625142448 sectors]
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    ------------------------------------------------------------------------
     1: EE    0   0   2 -   25 127  14 [         1 -     409639] <Unknown ID>
     2: AF   25 127  15 - 1023  67  62 [    409640 -  557580288] HFS+        
    *3: 07 1023 149   1 - 1023  80  23 [ 558252072 -   66890336] HPFS/QNX/AUX
     4: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
    gpt show: /dev/rdisk0: Suspicious MBR at sector 0
          start       size  index  contents
              0          1         MBR
              1          1         Pri GPT header
              2         32         Pri GPT table
             34          6         
             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
         409640  557580288      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
      557989928     262144         
      558252072   66890336      3  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
      625142408          7         
      625142415         32         Sec GPT table
      625142447          1         Sec GPT header
    Vielleicht kann mir einer von euch sagen was da los war oder aber ob es sich um ein Hardwareproblem handelt da ich außerdem noch dieses Problem habe.
    Wenn ich den Mac in den Ruhezustand schicke und wieder aktiviere geht gar nichts mehr. Ich sehe OSX kann aber nichts mehr machen. Nur noch hart ausschalten. Wenn ich den Mac ausschalte und nach paar Stunden wieder einschalte wird meine Festplatte nicht erkannt, auch keine DVD oder USB Stick (Startton -> grauer Bildschirm -> nichts). Mein Workaround sieht so aus. X-maliges Ein -Ausschalten und D-Taste drücken bis der Mac irgendwann den Hardwaretest von der DVD startet. Danach funktioniert der Start wieder reibungslos, bis zum nächsten Ausschalten. Damit das Problem auftritt, muss der Mac ca. mehr als 1h ausgeschaltet sein. Ansonsten funktioniert der Start normal. Im letzter Zeit schalte ich meinen Mac gar nicht mehr aus.
    Da ich keine Garantie mehr habe und ein eventueller Festplattenwechsel oder ähnliches mit sehr viel Aufwand verbunden ist, kann mir noch einer irgendwelche Tipps zu meinem Problem geben. Die üblichen Sachen wie Rechte reparieren, PRAM, VRAM, SMC zurücksetzen hab ich schon gemacht.

    Danke fürs Bemühen
     

    Anhänge:

  2. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    deiner signatur entnehme ich, dass du eine time capsule hast. dann hast du doch bestimmt ein time machine backup. wenn der fehler im system liegt, könnte eine komplette formatierung der platte und anschliessendes wiederherstellen eines früheren backups abhilfe schaffen. wichtige daten, die nicht im backup enthalten sind, sollten natürlich vorher auf cd gesichert werden.

    was zeigt das FPDP beim S.M.A.R.T. status an?
     
  3. abiogenesis

    abiogenesis Macoun

    Dabei seit:
    22.07.08
    Beiträge:
    122
    Beim S.M.A.R.T. Status steht: Überprüft
    Ja das mit der kompletten Neuinstallation hab ich mir auch schon gedacht. Möchte halt vorher alle anderen Möglichkeiten checken. Könnte ja auch Hardware sein.
     
  4. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    hast du zufällig bootcamp im einsatz?
     
  5. abiogenesis

    abiogenesis Macoun

    Dabei seit:
    22.07.08
    Beiträge:
    122
    Ja mit Windows XP.
     
  6. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    google das mal:

    /dev/rdisk0: Suspicious MBR at sector 0
     
  7. abiogenesis

    abiogenesis Macoun

    Dabei seit:
    22.07.08
    Beiträge:
    122
    Danke,

    finde da aber nur Probleme bei Triple-Boot Installationen oder wie man am besten die Bootcamp Partition loswird. Möchte meine aber ganz gern behalten. Einen Tip zu rEFIt hab ich noch gefunden. Da ist ein Tool (gptsync.efi) dabei welches die GPT und MBR Partitionstabellen synchronisiert. Benutze rEFIt schon und hab das Tool mal verwendet, die Tabellen sind bei mir synchron. Und ja, auch ohne rEFIt treten die Probleme bei mir auf.
     
  8. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.902
    Darauf sollte man nicht sein Geld verwetten.
    Du solltest folgendes tun:
    - Alle Arten von nicht unbedingt benötigten Peripheriegeräten trennen, einschliesslich Netzwerk. CD/DVD aus dem Laufwerk rausnehmen ggf nicht vergessen.
    - Gerät vom Stromnetz trennen und einige Minuten abwarten vor dem wieder anstecken. (Noch nichts weiteres anstecken)
    - Startversuch mit NV-RAM Reset (Command+Wahl+P+R beim Einschalten drücken und halten, bis der Startgong zum dritten mal kommt.)

    Wenn dieser Start jetzt klappt, einfach mal in diesem Zustand (ohne Gerödel) eine Weile beobachten, Ruhezustand testen usw.
    Eine System-Neuinstallation durchzuführen ist nach solchen Crashs sicher eine gute Idee.
    (DW konnte offensichtlich an einigen Stellen nur Behelfsreparaturen durchführen. Wo genau, sagt das Protokoll leider nicht.)
    Wenn das in diesem Zustand rund läuft, teste einzeln ein externes Gerät nach dem anderen, um den Sünder zu finden. (Mit reichlich Geduld und am besten mit einer Strichliste zum abhaken daneben, wenns mehr ist.)

    Wenn es nicht läuft, ist wohl leider der Gang zur Werkstatt bzw der Griff zum Schraubenzieher gefragt. Rein verdachtsmässig würde ich auf eine HD mit Hitzeschaden tippen (die haben gerne Anlaufschwierigkeiten, sobald sie richtig abgekühlt sind...)
    RAM könnte auch hinüber sein. Oder oder oder... Ferndiagnosen sind leider nicht so einfach. o_O
     
  9. abiogenesis

    abiogenesis Macoun

    Dabei seit:
    22.07.08
    Beiträge:
    122
    Danke,

    werde deine Empfehlungen mal durchgehen und schauen was passiert. Das mit dem Hitzeschaden der HD klingt am plausibelsten, hatte mir schon so was ähnlich gedacht. Mich wundert nur das ich auch nicht von DVD oder USB-Stick booten kann, habe auch schon an das Logic Board gedacht.
    Nun gut werde nochmal alles testen und wenn nicht besser wird, Schraubenzieher frei!
     

Diese Seite empfehlen