1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Falsche Java-Version, woher die neue?

Dieses Thema im Forum "Andere Software" wurde erstellt von Thaddäus, 16.02.09.

  1. Thaddäus

    Thaddäus Golden Noble

    Dabei seit:
    27.03.08
    Beiträge:
    15.163
    Hi Leute...

    Hab hier ein Programm und wenn ich es aufstarten will kommt folgende Fehlermeldung:

    Dieses Programm benötigt Java-Version 1.6+. Die verfügbare Java-Version 1.5 kann dieses Programm möglicherweise öffnen, aber es funktioniert u. U. nicht korrekt.

    Wenn ich dann 1.5 verwenden anklicke, passiert überhaupt nix. Kann mir jemand sagen wo ich die Version 1.6 für OS X 10.5.6 herbekomme? Bin leider kein Java-Held und mich verwirren die Bezeichnungen wie JRE und JSE und so immer wieder.

    Wär also dankbar, wenn jemand einen Link für mich hätte... :)
     
  2. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    handelt es sich um limewire?
     
  3. Thaddäus

    Thaddäus Golden Noble

    Dabei seit:
    27.03.08
    Beiträge:
    15.163
    Spielt das eine Rolle?
     
  4. MacApple

    MacApple Lord Grosvenor

    Dabei seit:
    05.01.04
    Beiträge:
    3.470
    Die Version 1.6 sollte bereits auf Deinem Rechner sein, wenn die Softwareaktualisierung nichts neues mehr anzeigt. Du musst wahrscheinlich nur noch die bevorzugte Version umstellen. Das machst Du mit dem Programm „Java-Einstellungen”, welches im Ordner /Programme/Dienstprogramme/Java liegt.

    MacApple
     
  5. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    nein, war nur vor kurzem wer im forum, der hatte das gleiche problem, das trat bei ihm auf, als er limewire verwenden wollte
     
  6. Thaddäus

    Thaddäus Golden Noble

    Dabei seit:
    27.03.08
    Beiträge:
    15.163
    Hm, also über die Softwareaktualisierung wird mir nix angezeigt.

    Und im besagten Dienstprogramm habe ich nur diese Versionen:

    J2SE 5.0 und J2SE 1.4.2

    Was mach ich da bloss falsch?
     
  7. MacApple

    MacApple Lord Grosvenor

    Dabei seit:
    05.01.04
    Beiträge:
    3.470
    Keine Ahnung, warum das bei Dir nicht angeboten wird. Die Java-Updates gibt's aber auch hier zum Download.

    MacApple
     
  8. DesignerGay

    DesignerGay Danziger Kant

    Dabei seit:
    27.07.07
    Beiträge:
    3.897
    Bei mir steht das gleiche wie bei skoenig1 und ich hatte diese Java-Update vor ein paar tagen gemacht.
     
  9. Thaddäus

    Thaddäus Golden Noble

    Dabei seit:
    27.03.08
    Beiträge:
    15.163
    Hab wahrscheinlich das Problem rausgefunden: Es handelt sich beim Rechner um ein Macbook Core Duo, also 32 Bit. Soweit ich das verstehe wurde Java 1.6 allerdings nur für 64 Bit Maschinen gemacht, und die alten blieben aussen vor, sprich müssen sich nun mit Java 1.5 begnügen... :mad:

    PS: Hab auch alle Javaupdates inkl. Update 3 gemacht...
     
  10. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Vielleicht ist SoyLatte etwas für Dich.
     
  11. MacApple

    MacApple Lord Grosvenor

    Dabei seit:
    05.01.04
    Beiträge:
    3.470
    Ja, das erklärt natürlich einiges.

    MacApple
     
  12. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    Haha...ich hab hier nen 64Bit G4...und da läuft 1.6 problemlos. Endlich mal ne Sparte, wo Intels nen Nachteil haben.

    So, und zur Versionsnummer:
    Java 1.0 ist Java 1.0
    Java 1.1 bis Java 1.3 ist nie übers Betastadium rausgekommen.
    Java 1.4 wird deswegen auch Java2 genannt.
    Java 1.5 dann direkt Java 5.0.

    Und was du brauchst ist nen JRE. Java Runtime Environment. Da gibts auch nur eins von. Bloß bei den Entwicklungsumgebungen gibt's Versionen, da ist mehr Chaos drin als bei Windows Vista.
     
  13. Jamsven

    Jamsven London Pepping

    Dabei seit:
    21.11.07
    Beiträge:
    2.046
    Kann nicht sein der G4 ist doch ein 32 bit rechner, der G5 ist ein 64 Bit Rechner.
    Das Problem haben nur die Leute, die keinen Core 2 Duo haben. ;)
     
  14. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    Eeecht? Ich war bis jetzt der meinung, dass mein G4 auch schon 64 Bit getrunken hat....naja, wieder was gelernt.
     
  15. Thaddäus

    Thaddäus Golden Noble

    Dabei seit:
    27.03.08
    Beiträge:
    15.163
    Nö, erst der G5 war 64-Bit... Und bei Intel halt erst die Core 2 Duo...
     
  16. erikdietz

    erikdietz Morgenduft

    Dabei seit:
    10.05.07
    Beiträge:
    164
    Core2Duo

    Hallo Leute, überall lese ich das,
    das Core2Duo 64bit sein sollen.
    Nun habe ich aber ein Core2Duo und m.E. nur 32bit.
    Auch über Standard-Software-Uopdate zieht er maximal auf die Java 1.5...

    Wie kann das sein?!
    Habe ich unwissentlich einen 64bit und fahre mit einem 32bit Leopard?!
    Geht das überhaupt?!

    Mfg
     
  17. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Nö. Kannst Du Dir anzeigen lassen und wählen mit "/Applications/Utilities/Java Preferences.app".

    Nein. Es wird automatisch die richtige Version geladen.
     
  18. erikdietz

    erikdietz Morgenduft

    Dabei seit:
    10.05.07
    Beiträge:
    164
    Jetzt weiß ich genauswoviel wie vorher...
    Das automatisch die richtige gezogen wird weiß ich ja,
    aber im Netz heißt es, ALLE Core2Duo sind 64bit...

    und ich hab eines von denen...
    Damals 04.2006 bestellt.
    Mit OSX 10.4 oder so... Panther?! Tiger?! kA...
    Jetzt hab ich Leopard oben...
    Aber da er nur max. Java 1.5 automatisiert saugt,
    sollte ich ja ein 32bit haben.
    Was aber im Widerspruch zu obiger Behauptung steht,
    alle C2D sind 64bit...

    Also ist es mögich, auf 64bit Systemem 32bit Betriebssysteme zu installieren!?

    Danke für die rasche antwort...
     
  19. yamiro

    yamiro Fießers Erstling

    Dabei seit:
    16.03.09
    Beiträge:
    128
    Ja, ist es. Statistisch gesehen überwiegt diese Art der Installation sogar (Vista 32bit als default auf neuen 64Bit Prozessoren).
     
  20. erikdietz

    erikdietz Morgenduft

    Dabei seit:
    10.05.07
    Beiträge:
    164
    Habe jetzt mal unter JAva-Einstellungen auf 1.6 gestellt...
    Ihr wisst sicher wo ich meine... Habe die 6er nach oben geschoben.
    Wenn ich jetzt unter Terminal "jave -version" eingebe,
    dann steht da auch 1.6... Mal sehen, ob dem so ist...
     

Diese Seite empfehlen