1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Excel Problem -> SUMMEWENN oder ZÄHLENWENN

Dieses Thema im Forum "Office:Mac" wurde erstellt von Bissy, 11.06.08.

  1. Bissy

    Bissy Johannes Böttner

    Dabei seit:
    03.02.07
    Beiträge:
    1.159
    Hi,

    habe mal wieder ein Excelproblem.

    Ich habe eine Tabelle, in Spalte A stehen intern vergebene Nummern (z.B. "E2008-345", wobei 2008 das Jahr symbolisiert), in Spalte E steht die Geschäftseinheit (z.B. "A1 - Softwarebeschaffung").
    Nun soll in einem anderen Arbeitsblatt gezählt werden, wie viele Eintragungen pro Geschäftsjahr welcher Abteilung zugeordnet werden.

    Es soll dann so aussehen:

    A1:
    2006: 14
    2007: 3
    2008: 0

    und so weiter....

    Wie gesagt, es ist in einem anderen Arbeitsblatt.
    Hier meine momentane Formel:

    Code:
    =SUMME(WENN(('P1'!A$1:A$500="*2006*")*('P1'!E$1:E$500="A1 - Softwarebeschaffung");1;0))
    Obwohl es dort Zeilen gibt, in denen Softwarebeschaffung Einträge aus 2006 hat, bekomme ich eine "0" angezeigt.
    Vielleicht hat jemand den entscheidenen Tip, habe auch schon ZÄHLENWENN probiert, gleiches Problem.

    Zum Geschäftsjahr: Leider kann man es nur aus der ersten Spalte rausziehen, da die Daten so direkt aus einer DB gezogen werden. Man muss also quasi die erste Spalte durchsuchen, ob der Eintrag "2006", "2007", etc. enthält.

    Ich bin euch absolut dankbar für jeden Hinweis!

    vg,
    Bissy
     
  2. Petzi

    Petzi Gast

    Hallo!

    Du mußt zuerst die Jahreszahl freibekommen um diese abfragen zu können, Bsp.

    =WERT(RECHTS(LINKS(A1;5);4))
    oder bei Tabelle
    =WERT(RECHTS(LINKS(Tabelle!A1;5);4))

    um A1 umzuwandeln.

    Der Rest ist deine gewünschte SUMMEWENN-Funktion.

    MfG Petzi
     

Diese Seite empfehlen