1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ethereal-Rechte

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von Wikinator, 15.09.05.

  1. Wikinator

    Wikinator Adams Parmäne

    Dabei seit:
    21.08.04
    Beiträge:
    1.297
    Hallo,

    ich habe mir via fink ethereal installiert, und es läuft auch unter X11. Allerdings gibt er bei 'capture -> start' auf den schnittstellen en0 (nicht benutzt) und en1 (AirPort) folgende Fehlermeldung:
    Code:
    The capture session could not be initiated ((no devices found) /dev/bpf0: Permission denied).
    Please check to make sure you have sufficient permissions, and that
    you have the proper interface or pipe specified.
    Es funktioniert nicht unter dem Standard-Benutzer und dem Admin.
     
  2. Rusty

    Rusty Gast

    mit sudo starten "Please check to make sure you have sufficient permissions"

    -->sudo ethereal

    Rusty
     
  3. Wikinator

    Wikinator Adams Parmäne

    Dabei seit:
    21.08.04
    Beiträge:
    1.297
    als admin funktioniert das, aber als standard-user (nicht in /etc/sudoers eingetragen) nicht. geht das nicht anders?
     
  4. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    ne, das darf nur ein admin machen - ist ja auch ein massiver eingriff, zB in die privatsphäre anderer user.

    natürlich kannst du etheral SID machen, aber das sollte man sich für jene dinge aufsparen, wo man es zwingend braucht.
     
  5. tjp

    tjp Baldwins roter Pepping

    Dabei seit:
    07.07.04
    Beiträge:
    3.252
    Als nicht admin kannst Du admin werden, sofern Du das Passwort kennst.

    su admin
    sudo ethereal

    Dann brauchst Du den Account nicht zu wechseln. X11 forwarding sollte enabled sein, anderfalls mittels xhost oder xauth das Problem auflösen.
     
  6. Wikinator

    Wikinator Adams Parmäne

    Dabei seit:
    21.08.04
    Beiträge:
    1.297
    wie kann ich den X11 forwarding auswählen, in den Einstellungen finde ich es nicht.
     
  7. tjp

    tjp Baldwins roter Pepping

    Dabei seit:
    07.07.04
    Beiträge:
    3.252
    Funktioniert es nicht?
    X11 Forwarding wird eigentlich nur per ssh gemacht. Setzt einfach die Zugriffsrechte via xauth (oder wenn Du kein Problem damit hast, "xhost +localhost", "export DISPLAY=localhost:0.0"), dann funktioniert das auch. Als root kannst Du ja problemlos das XCookie im Homeverzeichnis des Nutzer lesen.
     
  8. Wikinator

    Wikinator Adams Parmäne

    Dabei seit:
    21.08.04
    Beiträge:
    1.297
    Hallo,
    wie mache ich das mit xauth?
     
  9. slartibartfast

    slartibartfast Schöner von Nordhausen

    Dabei seit:
    10.05.05
    Beiträge:
    323
    xterm starten, dann tippen:
    Code:
    xhost +localhost
    su admin <-- nur, wenn nicht Admin
    export DISPLAY=localhost:0
    sudo ethereal
    Hilft das?


    Grüße
    slartibartfast
     
  10. Wikinator

    Wikinator Adams Parmäne

    Dabei seit:
    21.08.04
    Beiträge:
    1.297
    danke, das funktioniert :)
     

Diese Seite empfehlen