1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Error Code -50 / Netzwerkzugriff

Dieses Thema im Forum "macOS & OS X" wurde erstellt von dandjo, 13.05.07.

  1. dandjo

    dandjo Starking

    Dabei seit:
    28.03.07
    Beiträge:
    216
    Hi Community!

    Habe seit neuestem ein schier unlösbares Problem.
    Das Problem betrifft konkret Netzwerkfreigaben in Netzwerkverbindungen zwischen Macs und Windows PCs.

    Möchte ich auf meinem Mac auf ein freigegebenes Verzeichnis auf meinem Windows PC via SMB zugreifen (im Finder via Go -> Connect to Server), scheint bis zur Anzeige der freigegebenen Ordner alles in Ordnung. Nach Auswahl des freigegebenen Verzeichnisses und einem Klick auf OK ist jedoch Sendeschluss (Error Code -50).
    Das Merkwürdige ist, dass es schon funktioniert hatte, aus nicht nachvollziehbaren Gründen jedoch plötzlich nicht mehr funktionierte.

    Das gleiche passiert, wenn ich im Finder über Netzwerk -> Arbeitsgruppe -> PC versuche mich zum Windows PC zu verbinden. Die Fehlermeldung hier lautet "The Alias XXXXX could not be opened, because the original item could not be found." und bietet folgende Buttons an: "Delete Alias", "Fix Alias ...", "OK". Alle 3 Buttons sind wirkungslos.

    Jetzt dachte ich mir, dass OS X irgendwo Aliases von Netzwerkverbindungen zu speichern scheint, dem ist aber offensichtlich nicht so.
    Mein Windows PC besitzt die IP 192.168.0.100. Nach einem "locate 192.168.0.100" im Terminal bekam ich folgende Ausgabe:

    /Volumes/192.168.0.100
    /Volumes/192.168.0.100-1
    /Volumes/192.168.0.100-2
    /Volumes/192.168.0.100-3

    Aha, dachte ich mir und versuchte ein klassisches "sudo rm -Rf /Volumes/192.168.0.100". Nichts, nada passierte.

    Hat jemnand ein ähnliches/gleiches Problem?
    Was ist hier faul und wie kann man das Problem beseitigen?

    Wäre für jede Hilfe dankbar!
     
  2. dandjo

    dandjo Starking

    Dabei seit:
    28.03.07
    Beiträge:
    216
    Keiner das gleiche Problem, Erfahrung oder Lösungsvorschläge?
     
  3. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Lass, mich raten, das funktioniert seit dem Update auf 10.4.9 nicht mehr? Die Fehlermeldung hatte ich auch.
    Öffne mal ein Terminal und tippe folgendes ein "sudo tail -f /var/log/system.log".
    tail -f sorgt für die Ausgabe der letzten Zeilen einer Textdatei, kontinuierlich immer wenn was neues dazu kommt.
    Danach versuchst du noch einmal dein Netzlaufwerk zu verbinden. Wenn dann als Fehlermeldung
    "mount version mismatch: kernel=103700, mount=103600" kommt, dann liegt das am Update.
    Lösung ist recht "einfach" aber man muss 2 Dateien von der 10.4.8 zurück einspielen. Ich habe noch keine andere Lösung gefunden.
     
  4. dandjo

    dandjo Starking

    Dabei seit:
    28.03.07
    Beiträge:
    216
    Nein, daran kann es nicht liegen, da es bereits mit 10.4.9 funktioniert hatte. Auch die Fehlermeldung erscheint nicht.
     
  5. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Was steht denn sonst da? hast du mal versucht über das Terminal eine Freigabe einzubinden?
     
  6. wlanboy

    wlanboy Cripps Pink

    Dabei seit:
    13.05.05
    Beiträge:
    150
    -50 paramErr Error in user parameter list
    was aber nicht weiterhilft.

    Ergo zwei Einstellungsprobleme bei Windows?

    1.
    Zugriffsrechte des Benutzers auf die Shares?

    2.
    Microsoft network client: Digitally sign communications (always) <- auf disable
    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options
    Description
    Determines whether the computer always digitally signs client communications.

    Ist mir schon bei einigen Windowsservern und XP Pros passiert.

    Er listet dir ja alle Shares auf, oder? Root + 3 Shares würde die Consolenausgabe bedeuten ... Vielleicht liegt es auch an den letzten Windowsupdates?
     
  7. dandjo

    dandjo Starking

    Dabei seit:
    28.03.07
    Beiträge:
    216
    Das Problem ist, dass das system.log keine sinnvollen und verständlichen Meldungen ausgibt. Es wird hier nur der Error -50 geloggt.

    Wie binde ich über das Terminal eine Freigabe is OS X ein? Habe ich noch nie versucht.

    Das Interessante ist, dass die gleiche Fehlermeldung erscheint, wenn ich eine Samba-Freigabe von einem Linuxrechner versuche einzubinden. Es muss also zwangsläufig mit Konfigurationen/Bugs in OS X zu tun haben.

    Es liegt 100%ig nicht an den Zugriffsrechten von Windows XP, da ich in der Zeit, in der das Prolbem auftrat, mein Windows XP weder aktualisiert noch berührt habe (das Notebook steht immer zugeklappt im Abstellkammerl als kleiner Server).
     
  8. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    mount_smbfs
    Damit kannst du im Terminal es testen.
     
  9. dandjo

    dandjo Starking

    Dabei seit:
    28.03.07
    Beiträge:
    216
    Fehlanzeige.
     
  10. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Was Fehleinzeige? geht es nicht? Ich musste 2 Dateien aus dem 10.4.8 zurückspielen, danach ging es (ok einmal Rechte korrigieren lassen, nachdem ich die Datein hab ausgetauscht). Danach war das klein Thema mehr.
     
  11. marcozingel

    marcozingel Brettacher

    Dabei seit:
    07.12.05
    Beiträge:
    7.482
    Hilft auch nicht weiter,aber es gibt noch viele andere Störmeldungen:

    Operating System Errors

    0 No error.
    -34 Disk <name> is full.
    -35 Disk <name> wasn't found.
    -37 Bad name for file.
    -38 File <name> wasn't open.
    -39 End of file error.
    -42 Too many files open.
    -43 File <name> wasn't found.
    -44 Disk <name> is write protected.
    -45 File <name> is locked.
    -46 Disk <name> is locked.
    -47 File <name> is busy.
    -48 Duplicate file name.
    -49 File <name> is already open.
    -50 Parameter error.
    -51 File reference number error.
    -61 File not open with write permission.
    -108 Out of memory.
    -120 Folder <name> wasn't found.
    -124 Disk <name> is disconnected.
    -128 User canceled.
    -192 A resource wasn't found.
    -600 Application isn't running.
    -601 Not enough room to launch application with special requirements.
    -602 Application is not 32-bit clean.
    -605 More memory is needed than is specified in the size resource.
    -606 Application is background-only.
    -607 Buffer is too small.
    -608 No outstanding high-level event.
    -609 Connection is invalid.
    -904 Not enough system memory to connect to remote application.
    -905 Remote access is not allowed.
    -906 <name> isn't running or program linking isn't enabled.
    -915 Can't find remote machine.
    -30720 Invalid date and time <date string>.


    Apple Event Errors

    -1700 Can't make some data into the expected type.
    -1701 Some parameter is missing for <commandName>.
    -1702 Some data could not be read.
    -1703 Some data was the wrong type.
    -1704 Some parameter was invalid.
    -1705 Operation involving a list item failed.
    -1706 Need a newer version of the Apple Event Manager.
    -1707 Event isn't an Apple event.
    -1708 <reference> doesn't understand the <commandName> message.
    -1709 AEResetTimer was passed an invalid reply.
    -1710 Invalid sending mode was passed.
    -1711 User canceled out of wait loop for reply or receipt.
    -1712 Apple event timed out.
    -1713 No user interaction allowed.
    -1714 Wrong keyword for a special function.
    -1715 Some parameter wasn't understood.
    -1716 Unknown Apple event address type.
    -1717 The handler <identifier> is not defined.
    -1718 Reply has not yet arrived.
    -1719 Can't get <reference>. Invalid index.
    -1720 Invalid range.
    -1721 <expression> doesn't match the parameters <parameterNames> for <commandName>.
    -1723 Can't get <expression>. Access not allowed.
    -1725 Illegal logical operator called.
    -1726 Illegal comparison or logical.
    -1727 Expected a reference.
    -1728 Can't get <reference>.
    -1729 Object counting procedure returned a negative count.
    -1730 Container specified was an empty list.
    -1731 Unknown object type.
    -1750 Scripting component error.
    -1751 Invalid script id.
    -1752 Script doesn't seem to belong to AppleScript.
    -1753 Script error.
    -1754 Invalid selector given.
    -1755 Invalid access.
    -1756 Source not available.
    -1757 No such dialect.
    -1758 Data couldn't be read because its format is obsolete.
    -1759 Data couldn't be read because its format is too new.
    -1760 Recording is already on.


    AppleScript Errors

    -2700 Unknown error.
    -2701 Can't divide <number> by zero.
    -2702 The result of a numeric operation was too large.
    -2703 <reference> can't be launched because it is not an application.
    -2704 <reference> isn't scriptable.
    -2705 The application has a corrupted dictionary.
    -2706 Stack overflow.
    -2707 Internal table overflow.
    -2708 Attempt to create a value larger than the allowable size.
    -2709 Can't get the event dictionary.
    -2720 Can't both consider and ignore <attribute>.
    -2721 Can't perform operation on text longer than 32K bytes.
    -2729 Message size too large for the 7.0 Finder.
    -2740 A <language element> can't go after this <language element>.
    -2741 Expected <language element> but found <language element>.
    -2750 The <name> parameter is specified more than once.
    -2751 The <name> property is specified more than once.
    -2752 The <name> handler is specified more than once.
    -2753 The variable <name> is not defined.
    -2754 Can't declare <name> as both a local and global variable.
    -2755 Exit statement was not in a repeat loop.
    -2760 Tell statements are nested too deeply.
    -2761 <name> is illegal as a formal parameter.
    -2762 <name> is not a parameter name for the event <event>.
    -2763 No result was returned for some argument of this expression.


    Application Scripting Errors

    -10000 Apple event handler failed.
    -10001 A descriptor type mismatch occurred.
    -10002 Invalid key form.
    -10003 Can't set <object or data> to <object or data>. Access not allowed.
    -10004 A privilege violation occurred.
    -10005 The read operation wasn't allowed.
    -10006 Can't set <object or data> to <object or data>.
    -10007 The index of the event is too large to be valid.
    -10008 The specified object is a property, not an element.
    -10009 Can't supply the requested descriptor type for the data.
    -10010 The Apple event handler can't handle objects of this class.
    -10011 Couldn't handle this command because it wasn't part of the current transaction.
    -10012 The transaction to which this command belonged isn't a valid transaction.
    -10013 There is no user selection.
    -10014 Handler only handles single objects.
    -10015 Can't undo the previous Apple event or user action.


    Source: Apple Developer Connection (ADC)
     
  12. dandjo

    dandjo Starking

    Dabei seit:
    28.03.07
    Beiträge:
    216
    Nein, es funktioniert nicht. Welche Dateien sind denn das? Ich werde es jetzt einfach mal damit versuchen.
     
  13. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    also wie oben steht ist -50 parameter error.
    Du musst die mount_smbfs unter "/sbin/" und die "/System/Library/Extensions/smbfs.kext" austauschen. Das ganze als su. Danach ein reboot und noch einmal die Rechte reparieren lassen.
     

Diese Seite empfehlen