1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Error 414 in Safari

Dieses Thema im Forum "Browser" wurde erstellt von krummhorn, 16.02.10.

  1. krummhorn

    krummhorn Golden Delicious

    Dabei seit:
    15.02.10
    Beiträge:
    10
    Fällt einem was zu folgendem kuriosen Problem ein: Seit einigen Tagen bekomme ich auf meinem Mac Mini (10.6.2., Intel) beim Versuch, in Safari 4.0.4 eine bestimmte Website aufzurufen, einen Fehler "414 - Request-URI Too Long", der mir früher noch nie untergekommen war. Die gleiche Website kann ich auf dem Mini mit Firefox 3.5.7 problemlos aufrufen, ebenfalls problemlos mit Safari 4.0.4 auf meinem iBook G4 (10.4.11)! Neuinstallation von Safari hat nichts gebracht. Mein Sohn spekuliert, daß vielleicht ein zerschossenes Plug-in beim Anmeldevorgang versagt (414 betrifft, soweit ich das ermitteln konnte, einen der letzten Schritte im Verbindungsaufbau), der Fehler zeigt sich aber nur bei dieser einen Website (www.taringa.net), und ich bin viel unterwegs. Wer hat einen Tip(p), wie ich hier weiterkomme? Bin für jede Erleuchtung dankbar.

    Greetz, krummhorn
     
  2. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.942
    Hilft dir nicht viel weiter, aber ich kann die Webseite ohne Probleme öffnen, allerdings ist mir ein 414 noch nie untergekommen, 404 und 504 des öfteren, aber 414 noch nie. Daher kann ich dir auch nicht viel weiter helfen
     
  3. krummhorn

    krummhorn Golden Delicious

    Dabei seit:
    15.02.10
    Beiträge:
    10
    Ja, ich bin auch wirklich gespannt, was da rauskommt. Der Fehler ist offensichtlich selten und die Informationen darüber spärlich, ich habe lange genug rumgegoogelt und hier im Forum gesucht, bevor ich mich zum Posten entschlossen habe. Danke jedenfalls fürs Ausprobieren und die schnelle Antwort.
     
  4. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Zunächst einmal wird der Fehler ja vom angesprochenen Webserver zurückgegeben, nicht Safari gibt die Meldung aus. Eine Neuinstallation von Safari wird also wohl kaum etwas ändern (mal abgesehen davon, dass eine „Neuinstallation“ einer OS-X-App fast nie ein Problem lösen kann, weil sie in der Regel die Einstellungen des Programms, die für einen Fehler verantwortlich sind, ja gar nicht beeinflusst. Statt eine App neu zu installieren, löscht man typischerweise besser ihre Einstellungen (~/Library/Preferences/....plist)).

    Und wenn die Request URI zu lang ist, deutet das eher darauf hin, dass Du eben nicht nur die kurze URI „http://www.taringa.net“ abschickst, sondern eine viel viel längere, die Dein Browser vielleicht noch im Verlauf oder irgendwo gespeichert hat. Oder kommt dieser Fehler tatsächlich, wenn Du sicherstellst, dass die Adresszeile des Browsers nur oben genannte ganz kurze URI enthält und Du daraufhin Return drückst?
     
  5. krummhorn

    krummhorn Golden Delicious

    Dabei seit:
    15.02.10
    Beiträge:
    10
    OK, die Neuinstallation war so eine Art letzter Versuch, nachdem Verlauf und Cache löschen nichts genutzt hatten. Das ist sicher noch eine Denke aus der Vor-OS X-Ära, mein erstes System war, glaube ich, 5.1, das prägt ;) . Und ich hatte den URL wirklich nicht irgendwo hergenommen, sondern frisch eingetippt und abgeschickt; beim Rumgoogeln nach 414 meine ich verstanden zu haben, daß er das Ergebnis eines mehrstufigen Dialogs zwischen meiner Kiste und dem angesprochenen Server ist, nicht die Erstreaktion auf meine Eingabe.

    Also machte ich mich auf Deinen Hinweis hin auf die Suche nach den Preferences, was nicht so einfach war, weil Safari seine Hilfsdateien nicht wie Firefox und Camino im Application Support ablegt, sondern einen eigenen Ordner hat. Darin liegen bei mir die Bookmarks.plist, Downloads.plst, History.plist, LastSession.plist und TopSites.plist. Gelöscht und Safari-Neustart, URL eingegeben -> Error 414. Neuer Versuch: gesamten Inhalt des Safari-Ordners gelöscht, Safari zusätzlich zurückgesetzt, wobei ja auch Cache und Verlauf gelöscht werden, Safari neu gestartet, URL eingegeben -> Error 414. Da spinnt noch irgendwas rum, aber warum ausgerechnet diese Seite und keine andere?Warum geht's auf dem iBook mit Safari und auf dem Mini mit anderen Browsern problemlos? Mache ich irgendwas grundsätzlich falsch? Leider habe ich von der Konsole keine Ahnung, vielleicht könnte man dem Log was entnehmen, aber das übersteigt meine Kenntnisse. Trotzdem Danke für die Beschäftigung mit dem Problem, vielleicht hilft diese Ergänzung ja weiter.

    Grüße, krummhorn
     
  6. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.942
    lege dir zum Testen mal einen neuen Benutzer an, melde dich mit dem an, gehe ins Netz und rufe diese Seite auf, wenn es dort dann geht, liegt der Fehler im Benutzerordner, geht es dort auch nicht, liegt der Fehler im System/Programm.
     
  7. krummhorn

    krummhorn Golden Delicious

    Dabei seit:
    15.02.10
    Beiträge:
    10
    Na super - danke! Schade, daß ich gestern nicht mehr an die Kiste kam. Damit kommt zum ersten Mal Bewegung in die Sache. Es funktioniert, als anderer Benutzer habe ich den Safari-Fehler nicht mehr. Jetzt kann ich daran gehen, die Accounts zu vergleichen. Wenn ich den Schuldigen am Wickel habe, melde ich mich wieder (und wenn nicht, natürlich auch :-D )

    Gruß, krummhorn
     
  8. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Es gibt auch die ganz normale ~/Library/Preferences/com.apple.Safari.plist. Mit der hätte ich das zuerst probiert.
    Und die Caches (damit könnte das durchaus zusammenhängen). ~/Library/Caches/com.apple.Safari
    Aber zum Cache-Leeren hat Safari sogar einen Menüpunkt und Shortcut Cmd-Option-E(mpty Cache)

    Bookmarks, Topsites etc. dürften kaum etwas damit zu tun haben.
     
  9. krummhorn

    krummhorn Golden Delicious

    Dabei seit:
    15.02.10
    Beiträge:
    10
    Stimmt, danke für den Hinweis, ich war inzwischen beim Vergleichen der Accounts auch drübergestolpert. Mit der Bezeichnung war es gut versteckt. Habe ich ausprobiert, das war's aber auch nicht, und mit dem Ausnutzen der Menüpunkte war ich auch schon bis zur Keule "Safari zurücksetzen" gegangen. Aber immerhin lerne ich einiges bei diesem Abstieg in die Unterwelt. Und unter der falschen Flagge Testuser kann ich immerhin wieder normal segeln mit Safari, was mir unterm Strich doch lieber ist als Firefox. Bis auf Weiteres!
     
  10. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.942
    Hast du denn im zickigen User irgendetwas in
    DeinBenutzer/Library/Internet Plugins ?
     
  11. krummhorn

    krummhorn Golden Delicious

    Dabei seit:
    15.02.10
    Beiträge:
    10
    Nö, der Ordner ist leer.
     
  12. axx90

    axx90 Idared

    Dabei seit:
    06.01.09
    Beiträge:
    28
    Ah, endlich ein Gleichgesinnter :p
    Bin wegen dieses Fehlers (auch bei Taringa ;) ) zu Firefox gewechselt, da ich kein Lösung gefunden habe. Habe den Post grade gelesen und mich mal in meinem Account umgeguckt, kann aber nicht sagen, was das Problem verursacht o_O
     
  13. krummhorn

    krummhorn Golden Delicious

    Dabei seit:
    15.02.10
    Beiträge:
    10
    Tja, Leidensgenosse: was es wirklich war, habe ich nicht herausbekommen. Aber ich habe es immer wieder probiert und konnte eines Tages mein Safari wieder für Taringa benutzen! Was es letztendlich gebracht haben muß, war nach dem Löschen der Prefs die Kombination von Zurücksetzen von Safari (im Safari-Menu) und Neustart des Computers. Probier's mal aus, die Bookmarks kannst Du ja vorher exportieren.
    Schon erstaunlich, daß keiner der Cracks hier im Forum den Fehler wirklich aufdröseln konnte, scheint wirklich was Seltenes zu sein. Am meisten hat der Rat geholfen, einen neuen User anzulegen, so konnte man wenigstens sagen, daß es nicht am System lag. Viel Glück und nochmal danke an alle!
     

Diese Seite empfehlen