1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Erneutes Problem mit Adminrechte und Root-User

Dieses Thema im Forum "macOS & OS X" wurde erstellt von eimo, 19.11.08.

  1. eimo

    eimo Cripps Pink

    Dabei seit:
    15.01.07
    Beiträge:
    152
    Hey,

    ich hab seit paar Monaten keine Adminrechte mehr an meinem Mac. Hab dann rausgefunden das man mit der Leopard Disk booten muss und dort die Kennwörter zurücksetzen kann. Hat bis heute gedauert bis ich endlich wieder meine Disk in Händen halten konnte.
    Also hab ich direkt die Disk eingeworfen und wie beschrieben ein Kennwort für den root-user eingegeben.

    Im weiteren Schritt soll man also Im Login Fenster "andere Benutzer" auswählen und sich dort mit root und dem neuen Passwort einloggen. Klappt auch wunderbar.
    Im nächsten Schritt soll man in den Benutzereinstellungen dann den betroffenen Benutzer (der ohne Adminrechte) auswählen und dort das Häkchen bei "Benutzer darf Computer verwalten" setzen. Wenn ich jetzt aber das Häkchen setze und ich bspw. auf einen anderen Nutzer clicke, dann wieder auf den eben erwähnten Nutzer wechsle ist das Häkchen wieder weg.
    Ok, könnte man denken ... da das System mich auffordert mich nach dem setzen des Häkchen abzumdelen und mit dem betroffenen Benutzer wieder einzuloggen.

    Jetzt meld ich mich also ab, meld mich mit meinem neuen Benutzer an (der ja jetzt eigentlich ein Häkchen haben sollte und somit wieder Adminrechte) gehe in den Benutzerordner und siehe da: immernoch Standartbenutzer und keinerlei Adimrechte ...

    hab alles so gemacht wie beschrieben.

    Vielleicht nochwas: Wenn ich mich mit dem root-user anmelde und in den Benutzerordner gehe, kann ich zwar andere Benutzer löschen/hinzufügen und auf die anderen zugreifen (sind also nicht wie bei normalen Standartbenutzer weggegraut) aber unter "Sytsem-Administrator" nicht "Admin" sondern auch "Standartbenutzer" :-c
     
  2. eimo

    eimo Cripps Pink

    Dabei seit:
    15.01.07
    Beiträge:
    152
    keiner ne Idee?
     
  3. Katzenfutter

    Katzenfutter Kaiser Wilhelm

    Dabei seit:
    16.12.06
    Beiträge:
    174
    Interessant wäre, wie du die Adminrechte verloren hast. Einfach das Passwort vergessen?
    Root-User auf der grafischen Oberfläche?!
    Auf einem sauberen Unix kannst du dich erstmal gar nicht als Root anmelden. Zumindest solange nicht, bis du für den Root-User ein Passwort vergeben hast.

    Versuch dein Problem mal mit den Augen derer zu sehen, die deinen Eintrag lesen.
    Mein Orakel ist leider seit dem Sommer in der Südsee unterwegs, daher kann ich grad nich mal eben... verstehst?

    Idee:
    http://www.macosxhints.com/article.php?story=2007110800450816

    Hab es noch nie testen müssen, klingt für mich aber logisch.
     
  4. eimo

    eimo Cripps Pink

    Dabei seit:
    15.01.07
    Beiträge:
    152
    Wie genau ich meine Rechte verloren hab weiss ich nimmer genau. Ich wollte ne Cross-Over Verbidung mit meinem PC herstellen um meine Platte mal zu räumen. Da sich da seit Tiger was verändert hat hab ich es anfangs nicht gerafft. Ich glaub da war was mit File-Sharing das es in der Form nimmer gibt. Jedenfalls hatte ich nach dem Konfigurieren des Gast-Zugangs und des Windosws File-Sharings keine Adminrechte mehr.
    Aber das Problem hatten schon viele ... war oder ist wohl irgendein Bug in Leo.

    Jedenfalls hat es den anderen jeweils geholfen mit der Leo Install Disk im Installationsassistenten via "Kennwörter zurücksetzen" dem root-user ein Passwort zuzuweisen. Mit diesem PW konnte man sich bei Neustart via "anderen Benutzer" als root und mit dem eben geänderten oder angelegten PW anmelden. Da man jetzt alle Rechte dieser Erde hat konnte man dem "rechtelosen Benutzer" in den Benutzereinstellungen durch aktivieren des Kästchen "Benutzer darf diesen Computer verwalten" wieder seine Adminrechte geben.

    Bei mir ist das Problem das ich mich zwar mit dem root-user einloggen kann und auch die anderen Benutzer "verwalten"/"verändern" kann, aber sobald ich in den Benutzereinstellungen bspw. auf einen anderen Benutzer clicke und dann wieder auf den eben veränderten ... ist wieder alles wie vorher.
    Ich kann das Häkchen vor "Benutzer draf ... verwalten" zwar setzen ist aber quasi direkt wieder weg...

    Unter meinem root bzw. System-Administrator steht auch nicht "Admin" sondern wie bei den anderen "Standartbenutzer"
     
  5. eimo

    eimo Cripps Pink

    Dabei seit:
    15.01.07
    Beiträge:
    152

Diese Seite empfehlen