1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

einloggen mit ssh klappt nicht

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von quax, 12.01.06.

  1. quax

    quax Gast

    hi,

    vielleicht finde ich hier hilfe.

    ich versuche mich mittels ssh im terminal "ssh benutzername@domain.tld" auf einem bekannten server einzuloggen. dann kommt die passwortabfrage, das wird akzeptiert, danach geht es aber nicht weiter. in den logfiles stehe ich als angemeldet drin. ich habe es mit der einstellung x-term-color, x-term und vt102 versucht.

    ssh -v liefert folgendes ergebnis:

    macuser$ ssh -v benutzername@domain.tld
    OpenSSH_3.8.1p1, OpenSSL 0.9.7i 14 Oct 2005
    debug1: Reading configuration data /etc/ssh_config
    debug1: Connecting to domain.tld [xxx.xxx.xxx.xx] port 22.
    debug1: Connection established.
    debug1: identity file /Users/macuser/.ssh/identity type -1
    debug1: identity file /Users/macuser/.ssh/id_rsa type -1
    debug1: identity file /Users/macuser/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.2
    debug1: match: OpenSSH_4.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1
    debug1: Miscellaneous failure
    No credentials cache found

    debug1: Miscellaneous failure
    No credentials cache found

    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'domain.tld' is known and matches the RSA host key.
    debug1: Found key in /Users/macuser/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: publickey
    debug1: Trying private key: /Users/macuser/.ssh/identity
    debug1: Trying private key: /Users/macuser/.ssh/id_rsa
    debug1: Trying private key: /Users/macuser/.ssh/id_dsa
    debug1: Next authentication method: keyboard-interactive
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: password
    benutzername@domain.tld's password:
    debug1: Authentication succeeded (password).
    debug1: channel 0: new [client-session]
    debug1: Entering interactive session.
    debug1: channel 0: free: client-session, nchannels 1
    Read from remote host domain.tld: Connection reset by peer
    Connection to domain.tld closed.
    debug1: Transferred: stdin 0, stdout 0, stderr 98 bytes in 542.6 seconds
    debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.2
    debug1: Exit status -1


    wie geschrieben, nach der passworteingabe kommt kein "prompt", also ich kann nichts tun und werde irgendwann ausgeloggt. das passiert nicht nur bei dem einen server, auch bei anderen funktioniert das nicht, andere mac-user können sich einloggen und mit nem windows-laptop kann ich mich auf dem selben server mit dem selben internetanschluß (wie mein mac) einloggen...
     
  2. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    hmm, sagt da das log des servers irgendwas, weshalb er die connection resetted?
     
  3. quax

    quax Gast

    leider steht dazu nichts drin...
     
  4. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    <OT>
    Hallo quax und willkommen im Forum! Hoffentlich verwechselt man uns nicht... ;)
    </OT>
     
  5. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    hmm komisch...

    das einzige was mir auffällt ist, dass os x nur mit der version 3.8.1 fährt, der server aber mit 4.2, aber das sollte ja nun wirklich völlig abwärtskompatibel sein. vielleicht findest du auf den pages von openssh mehr troubleshooting-tips....
     
  6. commander

    commander Baldwins roter Pepping

    Dabei seit:
    25.02.04
    Beiträge:
    3.210
    War da nicht mal was mit SSH2? Force mal ssh1 mit der -1 Option - nur so testhalber.
     
  7. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Also ich glaube nicht, dass es an der ssh-Version liegt (siehe Log, da steht ja eindeutig 2.0 drin). Klappt der Zugriff eventuell von einem "frischen" Testaccount aus?
     
  8. quax

    quax Gast

    jo, danke erstmal. also mit -1 geht da auch nichts und das war eigentlich ein frischer account, auch auf dem zweiten server wo es auch nicht klappt. wie gesagt, in den log-files stehe ich als anwesend o_O

    kann es an diesem "No credentials cache found" (steht oben in dem log) liegen? sollte ich die datei known_hosts mal editieren?

    das blöde ist, andere mac-user haben zugang zum server, ohne probleme...

    @quarx: glaube nicht das es zu verwechslungen kommt. ich bin der, der erstmal de dummen fragen und wenigen beiträge hat ;)
     
  9. Cyrics

    Cyrics Neuer Berner Rosenapfel

    Dabei seit:
    01.04.05
    Beiträge:
    1.975
    es ist höchstwahrscheinlich die known_hosts oder /etc/hosts.allow oder /etc/hosts.deny
    Bei Hosts.allow musste ich alle freischalten, aber da ist es besser einen kleinen Sicherheitssatz runterzusetzen:
    ALL : ALL : spawn (/usr/sbin/safe_finger -l @%h | /bin/mail -s "Port Denial note
    d %d-%h" root) & : DENY

    und schau dir auch besser mal die etc/ssh/sshd_config:
    ich hab da z.B. eine Extra SSH-Gruppe, und dabei noch die User einzeln beschränkt. Weiterhin snid viele User auch extra abgelehnt.
    Weiterhin solltest du dir mal das TCP-Forwarding anschauen. Ich hatte damit immer meine Problemchen im Zusammenhang mit SSH. Ich hab es nun hinbekommen, dass ich es einfach neuninstallierte und bei SSH erlaubte.

    Vielleicht hilft dir das ja ein bissel weiter :)
     
  10. commander

    commander Baldwins roter Pepping

    Dabei seit:
    25.02.04
    Beiträge:
    3.210
    Deswegen bist Du hier, oder? Aber leider fällt mir nichts Schlaues ein.

    Gruß,

    .commander
     

Diese Seite empfehlen