1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

EFI Update schlägt fehl - Macbook late 2008

Dieses Thema im Forum "macOS & OS X" wurde erstellt von leibnizkeks, 16.12.08.

  1. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Hi Leute,

    ich versuche seit Tagen verzweifelt das aktuelle EFI Firmware Update auf mein 2,0 Ghz Macbook (late 2008) aufzuspielen. Bei der Installation bricht er allerdings immer mit folgender Meldung ab: "Die Firmware konnte wegen eines Fehlers (28:3) nicht aktualisiert werden. Möglicherweise wird das Partitionsschema der Festplatte nicht unterstützt. Die müssen von einem RAID oder GUID-Partitionsschema starten."
    Laut der (bei der Fehlermeldung) hinterlegten URL, tritt dieser Fehler auf, wenn die Platte falsch partitioniert und formatiert ist - zb kein Mac OS Format, sondern FAT oder NTFS. Das Festplatten-Dienstprogramm sagt mir aber eindeutig, dass das aktuelle Format "Mac OS Extended (Journaled)" ist.

    Was mache ich also falsch?!

    Gruß & Danke

    edit: ich meine übrigens dieses Update: http://www.apfeltalk.de/forum/firmware-updates-f-t190074.html
     
  2. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Hmmm hatte niemand das gleiche Problem?!

    Gruß
     
  3. Ikezu Sennin

    Ikezu Sennin Schöner von Bath

    Dabei seit:
    15.07.07
    Beiträge:
    3.649
    Lädst du das Update über die Softwareaktualisierung?
    Falls ja, probier es mal, in dem du das Update über die Apple-Seite runterlädst und dann installierst.
     
  4. Casi

    Casi Spartan

    Dabei seit:
    21.12.07
    Beiträge:
    1.601
    das bringt leider nichts. Ich hatte dasselbe Problem.
    Du kommst leider nicht um eine Neuinstallation von MacOSX herrum.

    Deine Festplatte, wie auch meine, wurde mit der MBR Partitionstabelle formatiert. Das EFI Update braucht aber eine GUID Partitionstabelle.

    Ich habs so gelöst:

    TimeMachine Backup gemacht.
    Mac OSX Install DVD eingelegt.
    Festplatte neu formatiert und bei den Optionen von MBR auf GUID gewechselt.
    Nach der Installation aus dem TimeMachine Backup alles wiederherstellen lassen.

    Fertig.

    Danach konnte ich auch das EFI Update ohne Probleme installieren.

    Gruß,
    Casi
     
    gugucom gefällt das.
  5. xScorpiex

    xScorpiex Eifeler Rambour

    Dabei seit:
    02.02.06
    Beiträge:
    596
    nicht gerade eine unkomplizierte Lösung :/
     
  6. Casi

    Casi Spartan

    Dabei seit:
    21.12.07
    Beiträge:
    1.601
    Aber leider die einzige.

    Viel Erfolg schonmal an den Threadersteller.
     
  7. Ikezu Sennin

    Ikezu Sennin Schöner von Bath

    Dabei seit:
    15.07.07
    Beiträge:
    3.649
    So kompliziert ist das gar nicht. Wiederherstellen per TimeMachine klappt relativ gut und problemlos.
    Ist halt etwas zeitaufwändig.
     
  8. Casi

    Casi Spartan

    Dabei seit:
    21.12.07
    Beiträge:
    1.601
    Man sollte nur nicht vergessen, MBR auf GUID umzustellen. Sonst war der ganze 'Stress' umsonst.

    Die Frage ist eher, warum Apple einige Alu Notebooks mit MBR ausliefert, anstatt ihr GUID??
     
  9. gugucom

    gugucom Spätblühender Taffetapfe

    Dabei seit:
    22.09.08
    Beiträge:
    2.772
    Ich glaube nicht, dass Apple ohne GUID ausliefert.

    Der Fehler wird auch angezeigt wenn User die unsichtbare EFI Treiber Partition löschen. Einige Anleitungen haben fälschlich dazu aufgefordert um Formatierungsprobleme mit Bootcamp zu lösen.

    Beim EFI Update wird die Treiberpartition benötigt.

    Mit dem Terminal Befehl "diskutil list" kann man nachsehen ob es ok ist.

    Abhilfe ist genau die gleiche. Allerdings muß man zusätzlich die Win Partition sichern und wieder herstellen.
     
  10. xScorpiex

    xScorpiex Eifeler Rambour

    Dabei seit:
    02.02.06
    Beiträge:
    596
    oh ja, das kommt ja auch noch hinzu. dann muss ich mein Windows auch wieder neu aufsetzen.
     
  11. gugucom

    gugucom Spätblühender Taffetapfe

    Dabei seit:
    22.09.08
    Beiträge:
    2.772
    Du kannst es mit Winclone sichern und zurückspielen. Das dürfte erheblich schneller sein als Windows neu zu machen. Um die Bootcamp Partitionierung und anschließende Windows Formatierung wirst du allerding kaum herum kommen.
     
  12. xScorpiex

    xScorpiex Eifeler Rambour

    Dabei seit:
    02.02.06
    Beiträge:
    596
    Meine Güte, das ganze ist ja anscheinend nicht mal mein Vergehen. Ich hab ehrlich gesagt keine da jetzt ne Stunde Zeit auf zu bringen. Warum hab ich den dieses blöde MBR??? Versteh ich absolut nicht. Vielleicht bringen die ja noch eine neue Firmware mit MBR.

    Gruß

    Ayk
     
  13. gugucom

    gugucom Spätblühender Taffetapfe

    Dabei seit:
    22.09.08
    Beiträge:
    2.772
    Du hast garantiert GUID gehabt, weil sonst gar keine native Windows Installation bei dir geklappt hätte. Auf MBR installiert nur Windows und kein OS X. Auf Apple nur OS X und kein Windows.

    Poste doch mal deinen Ausdruck vom Befehl "diskutil list"
     
  14. Casi

    Casi Spartan

    Dabei seit:
    21.12.07
    Beiträge:
    1.601
    Code:
    StasiBook:~ Casi$ diskutil list
    /dev/disk0
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:     FDisk_partition_scheme                        *149.1 Gi   disk0
       1:                  Apple_HFS Macintosh HD            127.9 Gi   disk0s1
       2:               Windows_NTFS Windows HD              21.0 Gi    disk0s2
    StasiBook:~ Casi$
    Natoll. Das stimmt sogar ;)
    Ich hab jetzt auch wieder MBR anstatt GUID. Echt scheisse. Denn Windows bekomme ich nicht installiert wenn ich die kleine Partition am Anfang lösche, während der Windows installation.
    Kann man den Fehler ohne neuinstallation beheben? Also dass er wieder GUID hat, anstatt MBR?
     
  15. gugucom

    gugucom Spätblühender Taffetapfe

    Dabei seit:
    22.09.08
    Beiträge:
    2.772
    Nein, da muß neu partitioniert werden. Überraschend ist für mich, dass bei der Tabelle beide Betriebssysteme gehen. Aber vielleicht wird das auch nur falsch ausgewertet, wenn die EFI Treiber Partition fehlt.
     
  16. Casi

    Casi Spartan

    Dabei seit:
    21.12.07
    Beiträge:
    1.601
    Mist, schon wieder neu machen *grml*

    Läuft ne Vista Installation ohne diese 'Medienfehler' bzw 'hal.dll' Fehler?
    Dann mach ich nochmal alles neu und installiere mir Vista ...
     
  17. gugucom

    gugucom Spätblühender Taffetapfe

    Dabei seit:
    22.09.08
    Beiträge:
    2.772
    XP und Vista ist prinzipiell nicht anders in der Installation. Man muß die Partitionierung/Formatierung/Update Reihenfolge genau einhalten. Dazu gibts die Kurzanleitung ganz oben im Forum "Windows auf Mac" von mir.
     
    Casi gefällt das.
  18. Casi

    Casi Spartan

    Dabei seit:
    21.12.07
    Beiträge:
    1.601
    Assklar, ich werds mir dann gleich mal reinziehen.

    Wünscht mir Glück :)
    Bis in ca 2 Stunden ^^
     
  19. leibnizkeks

    leibnizkeks Querina

    Dabei seit:
    13.04.06
    Beiträge:
    182
    Erst einmal Danke für das viele Feedback.
    So wie es ausschaut, habe ich auch MBR drauf:

    Code:
    /dev/disk0
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:     FDisk_partition_scheme                        *298.1 Gi   disk0
       1:                  Apple_HFS Mac OS X                298.1 Gi   disk0s1
    
    Das ist natürlich mal fürn Arsch...
    Für Time Machine brauche ich jetzt "nur" noch eine weitere externe 320 GB Platte, um das ganze zu testen. Bleiben denn dann auch alle Programmeinstellungen (inkl Mails etc) erhalten?

    >> Bis in ca 2 Stunden ^^

    Und? Hat sich etwas ergeben?

    Gruß
     
  20. gugucom

    gugucom Spätblühender Taffetapfe

    Dabei seit:
    22.09.08
    Beiträge:
    2.772
    Das ist mit 99%tiger Sicherheit eine GUID Tabelle gewesen, bei der die unsichtbare #1 EFI Treiber Partition gelöscht wurde. Dann erkennt EFI die GUID Tabelle nämlich nicht mehr. Bei Casi war das ja hier im Thread klar nachvollziehbar.

    Für Bootcamp dann bitte diese Kurzanleitung benutzen:
    http://www.apfeltalk.de/forum/medienfehler-hall-dll-t187507.html
     
    #20 gugucom, 19.12.08
    Zuletzt bearbeitet: 19.12.08

Diese Seite empfehlen