1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

drupal auf mamp: mails mit logindaten kommen nicht an

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von eyecandy, 08.01.09.

  1. eyecandy

    eyecandy Graue Französische Renette

    Dabei seit:
    08.12.05
    Beiträge:
    12.210
    ich habe hier eine frische drupal-installtion auf mamp zum testen. im zuge der einrichtung des admin-users verschickt drupal eine mail an die angegebene mailadresse. dort kommt allerdings nichts an (auch nicht im spam-ordner). ohne dieses mail kein login (als admin) in das drupal-backend.

    was kann ich wie ändern, um einen erfolgreichen mailversand zu erzielen bzw. den admin manuell einzurichten?
     
  2. knacky

    knacky Tydemans Early Worcester

    Dabei seit:
    09.10.06
    Beiträge:
    396
    Äh, also ich kenn MAMP jetzt gar nicht. Aber da du von testen sprichst, gehe ich davon aus, dass es lokal ist, und du lokal wohl kaum einen Mailserver laufen hast. Das Passwort welches Drupal für den Admin erstellt, ist das, welches du beim ersten Login benützt.

    Ich hoffe, ich konnte dir mit der Antwort helfen.

    Freundliche Grüsse
     
  3. eyecandy

    eyecandy Graue Französische Renette

    Dabei seit:
    08.12.05
    Beiträge:
    12.210
    ganz so einfach ist es nicht. das passwort vergibt drupal selbst und sendet es an die angegebene mailadresse.

    der mailversand, etwa für systemstatus-infos, funktioniert aus mamp mit anderen installationen sonst eigentlich sehr gut, nur drupal stellt sich da irgendwie quer (oder ich habe in mamp etwas verstellt, was mir nicht bewusst ist) ...
     
  4. knacky

    knacky Tydemans Early Worcester

    Dabei seit:
    09.10.06
    Beiträge:
    396
    Welche Version von Drupal benützt du? Ich habe es bereits mehrmals installiert und bin mir fast sicher, dass der erste Login gilt.

    Freundliche Grüsse
     
  5. eyecandy

    eyecandy Graue Französische Renette

    Dabei seit:
    08.12.05
    Beiträge:
    12.210
    ich nutze die aktuelle letzte version: 6.6

    hier kann ich einen user nur anlegen mit namen und mailadresse, nicht mit passwort.

    ich bin jetzt via umbiegen der mailadresse auf name@localhost und auslesen via terminal soweit, dass ich das passwort ändern konnte (kein dauerhafter zustand, aber fürs erste mal hilfreich). allerdings ist der angelegte user "admin" auch eingeloggt ohne admin-status, d.h. ich habe keinen zugriff auf den admin-bereich?

    wie lege ich einen admin-user an?
     
  6. eyecandy

    eyecandy Graue Französische Renette

    Dabei seit:
    08.12.05
    Beiträge:
    12.210
    das problem hat sich geklärt. ein fehler (zu wenig speicherzuweisung in mamp) bei der installtion führt diese nicht zu ende. danach läßt sich auch der admin-user nicht mehr anlegen.

    jetzt funktioniert alles. danke.
     
  7. knacky

    knacky Tydemans Early Worcester

    Dabei seit:
    09.10.06
    Beiträge:
    396
    Hab mir jetzt sogar noch extra die Mühe gemacht und Drupal 6.6 mal selber installiert. Habe mich also nicht geirrt. Hier (siehe Screenshot) gibt man den Admin User an.

    Edit: Btw. hättest es vielleicht am Rande erwähnen müssen, dass du einen Error kriegst... Wäre hilfreich gewesen... ;)

    Freundliche Grüsse
     

    Anhänge:

    eyecandy gefällt das.
  8. eyecandy

    eyecandy Graue Französische Renette

    Dabei seit:
    08.12.05
    Beiträge:
    12.210
    sorry für die mühen. und nochmals vielen dank. dein post brachte mich erst auf die fhelersuche in die richtige richtung!
     
  9. knacky

    knacky Tydemans Early Worcester

    Dabei seit:
    09.10.06
    Beiträge:
    396
    Gern geschehen. Wünsche dir noch einen schönen Tag und viel Spass mit Drupal.

    Btw: Von Drupal ist schon die 6.8 draussen, dass geht immer blitzschnell.

    Freundliche Grüsse
     
  10. eyecandy

    eyecandy Graue Französische Renette

    Dabei seit:
    08.12.05
    Beiträge:
    12.210
    für die neuinstalltion habe ich bereits 6.8 genutzt :)

    jetzt steht mir die auseinandersetzung mit modulen und vor allem theming bevor. ich muss eigene themes erstellen/implementieren und hoffe, dass ich dies auch mit meinen rudimentären php-kenntnissen schaffe.
     
  11. knacky

    knacky Tydemans Early Worcester

    Dabei seit:
    09.10.06
    Beiträge:
    396
    iPd gefällt das.
  12. eyecandy

    eyecandy Graue Französische Renette

    Dabei seit:
    08.12.05
    Beiträge:
    12.210
    1000 dank. da habe ich jetzt reichhaltige quellen.

    damit sollte ich hoffentlich diese theme-struktur umsetzen können.

    [​IMG]
     
  13. knacky

    knacky Tydemans Early Worcester

    Dabei seit:
    09.10.06
    Beiträge:
    396
    Das sollte klappen. Bitte zeige dann dein Ergebnis.

    Freundliche Grüsse
     
  14. McAtze

    McAtze Macoun

    Dabei seit:
    29.08.04
    Beiträge:
    120
    Ich hab inzwischen 6.16 drauf und Drupal schickt bei mir auch keine Loginmails raus. Hab auch den memory_limit auf 32MB hochgesetzt. Hilft nicht ... Ideen?
    Bei mir läuft auch MAMP.
     
  15. knacky

    knacky Tydemans Early Worcester

    Dabei seit:
    09.10.06
    Beiträge:
    396
    Da zitiere ich mich doch glatt selbst:

    :)

    Btw. Jetzt kenn' ich MAMP ;)
     
  16. Kiteman

    Kiteman Jamba

    Dabei seit:
    05.09.06
    Beiträge:
    55
    Hi,

    also überdenke mal Deinen Lösungsweg.

    Wenn die Login Mails nicht ankommen muss doch nicht ein Memory Problem vorliegen, das ist vielleicht das letzte was man kontrolliert ausser es gibt einen eindeutigen Hinweis.

    Installiere mal das SMTP Module für Drupal
    http://drupal.org/project/smtp
    Aktiviere debugging

    Zuerst folgende Angaben kontrollieren und dann eintragen

    mailserver adresse
    email adresse / konto
    zugangsdaten

    Wichtig Daten vom Sender und Empfänger doppelt kontrollieren.
    Spamfilter beim Empfänger deaktivieren.
    Kontrollieren ob nicht ein mail relay problem vorhanden ist, z. B. wegen fehlender SMTP Authentifizierung.

    In dem SMTP Module kannst Du dann auch einen test machen. Wenn es damit funzt kannst Du es noch mal mit den Drupal Standard Einstellungen versuchen. Das geht aber nur unter bestimmten Voraussetzungen bei Mac OS 10.5

    so long
    Kiteman
    www.noesis.de
     

Diese Seite empfehlen