1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

"Document Window" im Interface Builder

Dieses Thema im Forum "OS X-Developer" wurde erstellt von trapdoor, 12.12.07.

  1. trapdoor

    trapdoor Gast

    Hallo zusammen,
    ich habe eine kleine Frage bezüglich Xcode 3.0 bzw. dem aktuellen Interface Builder.

    Ich gucke mir grade die schicken Tutorials vonhttp://cocoadevcentral.com an und habe da ein kleines Problem. Selbige sind noch mit einer älteren Version von Xcode geschrieben, so dass der in Tutorial http://cocoadevcentral.com/d/learn_cocoa_two/ unter Punkt 12 beschriebene Punkt, bzw. das Document Window im Interface Builder wohl einem Redesign zum Opfer gefallen ist.

    Kann mir jemand erklären wie Mensch das ganze jetzt richtig machen kann?
     
  2. below

    below Kalterer Böhmer

    Dabei seit:
    08.10.06
    Beiträge:
    2.865
    1) Du kannst auch Xcode 2.5 auf Leopard installieren. Dann hast Du eine Version, die auch die ganzen Tutorials benutzen. Das ist vielleicht für den Anfang gar keine schlechte Idee

    2) Schritt 12 ist ja nur Informativ. Das Problem ist ja eher Schritt 13. Hier ist der Workflow bei Xcode 3 anders:

    * Wähle aus der "Library" ein "NSObject" Object und ziehe es in Dein NIB Fenster
    * Gehe in den "Identity Inspector" (Tools Menu)
    * Als "Class" wähle "appController"

    Jetzt siehst Du auch die Informationen aus Schritt 12

    Alex
     
  3. trapdoor

    trapdoor Gast

    Hey, danke für deine Antwort.

    Ich habe mal versucht eine ältere Version von Xcode zu installieren, dummerweise startet diese unter Leopard nichtmehr.

    Ich werde mal versuchen das ganze mit deinem Workaround, oder besser gesagt der jetzt korrekten Arbeitsweise zu realisieren.
     
  4. MacApple

    MacApple Lord Grosvenor

    Dabei seit:
    05.01.04
    Beiträge:
    3.470
    Was heißt ältere Version? Alex sprach von Xcode 2.5. Ältere Versionen gehen nicht unter Leopard.

    MacApple
     
  5. trapdoor

    trapdoor Gast

    Ist denn die Version auf der Tiger DVD 2.5? Weil die habe ich versucht zu installieren...
     
  6. below

    below Kalterer Böhmer

    Dabei seit:
    08.10.06
    Beiträge:
    2.865
    Nein, Xcode 2.5 gibt es nur zum Download

    Alex
     
  7. trapdoor

    trapdoor Gast

    Cool, danke für deine Antwort, dann probier ich's jetzt nochmal

    Edit: Alles klar, mit Version 2.5 funktioniert alles, danke für eure Mühen
     
    #7 trapdoor, 15.12.07
    Zuletzt von einem Moderator bearbeitet: 15.12.07

Diese Seite empfehlen