1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

DNS-Probleme mit WLAN

Dieses Thema im Forum "iPhone" wurde erstellt von mousseman, 24.07.08.

  1. mousseman

    mousseman Idared

    Dabei seit:
    23.12.06
    Beiträge:
    25
    Ich habe hier ein iPhone 2G mit einem lästigen DNS-Problem, dass ich mir nicht erklären kann.

    Kurz das Setup:

    - internes LAN im 10.x Bereich, mit DNS-Auflösung und DHCP
    - EDGE

    Innerhalb des internen LANs, wo ich u.a. auch ein MacBookPro OS X 10.5 betreibe und mehrere PCs, funktioniert ohne Hosts-File oder WINS-Server die DNS-Auflösung für den Server "foobar", sprich, ich kann "ping foobar" eingeben, und es wird die richtige IP-Adresse ermittelt. Hosts-File ist auch keines gepflegt, so dass ich auch diese Quelle ausschliessen kann. Auch das auflösen von externen Hosts (z.B. www.heise.de) funktioniert.

    Jetzt hat das iPhone aber mit dem ersteren Probleme - gebe ich in der Terminal-Applikation von Cydia (oder in Mail) "ping foobar" ein, kommt "Host not found". Gebe ich die IP-Adresse ein, klappt allerdings alles perfekt. Mit dem MBP und den Windows-Maschinen gehts.

    DHCP-Einstellungen werden vom iPhone richtig gezogen, inklusive den Default Domain Name (foobar.meek.org), aber ich kann vom iPhone aus nur externe Hosts auslösen, intern geht nicht. WLAN-Router sind Linksys WRTG54L, aber das dürfte nicht das Problem sein, dass es sonst bei keiner Maschine gehen dürfte. Die externe Auflösung meiner DNS klappt, da ich von EDGE aus den Namen auflösen kann, nur natürlich mit der externen IP (die geNATted wird).

    Firmware ist 2.0, pwned mit dem Pwnage-Tool 2.0.1 und dem Restore-IPSW 347, DNS-Server ist eine aktuelle Version von bind. Sind mit dem iPhone einige DNS-Probleme bekannt?
     

Diese Seite empfehlen