1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

dhcp problem (erhalte selbst zugewiesene ip adresse)

Dieses Thema im Forum "WLAN, Airport & TimeCapsule" wurde erstellt von armin_r, 27.12.08.

  1. armin_r

    armin_r Granny Smith

    Dabei seit:
    23.07.07
    Beiträge:
    12
    hallo

    ich habe auf meinem macbook pro folgendes problem:
    sämtliche netzwerkverbindungen beziehen über dhcp keine ip adresse. ich erhalte ständig die meldung "AirPort hat eine selbst zugewiesene IP-Adresse und kann möglicherweise nicht auf das Internet zugreifen."
    manuelle adressvergabe funktioniert, das problem dürfte also an dhcp liegen.
    es betrifft ethernet und airport, sowie offene und verschlüsselte netze in gleicher weise. andere rechner kriegen am router problemlos eine adresse zugewiesen und es funktionierte bisher auch problemlos.
    an anderen routern tritt das problem ebenfalls auf. lediglich die einwahlverbindung über das externe hsdpa modem funktioniert.
    die manuelle adressvergabe wäre für mein privates netz eine alternative, in fremden netzten komme ich damit nicht weit.

    den router kann ich als ursache weitgehend ausschließen, da das problem an anderen routern ebenfalls auftritt und es bisher auch problemlos funktionierte. es dürfte also am mac liegen.

    das pram habe ich bereits gelöscht. brachte nichts.

    hat jemand ideen? im internet fand ich bisher keine lösung.

    lg
    armin
     
  2. Scotch

    Scotch Ananas Reinette

    Dabei seit:
    02.12.08
    Beiträge:
    6.247
    Feste Adresszuweisung beenden und durch DHCP-Lease ersetzen.

    HTH,
    Dirk
     
  3. armin_r

    armin_r Granny Smith

    Dabei seit:
    23.07.07
    Beiträge:
    12
    genau das funktioniert eben nicht, da per dhcp keine daten zugewiesen werden. erneuern des dhcp lease funktioniert auch nicht. alles bereits getestet.
     
  4. Scotch

    Scotch Ananas Reinette

    Dabei seit:
    02.12.08
    Beiträge:
    6.247
    Adressraum des Routers ist ausreichend gross definiert?

    Gruss,
    Dirk
     
  5. armin_r

    armin_r Granny Smith

    Dabei seit:
    23.07.07
    Beiträge:
    12
    ja, das ist nicht das problem. habe auch schon erfolglos am router eine adresse zu reserviert.

    nach einigem stöbern bin ich auf einen zusammenhang zum programm configd gestoßen. das meldet sich seit kurzem über die osx-firewall bei mir. gelegentlich werde ich beim systemstart gefrat, ob configd eingehende netzwerkverbindungen akzeptieren darf. manachmal nicht. wenn ich gefragt werde und es zulasse, dann dürfte die adresszuweisung funktionieren. ein user eines anderen forums berichtete ähnliches. eventuell liegt es am zusammenspiel zwischen osx-firewall und configd. hat damit jemand erfahrung? vorerst habe ich configd bei den firewall settings manuell freigegeben. momentan läufts, aber das tat es auch in den letzen tagen gelegentlich.
     
  6. Scotch

    Scotch Ananas Reinette

    Dabei seit:
    02.12.08
    Beiträge:
    6.247
    Das klingt alles ziemlich seltsam. Du kannst ja mal mit

    Code:
    configd -V IPConfiguration
    schauen, ob du irgendeine erhellende Fehlermeldung bekommst. Die Firewall sollte man für DHCP definitiv nicht deaktivieren müssen und eine Ausnahme dafür definieren ebenfalls nicht.

    Gruss,Dirk
     
  7. armin_r

    armin_r Granny Smith

    Dabei seit:
    23.07.07
    Beiträge:
    12
    nachdem es nun ein paar tage funktionierte, streikte dhcp heute wieder. bei aktivierter firewall funktioniert das erneuern des dhcp lease nicht und ich erhalte keine daten zugewiesen. dekativiere ich die osx firewall (little snitch läuft jedoch weiter) kann ich den dhcp lease problemlos erneuern. seltsam!
    das oben stehende kommande habe ich im terminal mal versucht (bin kein freund der shell und dementsprechend unerfahren) und erhielt folgendes:
    *** configd (daemon) failed to start, exit status=69
    an den adminrechten dürfte es nicht liegen. erhielt zuerst eine meldung wegen fehlender reche und habe es dann mit sudo gestartet und wurde nach dem admin passwort gefragt.

    irgendwelche ideen? scheint unerklärbarer weise mit der firewall zusammenhängen.

    lg
    armin
     
  8. mag

    mag Riesenboiken

    Dabei seit:
    20.12.07
    Beiträge:
    290
    Versuchs mal mit:

    ipconfig getpacket en1

    und poste die Ausgabe.
     
  9. philmriss

    philmriss Tydemans Early Worcester

    Dabei seit:
    24.07.08
    Beiträge:
    396
    Habe das gleiche Probem, habe oben stehenden Befehl ausgeführt:

    Kommt leider gar nix bei rum :(



    Bitte um Hilfe!
    Bekomme nur ne selbstzugewiesende IP.(Fängt immer mit 169 an, normalerweise ja 192.)
     
    #9 philmriss, 09.01.09
    Zuletzt bearbeitet: 09.01.09
  10. philmriss

    philmriss Tydemans Early Worcester

    Dabei seit:
    24.07.08
    Beiträge:
    396
    Hat sich grad erledigt.
    Habe alles im Router neu eingegeben und siehe da, es geht wieder :)
    Warum auch immer.
     
  11. trillianer

    trillianer Roter Delicious

    Dabei seit:
    19.08.07
    Beiträge:
    94
    und was hast du denn alles neu eingegeben? Habe das selbe Problem und bei mir schaut das etwa so aus:
    op = BOOTREPLY
    htype = 1
    flags = 0
    hlen = 6
    hops = 0
    xid = 570247569
    secs = 1
    ciaddr = 0.0.0.0
    yiaddr = 192.168.1.196
    siaddr = 0.0.0.0
    giaddr = 0.0.0.0
    chaddr = 0:1c:b3:76:8:ec
    sname =
    file =
    options:
    Options count is 7
    dhcp_message_type (uint8): ACK 0x5
    server_identifier (ip): 192.168.1.1
    lease_time (uint32): 0x3840
    subnet_mask (ip): 255.255.255.0
    router (ip_mult): {192.168.1.1}
    domain_name_server (ip_mult): {192.168.1.1}
    end (none):


    DHCP lässt sich auf dem Airport Dienstprogramm nicht erneuern
     
  12. sku

    sku Golden Delicious

    Dabei seit:
    25.08.10
    Beiträge:
    6
    Habe exakt das gleiche Problem

    Liebe Foren-Mitglieder, ich hab' immer wieder exakt das gleiche, oben beschriebene, Problem. Alle paar Wochen bekomm' ich keine Internet-IP-Adresse zugewiesen und kann daher über WLAN und LAN nicht ins Internet. Es funktioniert nur per HSDPA-Modem und wenn man die IP-Adresse selbst einträgt. Auch andere Programme, die offenbar einen funktionierenden DHCP-Server benötigen, funktionieren gar nicht. Parallels zum Beispiel lässt sich nicht öffnen, immer wenn dieses Problem auftritt - und leider tritt es dann oft wochenlang auf. Ich hab' die Dateiberechtigungen mit dem Festplattendienstprogramm repariert, das Volume überprüft etc. - alles ohne Erfolg. Auch in einem anderen Forum hab' ich dieses Problem schon gelesen - auch ohne Lösung, allerdings mit einem Tipp, der nicht schaden kann:

    > hast du den zugriff auf configd und mDNSresponder erlaubt?
    > beim klick auf den plus-button kriegst du ein auswahlfeld
    > (springt bei mir direkt in den Programme-ordner),
    > dort kannst du mit apfel-shift-g auch einen pfad eingeben.
    > wenn du da mal /usr/sbin eingibst, kannst du die genannten programme auswählen.
    (C) zo vom Mac OS X Hints Forum - ich hoff', ich verstoß' mit diesem Zitat nicht gegen die Forumsregeln, zitieren ist ja eigentlich immer legal.


    Meine Konfiguration ist: Macbook 2,13 Ghz Intel Core 2 Duo, 4 GB 800 Mhz DDR2 SDRAM, Mac OS X 10.5.8,
     
  13. sku

    sku Golden Delicious

    Dabei seit:
    25.08.10
    Beiträge:
    6
    P.S: Ich glaube übrigens nicht, dass sich das Problem lösen lässt, wenn man etwas in den Router reinschreibt, weil ja das Problem bei allen Routern auftritt.
     
  14. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Gibt es zufällig mehrere aktive DHCP-Server im Netz? Das wäre pöse.
    Zu diesen aktiven DHCP-Servern kann übrigens auch eine virtuelle Maschine gehören, oder auch das Virtualisierungsprogramm selbst, wenn die Einstellungen unklug gewählt sind. (Auch wenn das Programm nicht läuft)
    Ebenfalls eine beliebte Quelle der Freude sind Geräte, deren fest eingestellte Addresse auf x.x.x.0 oder x.x.x.255 gewählt wurde, beides ist unzulässig.
     
  15. sku

    sku Golden Delicious

    Dabei seit:
    25.08.10
    Beiträge:
    6
    Danke für die Reaktion, aber nein, mehrere DHCP-Server gibt's nicht. Ausserdem tritt das Problem, wenn es da ist, ja bei allen Netzen auf. Und Geräte-IP-Adressen vergebe ich auch keine. Gerade tritt das Problem wieder auf. Ich hab' auch den Code:

    "configd -V IPConfiguration" eingegeben und die gleiche Fehlermeldung bekommen wie der User armin_r --> Fehlermeldung: *** configd (daemon) failed to start, exit status=69
    Ich kann das Problem nur umgehen, indem ich die IP-Adresse fix eingebe oder die Firewall kurz deaktiviere und den DHCP-Release erneuere und dann die Firewall wieder einschalte. Das Problem kommt daher ganz klar von der Firewall.

    Das Ärgerliche daran ist halt, dass Parallels dadurch auch nicht funktioniert.
     
  16. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.905
    Benutzen (oder benutzten) wir irgendwelche Tools zur Firewall-Konfiguration? (WaterRoof etc...)
    LittleSnitch im Einsatz?
    An /etc/hosts oder ähnlich lebenswichtigen inneren Organen des Unix-Dinosauriers rumgeschraubt?
     
  17. sku

    sku Golden Delicious

    Dabei seit:
    25.08.10
    Beiträge:
    6
    Nö. Ich hab' auch schon alle möglichen Programme deinstalliert.
     

Diese Seite empfehlen