1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

das Programm "Mail" ausblenden???

Dieses Thema im Forum "macOS & OS X" wurde erstellt von gustavmega, 02.06.06.

  1. gustavmega

    gustavmega Goldparmäne

    Dabei seit:
    15.02.06
    Beiträge:
    564
    Hallo,

    ich habe unter Systemeinstellung -> Benutzer -> Startobjekt so eingestellt, daß beim Systemstart das Programm "Mail" auch gestartet wird und auch ein Häckchen beim Option Ausblenden gemacht, aber beim Systemstart wenn das Programm gestartet wird, wird es nicht ausgeblendet, was nämlich bei andere Programmen super mit Ausblenden funktioniert.
     
  2. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    also ich hätte das nie bemerkt.
    suitcase macht das auch nicht.
    ich klick dann einfach mit gedrückter alt taste auf den schreibtisch.
    so lassen sich alle programme ausblenden und einblenden (über´s dock)

    HTH
    mike
     
  3. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Diesen Fehler gibt es schon seit einigen OS-X-Revisionen. Leider scheint er nicht wichtig genug zu sein, um endlich mal repariert zu werden.

    Umgehen laesst sich das mit einem AppleScript, das man statt Mail.app in die Log-in-Items zieht:

    -- AppleScript-Anfang --
    tell application "Mail" to activate
    tell application "Finder" to set visible of every process whose name is "Mail" to false
    -- AppleScript-Ende --
     
  4. gustavmega

    gustavmega Goldparmäne

    Dabei seit:
    15.02.06
    Beiträge:
    564
    erstmal Danke für die Antwort :) Ich bin aber ein totaler Anfänger :-[
    als was muß ich:

    -- AppleScript-Anfang --
    tell application "Mail" to activate
    tell application "Finder" to set visible of every process whose name is "Mail" to false
    -- AppleScript-Ende --

    speichern?
     
  5. Peter Maurer

    Peter Maurer Carmeliter-Renette

    Dabei seit:
    16.03.04
    Beiträge:
    3.274
    Oeffne den Skripteditor (/Programme/AppleScript/Skripteditor.app), dann sollte sich automatisch ein leeres AppleScript-Dokument oeffnen. Da kopierst Du das o.g. AppleScript rein und speicherst das ganze als "Dateiformat: Programm".

    Das so entstandene Programm ziehst Du schliesslich in Deine Log-in-Items.
     
    alex_neo gefällt das.
  6. gustavmega

    gustavmega Goldparmäne

    Dabei seit:
    15.02.06
    Beiträge:
    564
    VIELEN DANK, es funktioniert wunderbar :-D
     
  7. RobEightySix

    RobEightySix Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    09.07.08
    Beiträge:
    250
    Ich greife den alten Thread hier nochmal auf, da ich genau das gleiche Problem habe.

    Die Lösung über den Skripteditor funktioniert natürlich ist für mich allerdings keine perfekte Lösung, da das Programm Mail kurz gestartet und dann ausgeblendet wird...
    Würde gerne eine bessere Lösung finden.
    Hat noch jemand ne Idee oder bleibt mir nur noch das warten bis dieser Bug endlich mal gefixt wird?

    Mit freundlichen Grüßen,
    Rob
     
  8. Mosche

    Mosche Gala

    Dabei seit:
    27.12.08
    Beiträge:
    52
    Eine bessere Lösung wird es nicht geben, weil die Mail.app als Programm ja geladen werden muss. Es ist leider nicht so möglich wie bei Windows, dass man ein Flag in der Registry oder ähnlichem setzt, damit Mail.app keine "Erlaubnis" hat ein Fenster beim Starten einzublenden. Dazu müsste man die Mail.app umprogrammieren und ich schätze, dass wird Apple nicht machen. Außerdem stört es doch nicht wirklich, wenn Mail kurz eingeblendet wird, oder?
     
  9. BreZel

    BreZel Westfälische Tiefblüte

    Dabei seit:
    21.04.09
    Beiträge:
    1.060
    Also ich greife das Thema hier mal auf da ich kein neues aufmachen will...

    Ich habe seit gestern Lion drauf und habe mir es jetzt so eingerichtet dass bei der Anmeldung Safari auf Schreibtisch 1 aufgemacht wird, Mail auf Tisch 2, iTunes 3, Aperture 4, und Skype 5.

    Und das funktioniert auch bei Tisch 2-5. Allerdings wird bei der Anmeldung Safari auf Tisch 1 zwar gestartet aber minimiert. Das heißt ich muss immer nochmal auf das Safari Icon klicken um loszusurfen.

    Weiß jemand vielleicht warum das so ist ?

    Kann ich das Apple Script wie folgt umschreiben um Safari zu maximieren nach dem start ?

    -- AppleScript-Anfang --
    tell application "Safari" to activate
    tell application "Finder" to set visible of every process whose name is "Safari" to true
    -- AppleScript-Ende --

    Also ein Lösung á la "Setze einen Haken dort" wäre mir zwar lieber, denn es sollte ja eine Ursache für dieses Verhalten geben. Notfalls tut es mir ein Workaround per Script aber auch.

    g
    Me
     

Diese Seite empfehlen