1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

CSS + HTML Anzeigefehler bei Safari & Co.

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von messia04, 26.01.08.

  1. messia04

    messia04 Prinzenapfel

    Dabei seit:
    30.06.04
    Beiträge:
    544
    Hi,

    ich versuche gerade meinen ersten Entwurf meiner neuen Homepage mit CSS hinzukriegen aber irgendwie will es nicht klappen. Zum testen benutze ich immer Firefox, Safari und Opera....

    Problem
    Der gelbe Container verschwindet immer hinter dem grünen und blauen Container. Es sollte eigentlich genau unter den beiden sich platzieren, aber es funktioniert nicht. Irgendeine Idee? :eek:
    Im folgenden der Code und im Anhang ebenfalls


    Ich habe folgenden CSS-Code:
    Code:
    @charset "UTF-8";
    /* CSS Document */
    
    /*Containereinstellungen betreffent dem Rahmen und den Aufbau der Website*/
    #container{	background: #FF0000;
    			margin: 1em auto;
    			width: 1000px;
    			height:1000px;
    			border:#000000 thin;
    			}
    			
    #mainnav{	background:#00FF00;
    			width: 220px;
    			height: 300px;
    			float:left;
    			}
    
    #mainnav ul{text-align:right;
    			list-style-type:none;
    			padding-right:10px;
    			font-family:Arial, Helvetica, sans-serif;
    			}
    			
    #nav{		background:#0000FF;
    			width: 220px;
    			height: 300px;
    			float:left;
    			}
    #nav ul{	text-align:left;
    			list-style-type:none;
    			padding-left:10px;
    			font-family:Arial, Helvetica, sans-serif;
    			}
    
    #logo{		background:#FFFF00;
    			width:440px;
    			height:700px;
    			}
    	
    #contents{	background:#00FFFF;
    			width: 560px;
    			height: 1000px;
    			float:left;
    			}
    
    #footer{	background:#000000;
    			width:1000px;
    			height:20px;
    			clear:both;
    			text-align:center;
    			color:#FFFFFF;
    			}
    und folgende HTML-Datei:
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <title>ucuc.de - you see ugur cayoglu</title>
    <link rel="stylesheet" href="style.css" type="text/css" />
    </head>
    
    <body>
    
    <div id="container">
    	    <div id="mainnav">
            <ul><li><a href="#">home</a></li>
            	<li><a href="#">resimler</a></li>
                <li><a href="#">misc</a></li>
                <li><a href="#">stuff</a></li>
            </ul>
            </div>
            <div id="nav">
            <ul><li><a href="#">Erster Eintrag</a></li>
            	<li><a href="#">Überschrift 2</a></li>
                <li><a href="#">Überschrift 3</a></li>
                <li><a href="#">Überschrift 4</a></li>
                <li><a href="#">Überschrift 5</a></li>
                <li><a href="#">Überschrift 6</a></li>
                <li><a href="#">Überschrift 7</a></li>
            </ul>
            </div>
      <div id="contents">
        <h3>Überschrift</h3>
            	<p>Lorem dolor sit amet....</p>
      </div>
        	<div id="logo">
            	<h1>Das wird nicht richtig angezeigt</h1>
                <p>Das wird nicht richtig angezeigt</p>
            </div>
            <div id="footer">
            	<p>Copyright Ugur Cayoglu &copy; 2008</p>
            </div>
    </div>
    	
    </body>
    </html>
    
     

    Anhänge:

  2. dougart

    dougart Gala

    Dabei seit:
    09.04.07
    Beiträge:
    51
    Ich sehe das jetzt eigtnlich kein Problem, grün und blau sind nebeneinander, darunter gleich gelb, danach rot. Nur das der Text aus dem gelben nicht dort angezeigt wird, wo er eigentlich stehen sollte - im Safari. Im Firefox scheint alles zu klappen.
     

Diese Seite empfehlen