1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Crazy Systemeinstellung - Energie sparen...

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Poljpocket, 30.01.08.

  1. Poljpocket

    Poljpocket Salvatico di Campascio

    Dabei seit:
    07.01.07
    Beiträge:
    432
    Hallo!

    Ich verzweifle langsam. Bei meinem Macbook ist ständig eine Auschaltzeit von 17:15 täglich eingestellt, die ich nicht rausbringe. Das com.apple.AutoWake.plist:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>RepeatingPowerOff</key>
    	<dict>
    		<key>eventtype</key>
    		<string>shutdown</string>
    		<key>time</key>
    		<integer>1035</integer>
    		<key>weekdays</key>
    		<integer>127</integer>
    	</dict>
    	<key>WARNING</key>
    	<string>Do not edit this file by hand. It must remain in sorted-by-date order.</string>
    	<key>shutdown</key>
    	<array>
    		<dict>
    			<key>eventtype</key>
    			<string>shutdown</string>
    			<key>scheduledby</key>
    			<string>Repeating</string>
    			<key>time</key>
    			<date>2008-01-31T16:15:00Z</date>
    		</dict>
    	</array>
    	<key>sleep</key>
    	<array/>
    </dict>
    </plist>
    Es befindet sich in: HD/Library/Preferences/SystemConfiguration/

    Im Dictionary 'RepeatingPowerOff' ist der Wert 'time' mit 1035, was in Minuten genau 17:15 ist.
    Im Dict. 'shutdown' sind die Einstellungen für den nächsten Tag, also, wann das MacBook sich das nächste Mal ausschalten soll (Da, als ich das schreibe, 30.1. 17:15 schon vorbei ist!).

    Diese Einstellungen könnte ich ganz einfach ändern, trotz der Warnung, wenn sich das File nicht alle !!!!10 Sekunden!!!! automatisch erneuern würde. Ich habe also bei einer Version die Zugriffsrechte geändert, so dass ich das sichern könnte, plump, schon war die nächste Version da und der Editor teilte mir mit, ich hätte die Rechte nicht zum Speichern.

    Lässt sich da trotzdem was machen?

    Danke... Es kann gut sein, dass ihr nicht genau versteht, wie ich das meine, ich bin nicht gut im Schildern :(

    Edit: Betriebssystem 10.5.1 Leopard, nie solche Probleme bei Tiger...
     
  2. reab

    reab Wagnerapfel

    Dabei seit:
    07.12.04
    Beiträge:
    1.568
    Du hast aber sicherlich bereits in den Systemeinstellungen versucht diese Einstellung zu ändern?
    Systemeinstellungen / Energie sparen / Zeitplan
    Und ein komplettes löschen dieses Files und Neustart bringt auch nichts?
     
  3. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Bestimmt (siehe Threadtitel :p)

    Normalerweise sollte ein Zurücksetzen des PRAM den gewünschten Erfolg bringen … bei hartnäckigen Fällen noch ein PMU Reset

    In der Plist steht ja ausdrücklich, dass man an ihr nicht rumfummeln soll, aber so sähe eine "leere" Liste aus:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>WARNING</key>
    	<string>Do not edit this file by hand - it must remain in sorted-by-date order.</string>
    	<key>poweron</key>
    	<array/>
    	<key>shutdown</key>
    	<array/>
    	<key>wake</key>
    	<array/>
    </dict>
    </plist>
    
    Grüsse
     
  4. Poljpocket

    Poljpocket Salvatico di Campascio

    Dabei seit:
    07.01.07
    Beiträge:
    432
    Ich habe PRAM gelöscht, PMU Reset gemacht, HD repariert, File gelöscht... (schon bevor ich diesen Thread geschrieben hab)

    nützt nix...
     
  5. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Und wenn Du die Plist nicht löscht, sondern den Text durch den von mir geposteten ersetzt?
    (Bitte vorher Copy der Plist machen)

    Gruss
     
  6. Poljpocket

    Poljpocket Salvatico di Campascio

    Dabei seit:
    07.01.07
    Beiträge:
    432
    Nein das geht nicht, da ich das File danach nicht mehr speichern kann... es wird ja ständig erneuert :)

    Es treten noch andere komische Sachen mit und um Engergiemanagement auf :) Zum Beispiel: Ich schalte den Strom jeden Abend mit einer Leiste ganz aus. Am Morgen, wenn ich sie wieder einschalte, schaltet sich der Laptop automatisch ein, obwohl 'Automatisch neu starten nach Stromausfall' deaktiviert ist...
     
  7. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Arghh … ja, wer lesen kann ist im Vorteil. Du hattest es ja geschrieben...


    "Automatisch starten nach Stromausfall" ist in /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist gespeichert.

    Der "Leopard -com.apple.AutoWake.plist-Bug" dürfte dir ja bekannt sein ("Hilfe, mein Mac schaltet sich nachts um 1:00 ein" usw.) und ist ja normalerweise durch ein Löschen der Plist, Ausschalten und anschliessendem PRAM Reset beim nächsten Start zu beheben.
    Bei dir wird ja aber das File so schnell geschrieben, dass das schwer werden könnte … und ja anscheinend so auch nicht funktioniert hat.

    Zwei Ideen hätte ich … sie sind aber nur Versuche, welche ich unternehmen würde.
    1) Mit dem Terminal Kommando pmset kann man ja seine aktuellen Energie-Managment Werte abrufen und verändern. Da würde ich als erstes vergleichen, ob da etwas anderes ausgespuckt wird, als in den Systemeinstellungen angegeben ist:
    Code:
    pmset -g
    listet dir die aktuellen Werte auf
    und
    Code:
    man pmset
    die nötigen Befehle

    autorestart sollte z.B. auf 0 stehen (laut deinen Systemeinstellungen)

    2) Du löscht die beiden Plist und fährst sofort den Rechner runter (Am besten erledigst Du das auch mit dem Terminal. Dann geht es am schnellsten) Beim nächsten Start ein PRAM Reset

    Gruss
     

Diese Seite empfehlen