1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

\cite Fehlermeldung

Dieses Thema im Forum "Officeanwendungen" wurde erstellt von Zettt, 24.06.07.

  1. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Hallo

    Ich hab hier leider ein seltsames Problem.
    Als Dokumentenklasse verwende ich scrartcl als Bibliothekenstil jurabib. Nun wuerde ich gerne ein paar Quellenangaben machen.

    Wie mach ich das denn? Sonst habe ich bei \documentclass{exam} immer nur \cite{citeword} angegeben und gut war's. Mit scrartcl bekomme ich lauter Fehlermeldungen.

    Selbst wenn ich auf exam umstelle bekomme ich Fehlermeldungen. Irgendwie raff ich's seit gestern nicht, woran der Fehler liegt. Wisst ihr vielleicht Rat?
     
  2. guy_incognito

    guy_incognito Oberdiecks Taubenapfel

    Dabei seit:
    20.09.06
    Beiträge:
    2.751
    Hast du eine Verbindung zur Bibliographie-Datei? Stehen dort die zitierten Quellen drin? Wenn der die zitierten Quellen nicht finden kann, spuckt der dann haufenweise Fehlermeldungen aus.

    Könntest ja vielleicht auch mal eine Fehlermeldung hier abbilden. ;)
     
  3. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Einbinden:
    Code:
    \appendix
    \bibliographystyle{jurabib}
    \bibliography{bibliography}
    \addcontentsline{toc}{section}{\bibname}
    Fehlermeldung
    Code:
    LaTeX Warning: Citation `deviantstats' on page 8 undefined  on input line 275.
    LaTeX Warning: There were undefined reference
    Aber genau das verstehe ich nicht. Ich fuege das cite ja per Auto-Completion ein. Das heisst ich tippe
    \cite{dev} der Cursor steht beim v ich druecke Escape und das Wort wird automatisch vervollstaendigt. (zu deviantstats)
     
  4. guy_incognito

    guy_incognito Oberdiecks Taubenapfel

    Dabei seit:
    20.09.06
    Beiträge:
    2.751
    Hast du denn "deviantstats" als Kurzform in der Bibliograhie definiert. Wenn da was anderes drin steht, könnte das Programm natürlich zicken. o_O
     
  5. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Deswegen auch der Hinweis mit Auto-Completion...der Befehl macht genau das.
    Durchsuchen des tex Dokumentes, schauen wie heisst die Bibliographie, Bibliographiedatei auslesen, nach angegebenem Key suchen und dann eben vervollstaendigen.
     
  6. guy_incognito

    guy_incognito Oberdiecks Taubenapfel

    Dabei seit:
    20.09.06
    Beiträge:
    2.751
    Hmm ... dann können es ja fast nur irgendwelche "Unverträglichkeiten" sein, da ja Tippfehler u.ä. auszuschließen sind. Sehr merkwürdig. o_O
    Ich wüsste jetzt auch nicht, wo man da ansetzen könnte. Vielleicht mal Blackbox spielen und eine Minimaldatei basteln und dann ausprobieren, wo was wie passiert. Aber igendwie ist das auch nur wahnsinnig zeitaufwendig.
     
  7. Zettt

    Zettt Doppelter Melonenapfel

    Dabei seit:
    16.10.05
    Beiträge:
    3.374
    Richtig!

    Hab aber inzwischen rausgefunden an was es liegt bin naemlich drauf gekommen mal:
    Ging relativ flott!

    Hab herausgefunden, dass da das hyperref Paket Schwierigkeiten macht.
    Aber warum? Kann mir das jemand erklaeren? Ist hyperref veraltet oder was ist da los?

    EDIT:
    Ich musste noch folgendes auskommentieren.
    \addcontentsline{toc}{section}{\bibname}
    Jetzt gehts. Zumindest kommen keine Fehlermeldungen mehr. Aber dafuer werden mir jetzt gar keine Fussnoten angezeigt :p
     

Diese Seite empfehlen