Cherry-Tastatur. Layout.

Mitglied seit
31.03.18
Beiträge
26
Guten Morgen,

ich habe ein kleines Problem mit meiner Tastatur. Sie ist locker 5-10 Jahre alt. Cherry Tastatur (RS 6000). Und ich mag sie.
Heute habe ich sie in meinen MPB 15" 2018 mit einem Originaladapter reingesteckt und musste sie neu konfigurieren.
Seitdem wenn ich auf "^" Tippe kommt "<" und umgekehrt. Bestimmt kann man das schnell irgendwo ändern. Aber habe leider nicht gefunden wo. Habt ihr eine Idee ?

Vielen Dank !
 

wavelow

Weißer Trierer Weinapfel
Mitglied seit
09.09.14
Beiträge
1.510
Seitdem wenn ich auf "^" Tippe kommt "<" und umgekehrt. Bestimmt kann man das schnell irgendwo ändern. Aber habe leider nicht gefunden wo. Habt ihr eine Idee ?
Ja eine Idee habe ich. Hatte das gestern auch grad. Ich hatte normalerweise immer "kleine" Mac Tastaturen und nun neuerdings eine "vollwertige" grosse Logitech Craft Tastatur. Und damit zunächst genau den selben Effekt wie Du.

Abhilfe war einfach: Tastaturtyp ändern.
Ich hatte auf ANSI umgestellt und die ^ und ° und < und > Zeichen waren wieder dort wo sie sein sollten. Ich hoffe, dass dies auch bei deiner guten, alten Cherry funktioniert.



 
Mitglied seit
31.03.18
Beiträge
26
Ja eine Idee habe ich. Hatte das gestern auch grad. Ich hatte normalerweise immer "kleine" Mac Tastaturen und nun neuerdings eine "vollwertige" grosse Logitech Craft Tastatur. Und damit zunächst genau den selben Effekt wie Du.

Abhilfe war einfach: Tastaturtyp ändern.
Ich hatte auf ANSI umgestellt und die ^ und ° und < und > Zeichen waren wieder dort wo sie sein sollten. Ich hoffe, dass dies auch bei deiner guten, alten Cherry funktioniert.
Hm... bei mir sieht es irgendwie anders aus. Habe diesen Button nicht...
Bildschirmfoto 2020-02-20 um 09.11.14.png
macOS 10.15.3
 

wavelow

Weißer Trierer Weinapfel
Mitglied seit
09.09.14
Beiträge
1.510
Die scheint bei dir zur Zeit gar nicht aktiv zu sein. Das sind die Einstellungen für die MacBook Tastatur.
Ich nehme an, Deine Cherry hat ein Kabel. Ich kann das also nicht nachstellen an meinem MacBook, da ich Bluetooth bzw. Funk habe an meinem Keyboard.
 

wavelow

Weißer Trierer Weinapfel
Mitglied seit
09.09.14
Beiträge
1.510
Hmm... Da müssen wir wohl warten bis noch jemand eine Idee hat. Aber es hat was mit ANSI und ISO zu tun. Da bin ich ziemlich sicher. Nur wo das nun bei Dir versteckt ist kann ich nicht sagen.
 

Marcel Bresink

Ananas Reinette
Mitglied seit
28.05.04
Beiträge
6.255
Versuche Folgendes:

1) Lösche als Administrator die Datei /Library/Preferences/com.apple.keyboardtype.plist .
2) Trenne die Tastatur und verbinde sie wieder.

Erscheint nun der Tastatur-Assistent oder der zugehörige Knopf in den Systemeinstellungen?
 
  • Like
Wertungen: Bitnacht
Mitglied seit
31.03.18
Beiträge
26
habe die externe tastatur rausgesteckt.
sudo rm /Library/Preferences/com.apple.keyboardtype.plist
externe tastatur wieder reingesteckt.
es hat sich überhaupt nix verändert.

...was habe ich wohl gelöscht :rolleyes:
 

Nogulos

Erdapfel
Mitglied seit
21.10.20
Beiträge
2
Bin ja froh dass ich nicht alleine bin.
Ich hänge immer hier:
1603296410504.png

Wenn ich dann auf die ><-Taste tippe erscheint
1603296467333.png
aber sonst geht nichts weiter...
Die Tatstatur wird weiter "identifiziert".

Es geht um die CHERRY KC 6000 SLIM FOR MAC an einem 2015 Macbook.
Kaum geschrieben...
Jetzt habe ich es mehrfach probiert um dann das hier zu posten, jetzt habe ich offenbar die Lösung:
Nach der Aufforderung nicht "<" tippen sondern "y", dann wird das ganze auf der Gegenseite abgefragt, hier kommt "-", dann kann ich das auswählen:
1603296895772.png

Funktioniert mit der Einstellung wie angegeben.

Sorry für den Doppelpost.
 

Anhänge:

Zuletzt bearbeitet:

Bitnacht

Süssreinette (Aargauer Herrenapfel)
Mitglied seit
09.06.14
Beiträge
404
In Catalina gab es meines Erachtens einen Bug bei der Behandlung von ISO und ANSI-Tastaturen. Ich habe damals eine Liste erstellt mit Tastaturen, die genau das von Dir beschriebene Problem zeigten. (Ich sammele Tastaturen und etwa 30% meiner Keyboards waren betroffen.) Ich hatte auch einen Bug-Report an Apple geschrieben, aber darüber nie Feedback bekommen. Die Umstellung zwischen ISO und ANSI konnte das Problem nicht beheben. Mit Big Sur war das Problem weg. Alle meine Tastaturen laufen wieder wie früher.

Das könnte natürlich daran liegen, dass meine uralte com.apple.keyboardtype.plist beim Umstieg auf Catalina vom Updater nicht richtig angepasst wurde und erst BigSur sie komplett neu erstellt hat. Auf die Idee war ich gar nicht gekommen.

Das Bild mit dem liegenden M kenne ich nicht. Kann es sein, dass Du ein spezielles Keyboard-Shortcut-Programm benutzt? Eventuell auch so ein Fenster-Manager mit Snap-Funktion? Es sieht jedenfalls so aus, als würde ein drittes Programm dazwischenfunken.
Ich habe das Bild mit dem liegenden M über die Bildersuche im Netz gesucht. Kein richtiger Treffer. Mysteriös!
 
Zuletzt bearbeitet:

Nogulos

Erdapfel
Mitglied seit
21.10.20
Beiträge
2
Leider kann ich zu dem "M" nichts sinnvolles beitragen, auch habe ich keine speziellen Shortcuts eingerichtet. Das ist auch mir ein Rätsel...