1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Bootloader im Überfluss

Dieses Thema im Forum "Windows auf dem Mac" wurde erstellt von erikdietz, 22.01.10.

  1. erikdietz

    erikdietz Morgenduft

    Dabei seit:
    10.05.07
    Beiträge:
    164
    Hallo liebe Apfelfreunde,

    ich habe ein Problem mit einem Triple-boot.
    Es gibt sooo viele Anleitungen und jede unterscheidet sich.
    Ich hab ein Paar gelesen und dann auf blauen Dunst angefangen.
    Fazit: läuft. irgendwie.

    Bevor ich mein Problem umständlich beschreibe, habe ich kurz ein Bild erstellt.
    Bilder sprechen bekanntlich tausend Worte :p

    Bootlaoder im Überfluss

    Die erste Ebene (rEFIt, Windows) ist das uns allen bekannte BootCamp-Bild, wenn wir beim Starten die ALT-Taste drücken.

    Drücke ich auf rEFIt, kommt natürlich: rEFIt

    Aber wie ihr seht, hab ich den Grub-Bootloader 2x drin.
    und überhaupt ist das alles doof. ich hab jetzt drei loader drinnen.
    gerne würde ich nur den bootcamp-loader nutzen.
    OSX führt zu OSX und "Windows" führt dann zu Grub und dann eben Ubuntu oder Windows.
    Mit nur refit würde ich mich auch zufrieden stellen.
    Dann hab ich nur ein fenster und alles funzt.

    Aber wie?!
    Habt ihr eine Idee?!
    Wäre SEHR dankbar...

    THX
     
  2. manromen

    manromen Riesenboiken

    Dabei seit:
    28.01.08
    Beiträge:
    289
    Wahrscheinlich hast Du den Bootloader von Ubuntu auch in die Windows Partition installiert.

    Wenn Du refit benutzt, brauchst Du die ALT Taste nicht.
    (Insofern Du refit als standard festgelegt hast.)

    Wenn Du die ALT Taste drückst findet der den Bootloader von Ubuntu und refit.

    Bei Deinem Grub würde ich einfach OS X und Windows raus löschen und Ubuntu als Standard mit 5 sek. festlegen. Dann hält das auch nicht allzuviel auf. (So habe ich das bei meinem Tripleboot)

    [Edit]
    um refit als Standard festzulegen kannst du /efi/refit/enable-always.sh ausführen.
     
  3. erikdietz

    erikdietz Morgenduft

    Dabei seit:
    10.05.07
    Beiträge:
    164
    Nein, ich hab extra die Partiton genommen, wo Ubuntu drauf ist. Nicht in die Windows-Partition.

    Ich würde refit gerne so konfigurien, dass der das handelt wie BootCamp... Er zeigt sich nur, wenn ich die ALT drücke... Sonst ist von dem nix zu sehen... ist dann dann so, wenn ich enable aktiviere?

    edit: hat leider nicht geklappt... hab die enable-always ausgeführt und ist das gleiche wie vorher...
    erst BootCamp und dann refit... :(

    weitere ideen...?
     
  4. manromen

    manromen Riesenboiken

    Dabei seit:
    28.01.08
    Beiträge:
    289
    Man kann auch irgendwie nur grub benutzen, aber da kenne ich mich nicht gut genug mit aus.
    Bei mir lädt immer direkt refit und von da lade ich direkt windows oder direkt os x (os x ist standard nach 10 sekunden wird das automatisch gebootet) oder halt Linux (grub - der dann nach 5 sekunden automatisch bootet)

    wie sieht denn die refit.conf aus ?

    [Edit]
    Hast Du BootCamp zur installation benutzt? Ich habe alles ohne BootCamp benutzt ...
     
  5. erikdietz

    erikdietz Morgenduft

    Dabei seit:
    10.05.07
    Beiträge:
    164
    imo kann man das mit "nur grub" nicht abwickeln...
    es sei denn du nutzt grub 2... da solls dann gehen...
    Musst wohl den bootloader woanders hinschreiben.

    Wie bekomm ich das denn hin, dass der refit überspringt?
    und ihn nur dann anzeigt, wenn er auch wirklich hervorgerufen wird (mittels Tastendruck)...

    Was genau willst aus meiner *.conf sehen?
     
  6. erikdietz

    erikdietz Morgenduft

    Dabei seit:
    10.05.07
    Beiträge:
    164
    Moin, ich hab jetzt das Problem, dass ich das Prozedere auf meinem anderem MBP nachmachen wollte,
    und nun hängt es hier am Starten von Windows. Linux und OSX gehen.
    Aber Windows sagt mir, ich solle es mittels der DVD reparieren. Hab das probiert und Windows sagt es sei dazu nicht in der Lage.

    Wie kann ich das Problem jetzt beheben?
    Ich könnte euch das funktionierende MBP anbieten, um sachen zu vergleichen.
    Aber die grub.conf ist zB identisch.
    Hat noch jmd Lösungen? Ich verzweifle... Seit Stunden lese ich im Netz und suche nach Lösungen...

    [edit]: Wenn ich jetzt in OSX das Festplattendienstprogramm öffne, ist Windows grau hinterlegt.
    Unten steht"Mount-Point: Nicht aktiviert"... Ein "Aktivieren" bringt nichts...
     
    #6 erikdietz, 24.01.10
    Zuletzt bearbeitet: 24.01.10

Diese Seite empfehlen