1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Bootcamp-Partition retten?

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Horni, 06.09.09.

  1. Horni

    Horni Granny Smith

    Dabei seit:
    02.01.09
    Beiträge:
    12
    Hallo,

    ich habe dummerweise das neue Snow-Leopard clean (OSX-Partition zuvor komplett gelöscht) installiert, jedoch die Bootcamp-Partition nicht wirklich gesichert. Nun kann ich leider mein Windows nicht mehr starten obwohl die Partition noch vorhanden ist.
    Der Bootcamp-Assistent lässt sich leider auch nicht durchführen sondern meldet:
    Ich denk mal dass der Fehler irgendwo in der Partitionstabelle liegt.
    Wäre super wenn mir da jemand weiterhelfen könnte.

    Schöne Grüße
     
  2. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Lässt sich das Windows noch mit gedrückter Wahltaste starten?
     
  3. Horni

    Horni Granny Smith

    Dabei seit:
    02.01.09
    Beiträge:
    12
    Nein, leider nicht mehr.
     
  4. afri

    afri Maren Nissen

    Dabei seit:
    01.09.07
    Beiträge:
    2.319
    Und was sagt das Festplattendienstprogramm, wieviel/welche Partitionen sind vorhanden?
    Gruß
    Andreas
     
  5. Monti

    Monti Lambertine

    Dabei seit:
    30.10.07
    Beiträge:
    691
    Wenn du wirklich verzweifelt bist, du obendrein noch Langeweile und eine hinreichend große Festplatte hast, kannst du folgendes Versuchen:

    1) alle Dateien der Windows Partition in einem Archiv sichern
    2) mit dem Festplattendienstprogramm die Windows Partition löschen und die Mac Partition vergrössern
    3) mit dem Bootcamp Assistenten eine Windows Partition erstellen
    4) Windows installieren
    5) OSX booten und alle Dateien aus dem Archiv auf die Windows Platte ballern
    6) hoffen - denn das kommt mir gerade nur so in den Sinn, probiert habe ich das noch nicht ;)

    Gruß,

    Monti
     
  6. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.832
    So wie ich das verstanden habe, ist bereits hier das Problem.
     
  7. ElFloerno

    ElFloerno Carola

    Dabei seit:
    13.03.07
    Beiträge:
    112
    Habe das gleiche Problem!
    Hab schon diverse Recovery-Tools unter OS X probiert, leider finden die meine Windows-Daten nicht.
    Hab bisher StellarPhoenix und Data Rescue II ausprobiert...

    Gruß ElFloerno
     
  8. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Dann lass mal den Output von folgendem Kommando sehen (Kennwort bitte):
    Code:
    [SIZE="-1"]sudo bash -c "gpt -r show /dev/disk0; fdisk /dev/disk0;"[/SIZE]
     
  9. Horni

    Horni Granny Smith

    Dabei seit:
    02.01.09
    Beiträge:
    12
    start size index contents
    0 1 PMBR
    1 1 Pri GPT header
    2 32 Pri GPT table
    34 6
    40 409600 1 GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
    409640 278396928 2 GPT part - 48465300-0000-11AA-AA11-00306543ECAC
    278806568 262144
    279068712 31753480 3 GPT part - 48465300-0000-11AA-AA11-00306543ECAC
    310822192 1759583
    312581775 32 Sec GPT table
    312581807 1 Sec GPT header
    Disk: /dev/disk0 geometry: 19457/255/63 [312581808 sectors]
    Signature: 0xAA55
    Starting Ending
    #: id cyl hd sec - cyl hd sec [ start - size]
    ------------------------------------------------------------------------
    1: EE 1023 254 63 - 1023 254 63 [ 1 - 312581807] <Unknown ID>
    2: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
    3: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
    4: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
     
  10. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    So war das zu erwarten. Das sieht mehr als beschädigt aus.
    Ich kann dir nicht versprechen dass deine Daten noch da sind, weil ich nicht wissen kann ob die Zahlenangaben immer noch die sind, die vorher vorhanden waren. Ich kann nur das übernehmen, was dort jetzt steht.
    (Ich weiss auch nicht ob du dein Windows irrtümlicherweise als Mac-Volume formatiert und damit unwiederbringlich zerstört hast. Die Daten lassen das leider erahnen.)

    Du bootest jetzt zunächst von der System-DVD.
    Dort öffnest du das Festpl-DiProg und markierst die interne HD. Lass dir die Informationen dazu anzeigen. Gleich in der ersten Zeile unter "Medien-Identifikation" sollte zu lesen sein: disk0
    Falls bei dir das mit einer anderen Ziffer enden sollte, musst du das in der folgenden Terminaleingabe entsprechend anpassen.
    Den im Terminal-Text mit rot hervorgehobenen Teil musst du ebenfalls anpassen (diese Info habe ich nicht). Falls du hier nicht sicher bist, frage nochmal nach bevor du was falsches wählst. (Man kann das rausfinden. Ist nur zu umständlich das hier zu erwähnen. Ich setze voraus dass du es weisst.)

    FP-DP schliessen, Terminal öffnen.
    Auf deutsche Tastenbelegung umschalten macht immer schön:
    Das Pipe-Symbol "|" ist da auf <Wahl-7>
    Die Schweifklammern "{ }" auf <Wahl-8> und <Wahl-9>

    Code:
    [SIZE="-1"][I][COLOR="DimGray"]# Etwas Vorbereitung...[/COLOR][/I]
    hd=/dev/[COLOR="Blue"]disk0[/COLOR]
    alias eject="diskutil unmountDisk $hd"
    
    [I][COLOR="DarkRed"]# Hier musst du [U]eines von beiden[/U] auswählen:
    # Falls Windows auf einer NTFS-Partition installiert war:[/COLOR] [/I]
    p=7
    [I][COLOR="DarkRed"]# Falls Win auf einer FAT32-Partition lag:[/COLOR][/I]
    p=C
    
    eject
    [I][COLOR="DimGray"]# hierzu muss jedesmal "success"
    # berichtet werden vor dem fortfahren,
    # ggf. das 'eject' mehrfach wiederholen
    # (es kommt vor dass es etwas "hakt")[/COLOR][/I]
    
    gpt remove -i 3 $hd
    eject
    gpt add -i 3 -t windows -b 279068712 -s 31753480 $hd
    eject
    gpt label -i 3 -l "Boot Camp / Windows" $hd
    eject
    
    [I][COLOR="DimGray"]# Bei diesen Zeilen hier ändert sich
    # vorübergehend das Eingabeprompt in ein ">"
    # Das ist völlig normal und so beabsichtigt.
    # Achte darauf dass diese Anführungszeichen hier
    # *[U]nicht[/U]* falsch gesetzt sind, das [U]muss[/U] so sein. [/COLOR][/I]
    
    echo "1,409639,0xEE,-,1023,254,63,1023,254,63
    409640,278396928,0xAF,-,1023,254,63,1023,254,63
    279068712,31753480,0x0${p},*,1023,254,63,1023,254,63
    0,0,0x00,-,0,0,0,0,0,0"  |  fdisk -rye $hd
    
    [I][COLOR="DimGray"]# That's it. Terminal beenden.
    # Windows sollte sich jetzt mit gedrückter Wahltaste
    # wieder wie gewohnt starten lassen. 
    # Dann bootest du nochmals mit gedrückter Wahltaste,
    # aber diesmal mit OS X als Zielvolume.
    # Dort stellst du dann das Startvolume neu ein
    # und alles sollte wieder passen. 
     [/COLOR][/I]
    [/SIZE]
     
    #10 Rastafari, 08.09.09
    Zuletzt bearbeitet: 08.09.09
  11. Horni

    Horni Granny Smith

    Dabei seit:
    02.01.09
    Beiträge:
    12
    Hi,
    sorry dass ich mich solange nicht gemeldet habe (hatte meine SL-CD nicht bei mir).

    Ich habe jetzt mal alle Schritte ausgeführt, allerdings gibt er mir beim letzten Schritt einen Fehler aus:

    -bash-3.2# eject
    Unmount of all volumes on disk0 was successful
    -bash-3.2# echo "1,409639,0xEE,-,1023,254,63,1023,254,63
    409640,278396928,0xAF,-,1023,254,63,1023,254,63
    279068712,31753480,0x0${p},*,1023,254,63,1023,254,63
    0,0,0x00,-,0,0,0,0,0,0" | fdisk -rye $hd
    fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory
    Enter 'help' for information
    fdisk: 1> fdisk: eof
    -bash-3.2#

    Bei der Formatierung der Festplatte für SL bin ich mir sicher die Windows-Partition nicht angerührt zu haben.
    Ich hoffe es gibt noch irgendwelche Tricks.

    Vielen Dank und schöne Grüße.
     
  12. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Kein Fehler, nur ein Hinweis. Die Aktion sollte trotzdem korrekt ausgeführt worden sein.
    Wiederhole danach einfach mal die Abfrage aus dem Post vorher um zu sehen was sich geändert hat.
     
  13. Horni

    Horni Granny Smith

    Dabei seit:
    02.01.09
    Beiträge:
    12
    gpt show: /dev/disk0: Suspicious MBR at sector 0
    start size index contents
    0 1 MBR
    1 1 Pri GPT header
    2 32 Pri GPT table
    34 6
    40 409600 1 GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
    409640 278396928 2 GPT part - 48465300-0000-11AA-AA11-00306543ECAC
    278806568 262144
    279068712 31753480 3 GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
    310822192 1759583
    312581775 32 Sec GPT table
    312581807 1 Sec GPT header
    Disk: /dev/disk0 geometry: 19457/255/63 [312581808 sectors]
    Signature: 0xAA55
    Starting Ending
    #: id cyl hd sec - cyl hd sec [ start - size]
    ------------------------------------------------------------------------
    1: EE 0 0 2 - 1023 254 63 [ 1 - 409639] <Unknown ID>
    2: AF 1023 254 63 - 1023 254 63 [ 409640 - 278396928] HFS+
    *3: 07 1023 254 63 - 1023 254 63 [ 279068712 - 31753480] HPFS/QNX/AUX
    4: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
     

Diese Seite empfehlen