1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Bilder auf Sever werden nach Serverwechsel nicht mehr gefunden

Dieses Thema im Forum "Fotosoftware" wurde erstellt von cosmic, 04.11.09.

  1. cosmic

    cosmic Zwiebelapfel

    Dabei seit:
    29.12.05
    Beiträge:
    1.281
    Hallo zusammen,

    ich habe eine Problemchen mit iPhoto.
    Da ich an mehrerer Rechner arbeite, habe ich meine Fotos auf einer Freigabe eines Server abgelegt und in iPhoto eingestellt, dass die Bilder nicht in die Mediathek kopiert werden. Das klappte bis vor wenigen Stunden ziemlich gut.

    Jetzt habe ich keinen Windows Server mehr, sondern einen mini zum Server gemacht. Die Freigaben heißen genauso wie vorher auch. Wenn ich iPhoto öffne, werden die Vorschaubilder alle angezeigt. klicke ich auf eines dieser Thumbnails, wurde bisher immer das Bild vergößert angezeigt. Jetzt dreht sich der bunte Ball und nach einer Weile kommt die Meldung, dass der Server "home4me" nicht verfügbar ist. Der neue Server heißt - da er zuerst parallel laufen musste - natürlich nicht so.

    Jetzt die Preisfrage:
    Wo ist der alte Servername "verdrahtet"? Ich hatte immer gedacht, iPhoto arbeitet direkt über die Freigaben.
     
  2. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Klar arbeitet iPhoto über die Feigaben, aber eine Freigabe setzt sich auch immer aus dem Servernamen und den Freigabennamen zusammen.
     
  3. Samir2602

    Samir2602 Fießers Erstling

    Dabei seit:
    12.03.09
    Beiträge:
    127
    Nur mal so aus Interesse. Du hast einen Server auf dem die Fotos sind! Auf deinem Client hast du eine iPhoto-Bib., welche die Bilder von dem Server beinhalten!
    Hab ich das richtig verstanden??
    Weil wenn das so ist, würde ich das vielleicht ändern: Du packst die Bib. auf den Server und wählst halt am Cient diese Bib. aus. So hast du z.b. alle Kommentare, Faces, Tags und so, die du machst auf allen Rechnern die du mit der Bib. verknüpfst. Da diese Infos ja mit auf dem Server liegen. Hast du hingegen nur die Fotos da und die eigentliche Bib, welche nur verknüpfungen zu den eigentlichen Fotos beinhaltet, auf den Client musst du die angaben an jedem Rechner machen.
     
  4. cosmic

    cosmic Zwiebelapfel

    Dabei seit:
    29.12.05
    Beiträge:
    1.281
    @drlecter
    OK das ist schon klar, nur kommt z.B. iTunes damit zurecht. Da mache ich das genauso.
    Die Frage ist eben, an welcher Stelle sich iPhote (im Gegensatz zur iTunes) den Servernamen merkt.

    @Samir2602
    Ne, ne. Dieses konstukt ist nicht aus versehen so, sondern mit Purer Absicht. Ich komme auch damit total gut zurecht. Auf diese Weise kann hier jeder im Haus seine Bildersammlung haben, ohne immer die kompletten Daten auf der lokalen Festplatte zu sammeln.
    Ich spiele auf dem Server immer die neuen Bilder in nach Ereignissen sortiert in einen Ordner und wenn man möchte zieht man sich die Daten ins iPhoto.
    Jeder die Bilder die er möchte.

    Als "Workaround" habe ich jetzt im DNS den alten Servernamen als Alias an den neuen Server gehängt. Das ist nicht so toll aber funktioniert.

    Schöner wäre es aber wenn man es richtig ändern könnte.

    Gruß
    Klaus
     
  5. cosmic

    cosmic Zwiebelapfel

    Dabei seit:
    29.12.05
    Beiträge:
    1.281
    Kann ich solche Details eigentlich auch beim Apple Support erfahren. Greift da ggf. mein noch gültiger Apple Care Protection Plan" ?
     
  6. cosmic

    cosmic Zwiebelapfel

    Dabei seit:
    29.12.05
    Beiträge:
    1.281
    ... es ist wohl so, dass bei meiner Vorgehensweise (Bilder werden nicht in die Mediathek kopiert) für jedes Bild ein Link erzeugt wird. Das heiß, dass bei mir aktuell einige hundert Files "falsch" verlinkt sind.

    Jetzt zur Preisfrage:
    Wie kann ich diese Links wieder "reparieren" ohne jeden einzeln anfassen zu müssen?

    Gruß
    Klaus
     
  7. .holger

    .holger Geflammter Kardinal

    Dabei seit:
    13.09.04
    Beiträge:
    9.117
    In der iPhoto Library (ctrl-Klick - Paketinhalt anzeigen) liegt eine "AlbumData.xml". Öffne die mal mit einem Texteditor.

    Für jedes Foto sollte da ein Satz an Daten drin sein

    So in etwa
    Code:
    <key>1008</key>
    <dict>
    <key>MediaType</key>
    <string>Image</string>
    <key>Caption</key>
    <string>IMG_2221</string>
    <key>Comment</key>
    <string></string>
    <key>GUID</key>
    <string>A189C751-CC73-4390-A379-0A675197D8BF</string>
    <key>Aspect Ratio</key>
    <real>1.500000</real>
    <key>Rating</key>
    <integer>0</integer>
    <key>Roll</key>
    <integer>889</integer>
    <key>DateAsTimerInterval</key>
    <real>204932170.000000</real>
    <key>ModDateAsTimerInterval</key>
    <real>204944889.000000</real>
    <key>MetaModDateAsTimerInterval</key>
    <real>0.000000</real>
    <key>ImagePath</key>
    <string>/Users/holgerkrupp/Pictures/iPhoto Library/Originals/2007/2007 06 30 Torfkahnralley/IMG_2221.JPG</string>
    <key>ThumbPath</key>
    <string>/Users/holgerkrupp/Pictures/iPhoto Library/Data/2007/2007 06 30 Torfkahnralley/IMG_2221.jpg</string>
    <key>ImageType</key><string>JPEG</string>
    </dict>
    
    Da steht auch der Pfad zur Datei drin:

    <key>ImagePath</key>
    <string>/Users/holgerkrupp/Pictures/iPhoto Library/Originals/2007/2007 06 30 Torfkahnralley/IMG_2221.JPG</string>

    Steht da bei dir der alte Servername mit Drin?
    Wenn ja, versuch mal (über den Texteditor mit Suchen & Ersetzen)

    "<string>ALTERSERVERNAME"
    durch
    "<string>NEUERSERVERNAME"
    zu ersetzen.

    VORHER EINE SICHERHEITSKOPIE DER DATEI MACHEN!
     

Diese Seite empfehlen