1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Autostart von CD/Audiodatei beim hinzufügen abschalten

Dieses Thema im Forum "iTunes (Mac only!)" wurde erstellt von scharti, 17.11.09.

  1. scharti

    scharti Alkmene

    Dabei seit:
    14.09.09
    Beiträge:
    30
    Hallo liebe ATler,
    ich hab schon die Sufu benutzt aber leider konnte ich nichts brauchbares finden...
    ich will nicht das automatisch eine CD/Audiodatei anläuft sobald ich sie neu in itunes hinzufüge, leider passiert das auch wenn schon ein track läuft. Deswegen möchte ich den Autostart deaktivieren...

    könnt Ihr mir verraten wie das geht? thx;)
     
  2. Guy.brush

    Guy.brush Weißer Winterkalvill

    Dabei seit:
    15.12.08
    Beiträge:
    3.544
    Du kannst in den iTunes Einstellungen unter Allgemein einstellen, was passieren soll, wenn du ne CD reinschiebst.
    Wie man das mit hinzugefügten Dateien macht, weiß ich leider nicht. So weit ich mich erinnern kann, tritt dieser Effekt bei mir nur bei Filmen/Fersehsendungen auf, evtl. weiß jemand anders mehr...
     
  3. scharti

    scharti Alkmene

    Dabei seit:
    14.09.09
    Beiträge:
    30
    Okay, das mit der CD kann man bestimmen, aber zu den datein konnte ich nichts finden...:oops:
     
  4. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.901
    Du meinst die Wiedergabe während der Konvertierung?
    iTunes beenden, Terminal starten:
    Code:
    [SIZE="-2"]defaults write com.apple.iTunes play-songs-while-importing -bool NO;[/SIZE]
     
  5. scharti

    scharti Alkmene

    Dabei seit:
    14.09.09
    Beiträge:
    30
    Hey,
    ja genau das ist exakt was ich such, jedoch erzielt der code keine Wirkung.
    Habe den Code im Terminal eingefügt, danach kam die normal Startzeile.
    Allerdings hat es kein effekt gehabt, bei Audiodateien.

    Code:
    Last login: Thu Nov 19 16:55:48 on ttys000
    noname:~ scharti$ defaults write com.apple.iTunes play-songs-while-importing -bool NO;
    noname:~ scharti$ 
    
    Danke
     
  6. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.901
    Ich wiederhole: iTunes beenden...
     
  7. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.401
    Habe zwar keine CD zur Hand, aber beim Importieren von mp3s von der Festplatte funktioniert es nicht.
    Mehrfach getestet mit jeweiligem iTunes-Neustart.
    Kann's an der Version liegen? iTunes 8.2.1 unter OS X 10.5.8
     
  8. scharti

    scharti Alkmene

    Dabei seit:
    14.09.09
    Beiträge:
    30
    Danke:)
    ich hab die itunes 9.02 und es funktioniert auch leider nicht, OSX 10.5.8
     
  9. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.901
    Nein, das kann eigentlich nur an zusätzlicher Software liegen.
    Eine direkt in iTunes integrierte Funktion zum automatischen Abspielen importierter Titel gibts nämlich gar nicht, das geht nur bei Import von Audio-CD.
    Ich würde mich also mal umsehen, welches Plugin/Zusatzprogramm/Skript/Widget/Helferchen/Kokolores die Wiedergabe von *ausserhalb* anwirft.
     
  10. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.401
    Ich will's nicht beschwören, aber eigentlich habe ich da nichts installiert bzw. vor einigen Monaten sämtliche Skripte, Plugins etc. gelöscht, weil iTunes anfing, des öfteren abzustürzen. Und iTunes-nahe Zusatzprogramme habe ich nicht am Laufen.
    Da werde ich wohl am nächsten langweiligen Abend eine sinnvolle Beschäftigung finden.
    Allerdings steht auf der Webseite von secrets, wo viele derartige write-default-Befehle aufgelistet sind, explizit "iTunes (8.0) bei diesem dabei, das gab mir dann zu denken.
    Früher konnte man das übrigens für CDs bei den Einstellungen abstellen.
     
  11. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.901
    Das ist genau der oben beschriebene Befehl. Es gibt nur lediglich keine Checkbox mehr dafür.
     
  12. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.401
    Das hab ich ja auch nicht bestritten - ist allerdings für uns Ottonormalverbraucher ein Anwendungsunterschied. Das eine findet man in den Einstellungen (sofern man da reinschaut, was wohl, wenn man diverse Threads anschaut, nur eine Minderheit macht), für das andere muß man den konkreten Befehl kennen - und außerdem den weitverbreiteten Horror vor dem Terminal überwinden.

    Ich habe übrigens mittlerweile festgestellt, daß das Abspielen nach dem mp3-Import bei mir auch unter einem anderen Benutzer auftritt, und daß laut Aktivitätsanzeige da keinerlei Prozesse auftauchen, die ich mit meinem maximal Halbwissen auch nur in die Nähe von iTunes bringe. Von mir selbst gestartete verdächtige Programme laufen sowieso nicht. (Und ich weiß war nicht, ab wann das Phänomen auftrat, bin mir aber sicher, daß es mir aufgefallen wäre wen es mal so gewesen wäre, und mal nicht, je nachdem welches Programm nebenher aktiv war.)
    In früheren Jahren habe ich immer wieder Plugins, Skripte, Zusatzprogramme ausprobiert, weil mir an iTunes das eine oder andere fehlte, aber wenn ich die nicht starte, können sie doch eigentlich nichts bewirken. Ich bezweifle irgendwie, daß da was dabei war, was iTunes patcht, und das über mehrere Updates hinweg.
    Ist ja eigentlich nichts Wichtiges, daß nach dem Import das neueste Lied gespielt wird, zumal ich eigentlich ziemlich selten irgendwas herunterlade (und ich glaube, kann's aber nicht beschwören, daß beim Einkauf im iTunes Store die Titel nicht abgespielt werden) und importiere (außer Podcasts, da passiert aber nichts), so gesehen stört es mich nicht.
    Andererseits reizt mich das Problem an sich, vielleicht lässt sich ja mein Viertelwissen auf ein 27%iges anheben.
     

Diese Seite empfehlen