1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Automator Probleme

Dieses Thema im Forum "macOS & OS X" wurde erstellt von hilikus, 30.10.06.

  1. hilikus

    hilikus Bismarckapfel

    Dabei seit:
    19.09.06
    Beiträge:
    77
    Hallo,

    ich habe hier ein kleines Problem mit dem Automator. Und Zwar hab ich mir damit ein Programm erstellt, das meine Netzlaufwerke mappt und dann das Wecker Skript eingebunden, damit ich nurnoch einen Eintrag in iCal verwalten muss.
    Nun, wenn ich das Programm dann manuell starte, tut es genau das, was es soll: Netzlaufwerke werden gemappt, Lautstärke hoch gesetzt, iTunes gestartet und die Playlist Wecker wird gespielt.
    Lasse ich das ganze jedoch zu einem festen Zeitpunkt von iCal ausführen, hört er nach dem mappen der Laufwerke einfach auf.
    Hat jemand vll ne Idee?

    Gruß
    Hilikus
     
  2. schlingel

    schlingel Melrose

    Dabei seit:
    06.06.04
    Beiträge:
    2.483
    Werden denn alle Laufwerke korrekt gemappt?
     
  3. lengsel

    lengsel Carola

    Dabei seit:
    11.08.05
    Beiträge:
    112
    Ich kenne Automator nicht gut genug um spezifisch darauf antworten zu können, stelle mir aber gerade die gleiche Abfolge von Befehlen in Applescript vor.
    Hier würde ich vermuten dass das Mounten der Laufwerke noch nicht abgeschlossen ist wenn bereits der Befehl zum Start von iTunes gegeben wird. Ergebnis: iTunes stirbt still und leise vor sich hin. Abhilfe: Wartezeit einbauen.
    In AS sähe dass dann z.B. so aus:

    Code:
    delay x
    tell application "blablabla"
    activate
    end tell
    
    x ist die Zeit in Sekunden

    Grüße,
    Flo
     
  4. hilikus

    hilikus Bismarckapfel

    Dabei seit:
    19.09.06
    Beiträge:
    77
    hi nochmal,

    also ja, es werden alle laufwerke korrekt gemappt.
    das seltsame ist ja, dass, wenn ich die datei manuell ausführe (also einfach nen doppelklick druff), es immer geht.
    Wenn ich aber von iCal starten lasse, grundsätzlich iTunes gestartet wird, aber dann abgebrochen wird, ohne irgendein Kommentar oder so
     
  5. hilikus

    hilikus Bismarckapfel

    Dabei seit:
    19.09.06
    Beiträge:
    77
    ah oh wie peinlich, vergesst es.
    hatte nur das automator skript für die netzlaufwerke, ohne iTunes drin.
    jesses, wie peinlich^^
     

Diese Seite empfehlen