1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Automatisches Anmelden geht nicht mehr, obwohl aktiviert

Dieses Thema im Forum "macOS & OS X" wurde erstellt von fanta, 08.07.07.

  1. fanta

    fanta Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    07.11.06
    Beiträge:
    252
    Aus unerklärlichen Gründen, kann ich den Automatischen Login bei 10.4.9 nicht mehr nutzen.

    Es ist unter den Benutzereinstellungen aktiviert, und ich bin laut Systemeinstellungen > Benutzer auch der einzige User auf dem System.

    Allerdings bekomme ich dennoch beim Hochfahren das Loginfenster angezeigt. Dort findet sich dann oben mein Benutzer samt photo und darunter der Punkt "Others..." wo ich nach Klick einen beliebigen Usernamen plus Passwort eingeben könnte.
     
  2. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    ich würde mal "die üblichen verdächtigen laufen lassen....
    (siehe sig.)

    HTH
    mike
     
  3. Dr.Apfelkern

    Dr.Apfelkern Jerseymac

    Dabei seit:
    18.04.07
    Beiträge:
    454
    Die Benutzereinstellungen sind nicht mehr ausschlaggebend, da du Systemeinstellungen > Sicherheit > "Automatisches Anmelden auf allen Accounts deaktivieren" markiert hast.
     
    Flugapfel gefällt das.
  4. DBertelsbeck

    DBertelsbeck Tiefenblüte

    Dabei seit:
    20.04.04
    Beiträge:
    6.425
    Du hast den "root" aktiviert.
     
  5. fanta

    fanta Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    07.11.06
    Beiträge:
    252
    Hier herrscht ja ein militärischer befehlston, du hast, du hast...
    Also..
    QuickMik, die sachen hab ich schon durch, alles was nach Startup oder Login aussieht, scheint korrekt eingestellt zu sein.
    Grubenunglück, Automatisches Anmelden ist nicht deaktiviert, kein Haken vor...
    DBertelsbeck, wo find ich das raus, oder wie mach ichs rückgängig?

    Was vorausgegangen ist, ist dass ich versehentlich den Beutzer umbenannt hab (Home Ordner) und dann hin und her fummeln musste um es gerade zu biegen. Irgendwann um den dreh hat das ganze angefangen....
     
  6. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Root kann man nicht versehentlich aktivieren.

    Ach der Befehlston von DBertelsbeck war doch nur ein Aufgreifen des Beitrags vorher… ;)
    Aber gut, dass Du mit weiteren Infos rausrückst.
    Schau dir mal die /Library/Preferences/com.apple.loginwindow.plist an … da könnte jetzt ein falscher Benutzername auftauchen.
    Oder ziehe sie einfach mal auf den Desktop und danach ein Neustart.

    Gruss
     
  7. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    na bravo....warum sagst du das nicht gleich.
    dann hätten wir uns die antworten sparen können
     
    #7 QuickMik, 09.07.07
    Zuletzt bearbeitet: 09.07.07
  8. fanta

    fanta Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    07.11.06
    Beiträge:
    252
    Heh, sorry :)
    Seid ihr mir jetzt böse und wollt nich mehr helfen? :)

    Hier der Inhalt der com.apple.loginwindow.plist, ist zwar etwas durcheinander, sorry :)

    bplist00Ý \lastUserName]autoLoginUserXlastUser^HideLocalUsers_IncludeNetworkUser_PowerOffDisabled_autoLoginUserUIDUKiosk_RetriesUntilHint]AdminHostInfo\SHOWFULLNAME_MasterPasswordHint^HideAdminUsersUMirzaXloggedInUfalseõXHostNameSfut#0>GVk~‘—ª¸ÅÚéïøþÿ ​


    Ich probiers mal damit, die Login Datei aufn desktop zu ziehen, damit er eine neue erstellt
     
  9. cybo

    cybo Aargauer Weinapfel

    Dabei seit:
    23.05.06
    Beiträge:
    753
    Manche lernen es nie... :mad:

    Hier und hier gibt es Abhilfe. Aber genau lesen, was dort steht !
    Ansonsten: Suchfunktion bei AT nutzen...

    Gruß
    cybo
     
  10. fanta

    fanta Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    07.11.06
    Beiträge:
    252
    Nein, nein Freunde.. Keine Panik!
    Die Benutzer-Homefolder Geschichte ist schon gegessen.. Ich habe letztendlich, weil ich Angst hatte, es zu verbocken, dieses o.g. Tool benutzt, und alles wieder hingebogen... Nachdem ich aber das erste mal den Folder umbenannt hatte, wollte sich mein OSX wieder komplett neu konfigurieren (Registrierung, Länderangabe etc.) Seitdem ist das ganze mit dem Login.. Aber wie gesagt, die Namengeschichte ist wieder OK, es existiert nur noch ein Benutzer und nur ein Homeverzeichnis...
     
  11. DBertelsbeck

    DBertelsbeck Tiefenblüte

    Dabei seit:
    20.04.04
    Beiträge:
    6.425
    Ich habe, genau so wenig wie mein Vorredner, nicht mal einen Imperativ benutzt und Du redest von "Befehlston".
    Hätte ich geschrieben: "Aktiviere den root" vielleicht noch mit dem Zusatz "Marsch, Marsch", gäbe ich Dir Recht. Man will helfen und wird angepi...., seltsam.
    Ich kann Deine Vorkenntnisse auf Grund der ungenügenden Angaben nicht einschätzen, inzwischen aber schon. ;), und weise auf eine Möglichkeit hin, von der ich annahm, dass Du sie verstehst. Entschuldige bitte, dass ich Dich überschätzt habe.
    War das jetzt unmilitärisch genug?

    Trotzdem bleibe ich dabei, dass mit Deinen Usern, ja bewusst den Plural benutzend, was nicht stimmt, sonst käme im Anmeldedialog, ob gewollt oder nicht spielt dafür keine Rolle, nicht der "Benutzer" other.
    Dies ist in der Regel ein Hinweis auf aktivierten "root" oder Zugriff auf ein Netzwerk.
    Ob jiggamirk root "versehentlich" aktiviert hat, halte ich zwar auch für relativ ausgeschlossen, aber was ist mit "bewusst"?
    So hat er doch sein Homeverzeichnis wieder, (wie er meint, endgültig o_O), repariert.
    Und das ohne "root"?

    Ich jedenfalls hätte ein ungutes Gefühl nach dem Umbennen des Homeverzeichnisses.

    Zu Deiner an mich gerichteten Frage:
    Starte netinfo Manager und schau ins Menü Sicherheit.
    Oh, Entschuldigung, ich wurde militärisch und das mit einem Imperativ, vergiss also bitte die Antwort auf Deine Frage. :)
     
  12. Flugapfel

    Flugapfel Querina

    Dabei seit:
    10.03.06
    Beiträge:
    183
    Mein Held !!! :):):):):):):):):)

    War bei mir zwar nicht deaktiviert, aber dafür in der Benutzereinstellung. Wie schön, das mein Mac jetzt wieder ohne Zwischenstopp hochrauscht.

    Danke und Gruß, Flugapfel
     
  13. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    "Hide" ist für das "Other" verantwortlich.
    Leider hast Du nicht mehr geschrieben, ob Du meinen Tipp befolgt hast … und ob es geholfen hat :(

    Gruss
     
  14. fanta

    fanta Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    07.11.06
    Beiträge:
    252
    DBertelsbeck: das war doch absolut nicht böse gemeint. Ich bin keiner der Menschen, die sich in einem Forum, in dem Sie nach Hilfe fragen, über jemanden beschwert oder rum meckert. Das war absolut als spaß gemeint, space scheint ihn wohl verstanden zu haben. Sorry wenn es falsch rübergekommen ist.

    Meine PC Kenntnisse sind zwar sehr gut, von Mac habe ich allerdings nicht so die Ahnung, hab den hier erst seit 3 Wochen... Man macht halt mal Fehler und lernt draus... Das kann man mir auch nicht "manche lernen es nie" vorwerfen, das find ich an dieser Stelle nicht angebracht...

    @space: ich bin gestern nicht mehr zu einem reboot gekommen, ich mach das gleich mal und schreibe dann das ergebnis...

    @DBertelsbeck: im Netinfo manager finde ich im menüpunkt Sicherheit (nach Identifikation mit meinem Usernamen und Password) den Menüpuntk "root deaktivieren"... Ist es das vll.?

    Noch eine allgemeine Frage? Wie zitiert man von mehreren Usern, sie wie DBertelsbeck es zu beginn der zweiten Threadseite gemacht hat?


    EDIT: Das verschieben der PLIST Datei hat keinen erfolg gebracht, er hat nach dem reboot eine neue erstellt mit folgendem inhalt:

    bplist00ÒXlastUser\lastUserNameXloggedInUMirza #,2
     
    #14 fanta, 10.07.07
    Zuletzt bearbeitet: 10.07.07
  15. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Ok, ich hätte DBertelsbecks Beitrag besser lesen sollen … das System ohne root zu reparieren ist sehr umständlich und tatsächlich: Du hast root aktiviert…

    Ja: deaktivieren (Solltest Du eh aus "Sicherheitsgründen" tun!)

    Gruss
     
  16. fanta

    fanta Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    07.11.06
    Beiträge:
    252
    Schade, es klappt immernoch nicht. Den root habe ich daktiviert, der Menüpunkt lautet jetzt dementsprechend "root aktivieren". Die PLIST habe ich auch wieder gelöscht und nach mehrmaligem Neustart klappt es immernoch nicht. Autmatoschen Login für meinen User habe ich eingeschaltet (und zwischendurch auch aus und wieder eingeschaltet".... Komisch...
     
  17. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Hmm ja … dann muss man die Plist ändern … da Du sie wohl mit TextEdit geöffnet hattest, gehe ich davon aus, dass Du keine "besseren" Programme an Bord hast.

    Man könnte sie mit Hilfe des Terminals leicht ändern, doch der entsprechende Befehl sollte natürlich stimmen. Ich bleibe dabei: das "Hide…" ist für das Others zuständig.
    Und bei autologinuser sollte dein name stehen und bei autologinuserUID 501…
    Doch aus dem kryptischen TextEdit-Text kann ich nichts rauslesen.
    Gut wäre also ein anderes Programm… Du hast Tiger… Ist der Omni Outliner installiert? Damit kannst Du die Plist mal öffnen und einen Screenshot erstellen, den Du hier hochladen kannst.
    Besser noch die Demo von BBEdit laden oder den TextWrangler und es damit öffnen und den Inhalt hier posten

    Gruss
     
  18. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Edit:
    Du kannst noch was versuchen (so könnte es gehen)

    /Library/Preferences/com.apple.loginwindow.plist
    UND
    /Users/Dein Name/Library/Preferences/com.apple.loginwindow.plist
    löschen

    Gruss
     
  19. fanta

    fanta Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    07.11.06
    Beiträge:
    252
  20. space

    space Neuer Berner Rosenapfel

    Dabei seit:
    02.12.05
    Beiträge:
    1.950
    Ahh! So sieht es schön aus … und soweit auch ok. Die root Einträge sind weg.
    Mir ist noch eingefallen, dass Du die Plist auch mit dem Terminal hättest darstellen können, aber so ist es am besten

    Interessant ist, ich habe noch (neben einigen selbst hinzugefügten Einträgen)
    RetriesUntilHint • Number • 3
    MCXLaunchOnLogout • Boolean • Yes


    Ersteres ist klar … die Bedeutung des zweiten ist mir - hüstel - unbekannt :eek:

    Hast Du auch mal die com.apple.loginwindow.plist in deiner User-Library gelöscht?

    Gruss
     

Diese Seite empfehlen