1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Aspell unter Texclipse einrichten

Dieses Thema im Forum "LaTeX" wurde erstellt von Steglich, 16.01.10.

  1. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    Nun probiere ich schon seit einigen Tagen daran herum und habe auch im Forum und sonst nirgend einen entsprechenden Hinweis gefunden.

    Mein Problem: Ich möchte gerne unter Texclipse (Plugin zu Eclipse) eine Rechtschreibung benutzen. Hier soll es die Möglichkeit geben Aspell einzubinden. Das entsprechende Einstellungsfenster habe ich in Texclipse gefunden, Aspell (0.6 für den Mac) installiert, habe aber keine Einstellungen dort gefunden, die Aspell mit der richtigen Kodierung zum Laufen brachten. (Screenshot im Anhang)

    Hat überhaupt schon mal jemand Aspell (oder eine andere Rechtschreibung) unter Texclipse auf dem Mac zum Laufen gebracht?
     

    Anhänge:

  2. skuZz

    skuZz Rheinischer Krummstiel

    Dabei seit:
    30.12.07
    Beiträge:
    377
    zur Verwendung von Aspell in Texclipse kann ich dir leider keine Auskunft geben. Wo liegt genau das Problem? läuft aspell überhaupt nicht?

    Vll hilft dir das programm weiter: cocoaspell Hier kann man die Rechtschreibung unter den Preferences steuern.
     
  3. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    Leider weiß ich nicht mehr, mit welcher Einstellung ich aspell schon einmal zum Laufen gebracht habe. Leider hatte ich damals das Problem, dass alle Wörter mit Umlauten trotz der richtigen Codierungsangabe (utf-8) nicht erkannt wurden.

    Aktuell bekomme ich in Eclipse (mit Texclipse) folgende Fehlermeldung:
    running: /usr/local/bin/aspell -a -t --lang=de --encoding=utf-8
    aspell> Error: No word lists can be found for the language "de".

    cocoaspell in der Version 2.1 ist installiert und in den Systemeinstellungen ist German als Dictionary aktiviert. Auch andere Parameter wie z.B. de_DE oder deutsch auch in Kombination mit anderen Aspell-Einstellungen (German(German)) habe ich schon ausprobiert.
     
  4. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    wahrscheinlich muss ich mit

    --dict-dir=<directory>
    Location of the main dictionary word list.

    das Verzeichnis der word-lists angeben - wenn ich das nur fände ...
     
  5. skuZz

    skuZz Rheinischer Krummstiel

    Dabei seit:
    30.12.07
    Beiträge:
    377
    ich hatte ebenfalls Probleme mit der Verwendung von Lyx, und zwar wurde die Datei "german.alias " im verzeichnins "/usr/local/lib/aspell-0.60/" nicht gefunden. überprüf das mal ob die vorhanden ist.

    um ins /usr/ verzeichnis zu kommen musst du die versteckten datein sichtbar machen.

    wenn die "german.alias" nicht vorhanden ist, dann ziehst du die "deutsch.alias" auf deinen Schreibtisch, nennst sie in "german.alias" um und schiebst sie wieder in den ordner zurück! damit war mir sehr geholfen!
     
  6. skuZz

    skuZz Rheinischer Krummstiel

    Dabei seit:
    30.12.07
    Beiträge:
    377
    evtl hilft dir das weiter Link
     
  7. skuZz

    skuZz Rheinischer Krummstiel

    Dabei seit:
    30.12.07
    Beiträge:
    377
    Was mir grad aufgefallen ist, welche Zeichencodierung verwendest du?
     
  8. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    Der Link hat mir insofern geholfen, als dass ich durch den darin beschriebenen compilier-Vorgang das ganze wieder zum Laufen brachte. Allerdings wurden die Umlaute nun wieder falsch erkannt.

    Das Dokument ist in utf-8 kodiert und aspell läuft mit der Option --encoding=utf-8. Die Version 0.6 von Aspell sollte auch mit utf-8 zurecht kommen. Zumindest erhalte ich auch keine Fehlermeldung - bis auf angemeckerte öäüÖÄÜ etc.
     

Diese Seite empfehlen