1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

ArchLinux auf externe HDD

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von nathanhi, 10.06.08.

  1. nathanhi

    nathanhi Braeburn

    Dabei seit:
    29.04.08
    Beiträge:
    44
    Hallöle, bin neu hier, hab hoffentlich das richtige Unterforum erwischt :D

    Es geht um folgendes Problem: Ich wollte mir auf die Externe HDD (500GB) Linux knallen. Da da aber noch Daten drauf sind und die sowieso Partitioniert ist, hab ich eine Partition freigeräumt und gleich mit der Installation angefangen. Ging auch alles soweit fehlerfrei, jedoch wohin muss ich GRUB schreiben lassen? Linux liegt auf sdb4 und ich habs vorhin weinfach in den MBR von sdb geschrieben. Will halt einfach die HDD anstecken und dann die Alt-Taste gedrückt halten beim Booten und da die Externe auswählen können. Sollte denke ich mal möglich sein, oder?

    Grüße,
    Nathan
     
  2. tfc

    tfc Ontario

    Dabei seit:
    21.07.07
    Beiträge:
    348
    Ja, sollte mit der Taktik möglich sein.
     
  3. nathanhi

    nathanhi Braeburn

    Dabei seit:
    29.04.08
    Beiträge:
    44
    Hat mir nur leider nix gebracht die Antwort :-x


    Wohin muss sich GRUB schreiben? sdb4 oder mbr von sdb oder irgendwie ganz anders?Hab GRUB in SDB4 und SDB geschrieben, beides ohne Erfolg. Hat keiner Lust mir zu helfen?

    Grüße,
    Nathan
     
    #3 nathanhi, 11.06.08
    Zuletzt bearbeitet: 11.06.08
  4. tfc

    tfc Ontario

    Dabei seit:
    21.07.07
    Beiträge:
    348
    Eigentlich schreibt man den Bootloader in die Linuxpartition die Du booten willst.

    rEFIt sucht sich den dann raus und zeigt diese Partition mit Tux-Logo an.

    Wie sieht Dein nicht-Erfolg aus? Passiert das was ich eine Zeile höher erwähnt habe nicht?
     
  5. nathanhi

    nathanhi Braeburn

    Dabei seit:
    29.04.08
    Beiträge:
    44
    Der Tux wird angezeigt, kann ihn auch anwählen, aber es kommt einfach ein blinkendes _...

    Grüße,
    Nathan
     
  6. tfc

    tfc Ontario

    Dabei seit:
    21.07.07
    Beiträge:
    348
    Kann natürlich sein, dass den das stört, dass Du den Bootloader in SDB und SDB4 geschrieben hast...
     
  7. simsimsim

    simsimsim Erdapfel

    Dabei seit:
    14.06.08
    Beiträge:
    3
    Hallo, ich habe das selble Problem.

    Installiert habe ich Linux auf eine Partition der internen Festplatte, GRUB habe ich nur auf die Partition installiert, nicht in den MBR.

    Ich benutze ebenfalls Arch Linux, vielleicht liegt das Problem hier?

    Ueber Hilfe wuerde ich mich freuen.

    MfG
     
  8. nathanhi

    nathanhi Braeburn

    Dabei seit:
    29.04.08
    Beiträge:
    44
    An Archlinux kann es nicht liegen, weil GRUB überall verwendet wird. Hab ja auch schon LILO getestet, bringt aber nichts. Mit Ubuntu das selbe. Ich weiß nur, dass ich mir zuvor die Partitionen am Mac versaut hab und jetz Bootcamp mit Vista nicht rennt :D Naja heißt dann wohl neu aufsetzen.
     
  9. Irgendein Held

    Irgendein Held Oberösterreichischer Brünerling

    Dabei seit:
    17.06.07
    Beiträge:
    714
    Wenn du GRUB auf die richtige Partition installiert, dann verschwindet auch dein blink-Teil.
    Nur riechen kann die hier niemand - aber du weiß ja sicher welche Partition es ist, und es ist jedem besseren Tutorial sogar drin wie es geht.
     
  10. MACiMessa

    MACiMessa Bismarckapfel

    Dabei seit:
    06.04.08
    Beiträge:
    141
    Wenn du Linux von einer externen Platte booten möchtest, dann muss normalerweise GRUB in den MBR der externen Platte geschrieben werden (also hier : /dev/sdb). Wichtig ist allerdings, dass vorher bei der Einrichtung der Platte für den Mac, für die externe Platte dann auch der Partitionstabellentypus "MBR" im Festplattendienstprogramm ausgewählt wurde; sonst kann das Ganze nicht funktionieren.
     
  11. simsimsim

    simsimsim Erdapfel

    Dabei seit:
    14.06.08
    Beiträge:
    3
    Ich weiß zwar nicht wen du mit "du ansprichst, aber ich habe Grub auf /dev/sda5 installiert, also meine root-Partition. Das Problem besteht trotzdem :(

    Edit:
    Was ich noch hinzufuegen will, auch wenn ich nicht weiß ob dies von bedeutung ist:
    Mac OS-X habe ich nicht installiert, nur Windows und Arch.

    Mal meine Partiotionen:

    /dev/sda (MBR only)

    /dev/sda1 HFS+ (rEFIt)
    /dev/sda2 fat23 (Windows XP)
    /dev/sda3 SWAP
    /dev/sda4 extended
    /dev/sda5 ext3 (Arch Linux / + GRUB)
    /dev/sda6 ext3 (Arch Linux /home)
    /dev/sda7 ext3 (Datenpartiotion)

    Ausserdem ist mir aufgefallen, dass das rEFIt-Partitioning Tool nur die ersten 4 anzeigt. aber die 4te korrekt als Extended erkennt.

    Liebe Gruesse
     
  12. simsimsim

    simsimsim Erdapfel

    Dabei seit:
    14.06.08
    Beiträge:
    3
    So, hab den Fehler behoben. REFit kann nur von primaeren Partitionen booten.
     

Diese Seite empfehlen