1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Aperture 3 legt (fast) den ganzen Mac lahm - Probleme

Dieses Thema im Forum "Fotosoftware" wurde erstellt von Mr. Muchacho, 11.02.10.

  1. Mr. Muchacho

    Mr. Muchacho Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    27.08.07
    Beiträge:
    244
    Hallo liebes Apfeltalk,

    ich habe nun endlich auch Aperture 3 und habe mich schon zu früh über die Schnelligkeit und eine neue herausragende Bedienung gefreut. Anstatt mich darüber eben nun zu freuen, bin ich nun fast 1 Tag am probieren, wie ich ein Problem lösen kann. Ich hoffe ihr seid mir behilflich, damit ich den Rest meiner Ferien nicht mit der Problemsuche verbringen muss.

    Von Aperture 2 wurden ca. 4000 Bilder in Aperture 3 importiert mit allem drum und dran. Alles schön und gut, gestern habe ich auch unter heftigen getöse der Lüfter an meinem MacBook Pro die Personen mehr oder weniger sortiert (Faces namen gegeben). Mit der Personensuche ist er nicht fertig geworden, daher habe ich den Mac dann über Nacht laufen lassen.

    Als ich morgens auf den Bildschirm schaute war mein Festplattenspeicher auf 0KB (von zuvor verfügbaren 50GB). Es stellte sich nach einigen Versuchen heraus, dass Aperture einen virtuellen Speicher anlegte und so meine Festplatte total belegte.

    Nun ja, also wollte ich den Mac entlasten, in dem ich nun "Faces" deaktiviere (und später auch meine Bilderordner löschte, so dass "nur" 30GB Bilder verarbeitet werden mussten). Aperture meinte trotzdem, er müsse "die Mediathek aktualisieren" (siehe dazu auch Screenshot), beim Laden wird der Begriff "Verarbeiten" genannt.

    Nun gut, lasse ich eben Aperture verarbeiten... aber das Ganze läuft dann wieder darauf hinaus, dass mein Festplattenspeicher leer geräumt wird, ich das Programm beenden muss und dann wieder wie am Anfang da stehe.

    Was nun? Die Prozesse lassen sich nicht wirklich beenden/aufheben, mein Mac hängt sich ziemlich schnell auf. Meist dann auch Firefox, sollte dieses Programm währenddessen aktiv sein.


    Hilfe! Karma winkt und ein großes Dankeschön!
     

    Anhänge:

  2. j@n

    j@n Eierleder-Apfel

    Dabei seit:
    03.01.07
    Beiträge:
    1.228
    Was steht unter Aperture > Fenster > Aktivität einblenden ?
     
  3. Mr. Muchacho

    Mr. Muchacho Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    27.08.07
    Beiträge:
    244
    Hi j@n,

    dort steht Mediathek aktualisieren / Verarbeiten / "1 Objekte bearbeiten". / 0 von 1.

    Grüße
     
  4. j@n

    j@n Eierleder-Apfel

    Dabei seit:
    03.01.07
    Beiträge:
    1.228
    Das ist ja nichtssagend. ;) Ich selbst hatte das Problem noch nicht, aber ich bin bisher auch noch nicht dazu gekommen, Aperture 3 tiefergehend auszuprobieren.
    Unter Aperture 2 habe ich die Erfahrung gemacht, dass es gerne mal zu Problemen führt, wenn Aperture große Dateimengen auf einmal bearbeiten soll. Du hast vermutlich alles am Stück importiert, nehme ich an? Ich weiß nicht, ob es was nutzt, aber versuch doch mal eine neue Library anzulegen und dort mal nur ein paar hundert Bilder am Stück zu importieren und zu verarbeiten.
     
  5. Mr. Muchacho

    Mr. Muchacho Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    27.08.07
    Beiträge:
    244
    Ja, leider - jetzt Verarbeitet er auch wirklich mehrere Objekte, und da geht es wenigstens voran! Juhu!

    Aaaaaber: Was soll denn das, Apple? Ich meine, was machen die Leute, die 40.000 Bilder und mehr haben? Ihr Geld damit verdienen? Alle Bilder neu sortieren wäre da ein Desaster.

    Und: Meine ganze Bildbearbeitungen sind verloren. :( Kann man diese irgendwie wiederherstellen? Ich habe eine alte Sicherungskopie, möchte aber meine bisherige Struktur beibehalten, es sollen also nur die gemachten Bildbearbeitungen angewendet werden.

    Grüße
     
  6. frei1533

    frei1533 Jonagold

    Dabei seit:
    07.11.09
    Beiträge:
    18
    Hallo
    Habe gestern abend meine Libray (50GB) auf mein MacBookPro Importiert, hat alles Super Funktioniert.
    Starte doch dein Book mal neu, öffne Aperture und lasse es erst mal alles Verarbeiten was es Denkt Ver arbeiten zu müssen.
    In dieser zeit solltest du das Book nicht mehr weiter belasten.
    Gruss Michael
     
  7. helmi2k

    helmi2k Bismarckapfel

    Dabei seit:
    25.12.08
    Beiträge:
    142
    Diese Aktivität die in diesem Fenster beschrieben wird bezieht sich glaube ich auf die Gesichtserkennung und Thumbnailerstellung. Kann schon mal einige Stunden dauern (je nach Größe der Datenbank). Wenn der Vorgang abgeschlossen ist, müsste Aperture um einiges flüssiger laufen.
     
  8. Mr. Muchacho

    Mr. Muchacho Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    27.08.07
    Beiträge:
    244
    Ich habe Aperture die ganze Nacht durchlaufen lassen und nichts am Macbook gemacht. Habe alle behindernden Prozesse ausgeschalten und nichts nebenher gemacht (ich habe ja geschlafen).
    Jedoch nimmt mir Aperture den ganzen virtuellen Festplattenspeicher weg, so dass der Vorgang "zeitlich begrenzt" ist und letztendlich gezwungenermaßen aufhören muss.

    Ich habe jetzt zwar eine neue Mediathek erstellt, aber ich fände es dennoch super, wenn wir eine Lösung finden. Der ein oder andere wird vielleicht auch hier seine Probleme bekommen.
     
  9. frei1533

    frei1533 Jonagold

    Dabei seit:
    07.11.09
    Beiträge:
    18
    Wie Gross ist deine Libray?
    Wieviel Platz hast du noch auf deiner Platte?
    Aperture benötigt schon recht viel Speicher.
    Beispiel: Libray 50 GB, HDD 40 GB = geht nicht
    Für eine 50 GB Libray würdest mindestens 52.51 GB freien Platz benötigen.
     
  10. Mr. Muchacho

    Mr. Muchacho Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    27.08.07
    Beiträge:
    244
    Meine Mediathek ist 4GB groß. Die Bilder sind extern gespeichert und befinden sich nicht in der Mediathek, sondern ganz "normal" auf der Macintosh HD, 40GB groß.

    Ich habe nun eine neue Mediathek erstellt, mit welcher ich auch schon alle Gesichtserkennungen gemacht habe. Alles super soweit, außer: Meine Arbeitskopien sind da nicht mehr drin. Ich habe noch die alte Libary. Wie "schreibe" ich die Fotobearbeitungen (also die Arbeitskopien) auf meine neue Mediathek, ohne eine fertige Bildatei zu erzeugen?
    Kurz: Ich möchte die alten Arbeitskopien von der alten Mediathek auf meine neue Mediathek übertragen, ohne Bilder zu erzeugen - ich möchte auch Änderungen auf meiner neuen Mediathek rückgängig machen, was ja nur geht, wenn ich die Arbeitskopien nicht exportiere. Bei der ganzen Aktion sollten auch wirklich nur die Arbeitskopien übernommen werden, und nicht die Ordnerstruktur, da sich meine jetzige total von der alten unterscheidet.
     
    #10 Mr. Muchacho, 13.02.10
    Zuletzt bearbeitet: 13.02.10
  11. phkl

    phkl Niederhelfenschwiler Beeriapfel

    Dabei seit:
    19.10.07
    Beiträge:
    838
    Ich habe gestern meine "Hauptbibliothek" (~600GB) auf einmal importiert. Mein iMac musste zwar ganz schön "stöhnen" und ich hatte schon Angst, die Lüfter drehen durch aber nach ungefähr einem Tag war alles fertig... (via Firewire 800)
     
  12. chabodeluxe

    chabodeluxe Boskoop

    Dabei seit:
    23.04.06
    Beiträge:
    41
    Ich habe ein Ähnliches Problem, möchte aber keinen neuen Fred öffnen.

    Bei jedem Neustart von Aperture werden immer und immer wieder 168 Objekte verarbeitet. Ich habe weder neue Bilder hinzugefügt noch etwas geändert. Weiß evtl. jemand was das sein kann? Siehe Bild.

    Kann man irgendwie rausbekommen, welche 168 Objekte jedes mal nach dem Starten "verarbeitet" werden und auch was in diesem Fall verarbeiten bedeutet?


    edit: Problem gelöst. Aperture mit CMD-ALT gestartet, Zugriffsrechte und Datenbank repariert und anschließend noch die Mediathek wieder hergestellt. Danach ging alles wieder ohne dass die 168 Objekte verarbeitet werden. :D
     

    Anhänge:

    #12 chabodeluxe, 14.03.10
    Zuletzt bearbeitet: 15.03.10
  13. buessel

    buessel Weißer Winterglockenapfel

    Dabei seit:
    25.04.09
    Beiträge:
    889
    Irgendwie klingen Eure Probleme nicht ursächlich nach Aperture Problemen.
    Was habt Ihr denn für eine Hardware? Welches OS?
    Wenn man die Gesichtserkennung über eine komplette Library laufen läßt, kann einem das den Rechner schon einige Stunden lahmlegen.
    Aber eine Bibliothek mit "nur" 4000 Bildern ist für Aperture wirklich nichts. Wie auch phkl bestätigt hat, kann Aperture problemlos mit wesentlich größeren Bilbliotheken umgehen.
    Allerdings ist Aperture 3 schon recht anspruchsvoll.
    Es sollte schon Snow Leo auf dem Rechner sein.
    Es muß ausreichend freier Festplattenplatz vorhanden sein und der Arbeitsspeicher sollte auch nicht zu knapp bemessen sein. (Besser 4GB als 2 GB). Gut ist auch eine schnelle Grafikkarte mit viel eigenem Speicher.
    Wenn Ihr eine langsame Festplatte habt, die fast voll ist kann Aperture den Rechner schon lahm legen.

    Natürlich importiert Aperture 3 auch die Arbeitskopien von Aperture 2. Wäre ja furchtbar, wenn die verloren gehen würden!

    Wenn Aperture bei jedem Neustart irgend etwas Aufwendiges verarbeiten muß, dann bedeutet das, daß irgendwelche Arbeiten beim letzten Beenden von Aperture noch nicht abgeschlossen waren, oder daß die Vorschaubilder neu berechnet werden. Drück einfach mal "p". Wenn die Verarbeitung dann aufhört liegt es tatsächlich am Berechnen der Vorschau.
    Versucht mal die Gesichtserkennung abzuschalten und die Vorschaubilder etwas kleiner zu wählen.
    Wenn es dann immer noch nicht flüssiger wird, arbeitet Euer Rechner an seinen Grenzen, oder die Library ist irgendwie fehlerhaft.
     
  14. chabodeluxe

    chabodeluxe Boskoop

    Dabei seit:
    23.04.06
    Beiträge:
    41
    Des weiteren ist mir aufgefallen, dass nach jedem Aperture Start und dem "verarbeiten" der 168 Objekten, Time Machine ein Update von 266 mb macht.

    Jedes mal, bei jedem verdammten Start von Aperture sind es die erwähnten 168 Objekte und auch 266 mb. :(
     
  15. Bissy

    Bissy Johannes Böttner

    Dabei seit:
    03.02.07
    Beiträge:
    1.159
    Also bei mir hat Aperture 3 auch ewig lange "Verarbeiten" angezeigt. Da ich das nicht gleich bemerkt hatte, habe ich es erstmal damit abgetan, dass das Programm nichts taugt, weil es total langsam war (EXTREM!). Als er dann aber mal fertig verarbeitet hatte, wurde es wirklich normal bedienbar.

    Zu deinem Problem: Bei mir hat das wie gesagt auch gedauert, lief die Nacht durch. Allerdings habe ich noch knapp 900GB frei und die werden glaub ich selbst bei 70GB Fotos nicht voll laufen.

    Hast du schon mal versucht, die Mediathek auf eine externe Platte zu lagern? Das wäre so die Einzige Möglichkeit, die ich sehe...
     
  16. NoaH11027

    NoaH11027 Weisser Rosenapfel

    Dabei seit:
    14.03.06
    Beiträge:
    777
    Bei mir ist es nicht eine, sondern vier mit ~120-150GB, aber meine Erfahrungen sind ähnlich. Ich habe zwei auf dem MacPro konvertiert und zwei auf dem MacBook Pro. Abgesehen davon das mein MacPro deutlich schneller war, hat das bei beiden problemlos funktioniert. Es muss halt die DB konvertiert werden und je nach Einstellungen werden die Vorschauen neu erstellt. Beides kostet Zeit, also nicht panisch werden.

    N
     
  17. sth

    sth Golden Delicious

    Dabei seit:
    20.10.06
    Beiträge:
    11
    Das Problem mit dem enormen Arbeitsspeicherverbrauch wurde in 3.0.1 und dem ProKit-Update vor kurzem gelöst. Aperture 3 ist zwar trotzdem kein Leichtgewicht, aber das extreme Speicher-Leck ist gestopft.
     

Diese Seite empfehlen