1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Apache und XAMPP

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Schomo, 31.08.05.

  1. Schomo

    Schomo Russet-Nonpareil

    Dabei seit:
    15.11.04
    Beiträge:
    3.749
    So ich nu wieder. Folgendes, ich hab mir das Apache Xampp Paket installiert und überlocalhost zu starten versucht. In der shell laufen alle Dienste auch. Doch ich kam nicht zur Startseite sondern zur normalen Apache Startseite, weil ich Depp vergessen hatte den Apache von Os X vorher zu beenden. Ok, dann über die Shell den Xampp wieder beendet mit
    Powerbook-Alu:/Users/XXXXXX root# /Applications/xampp/xamppfiles/mampp stop
    Stopping XAMPP for MacOS X 0.4...
    XAMPP: XAMPP-Apache is not running.
    XAMPP: XAMPP-MySQL is not running.
    XAMPP: XAMPP-ProFTPD is not running.
    XAMPP stopped.

    Apache vom Os X war nicht aktiviert. Neustart. Und was ist der Apache von Os X läuft immer noch. Was geht da ab. Wie kann ich sehen welcher Apache da werckelt?

    Gruß Schomo
     
  2. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    warum willst Du zwei Indianer auf deinem Rechner :oops:.

    Nimm doch den eingebauten, installiere die MySQL (direkt auf MySQL.org gibt's einen Paketinstaller) und PHP (z.B. das Entropy-Paket) und fertig ist. Perl ist eh schon drauf.

    Nachdem ich lange mit MAMP gearbeitet hab war mir das alles zu sehr durch die Brust ins Auge. HomeDir hab ich mir als erstes passend gebogen, dann noch ein paar virtuelle Hosts angelegt, schwuppsdiwupps war der Standard-MAMP bei mir nicht mehr das was er war und auch nicht mehr so einfach in die Tonne zu hauen. Ergo: warun nicht gleich richtig.

    Gruß Stefan
     
  3. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    kann es sein dass das executable-verzeichnis in php.ini des xampp moduls auf den selben pfad zeigt wie er in der php.ini des osx-php interpreter moduls steht?
    das wäre dann /Library/Webserver/Documents/

    lg.c7.
     
  4. Schomo

    Schomo Russet-Nonpareil

    Dabei seit:
    15.11.04
    Beiträge:
    3.749
    Mein Gott vielen Dank,

    der Trick war der, dass ich einen localhost Drucker eingerichtet hatte für den Distiller. ARRRRGGGGLLLL.

    Generell bin ich eine faule kleine Ratte ;.)

    Gruß Schomo
     
  5. Sputnik

    Sputnik Zwiebelapfel

    Dabei seit:
    15.10.04
    Beiträge:
    1.284
    Ansonsten kann ich Dir noch den MAMP empfehlen... der ist so ähnlich, läuft sehr stabil und hat wenigstens ne bunte Oberfläche... also Mac like! :-D
     
  6. Schomo

    Schomo Russet-Nonpareil

    Dabei seit:
    15.11.04
    Beiträge:
    3.749
    XAMPP und der Websites Ordner

    Da hol ich meinen Fred doch mal aus der Versenkung!

    Folgendes Problem.

    Um meine ganzen Websites nutzen zu können ohne Sie in den htdocs Ordner zu schmeissen (was aus unerfindlichen Gründen nicht geht) habe ich die httpd.conf Datei soweit geändert, dass ich die 2 Documentroots in den Websites ordner umgleitet habe.

    (mit sudo su und dann mit pico geändert)

    DocumentRoot "/Users/schomo/Sites"

    <Directory "/Users/schomo/Sites">

    dummerweise findet Apache aber die Seiten übder localhost nicht.

    Hab ich was vergessen?
     
  7. Schomo

    Schomo Russet-Nonpareil

    Dabei seit:
    15.11.04
    Beiträge:
    3.749
    Man bin ich doof, ich musste natürlich den Apache neu starten...blöderweise hängt er beim starten jetzt. Arrrrgl, aber die Seiten funktionieren. Mhhhhh Was soll man da nur machen?

    Gruß Schomo
     

Diese Seite empfehlen